Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cat 4507 layer 3 vlan routing

Some help:

I can ping interfaces from Cat4507 but it doesn't route packets between two VLANs. Following is what I have. What am I missing?

vlan 2

name Vlan2

!

vlan 208

name Vlan208

!

interface FastEthernet3/24

switchport access vlan 208

!

interface GigabitEthernet4/1

switchport access vlan 2

!

interface Vlan2

description VLAN2-SIG

ip address 10.18.88.220 255.255.255.240

!

interface Vlan208

description VLAN208-LABRTR

ip address 10.18.88.242 255.255.255.240

!

ip route 0.0.0.0 0.0.0.0 10.18.88.254

8 REPLIES

Re: Cat 4507 layer 3 vlan routing

Do you have IP routing turned on?

Do a show ip route and you should see the directly connected networks (vl 2 & 208) in the routing table.

--Sundar

New Member

Re: Cat 4507 layer 3 vlan routing

yes, Do have IP routing turned on.

10.0.0.0/28 is subnetted, 3 subnets

C 10.18.88.208 is directly connected, Vlan2

C 10.18.88.224 is directly connected, Vlan4

C 10.18.88.240 is directly connected, Vlan208

S* 0.0.0.0/0 [1/0] via 10.18.88.254

#ping 10.18.88.210

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.18.88.210, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

#ping 10.18.88.254

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.18.88.254, timeout is 2 seconds:

!!!!!

I can ping interfaces from Cat4507, but can't ping between VLANS???

Purple

Re: Cat 4507 layer 3 vlan routing

You do have the correct default gateway on your clients correct ??? The clients default gateway has to be the router interface address for the subnet (vlan) they are attached to.

New Member

Re: Cat 4507 layer 3 vlan routing

Yes, I do have correct default gateway

Purple

Re: Cat 4507 layer 3 vlan routing

the only other thing I can think of is to make sure the subnet mask is correct on your clients . Don't see any other reason not to be able to ping between subnets. Can you ping the clients using extending ping sourcing it from one of the other subnets on the router ?? Make sure client ports are setup as switchports and not routed ports .

New Member

Re: Cat 4507 layer 3 vlan routing

"Make sure client ports are setup as switchports and not routed ports", didn't understand. Please explain.

New Member

Re: Cat 4507 layer 3 vlan routing

How do I debug it? any debug cmds?

Purple

Re: Cat 4507 layer 3 vlan routing

On the ports where the clients attach the command "switchport" should be there along with the "switchport access vlan XX" command . The "show interface status" command will tel you if it is a routed port or not .

415
Views
0
Helpful
8
Replies
CreatePlease login to create content