Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Cat2940 upgrade to IOS 12.1(19)EA1 problem

I bought a new Cat2940 (WS-C2940-8TT-S, 20778K bytes of memory, IOS 12.1(13)AY) a month ago.

I tried to upgrade it to IOS 12.1(19)EA1 today.

The upgrade failed with an error message:

"Image info:

Version Suffix: i6q4l2-121-19.EA1

Image Name: c2940-i6q4l2-mz.121-19.EA1.bin

Version Directory: c2940-i6q4l2-mz.121-19.EA1

Ios Image Size: 3006976

Total Image Size: 6039040

Image Feature: LAYER_2|MIN_DRAM_MEG=32

Image Family: C2940

ERROR: Image requires 0x02000000 bytes of DRAM;

only 0x01000000 bytes are present"

Is my understanding correct that Cisco is selling devices which are not upgradable one month after delivery to the customer?

Regards,

Milan

7 REPLIES
Purple

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

It looks like it is either a bug or it really looks like it is only seeing 10 meg of dram instead of the 20 meg that is needed to runn the image . It looks like it only recognizes 10 meg according to the error messages.

New Member

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

I am having the exact same problem, except that I deleted the old IOS image on the switch thinking that would free up enough room, but it didnt. Inadvertently I forgot to plug the switch into a UPS while doing this and we had a power surge and the switch reset. So now I'm transferring the new image to the switch via xmodem. A 5.9mb file at 9600bps per second...it should be done in, oh...2 hours or so, unless there still is not enough room for the image on the switch. Woops.

New Member

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

I just upgraded my 2940-8TT from 12.1(13)AY to 12.1(19)EA1. I couldnt do it through IOS though, I got the 'not enough DRAM' error message as did the first poster. This leads me to believe there is a bug in IOS 12.1(13)AY that prevents upgrading to the new version. Here's how I upgraded my switch:

As mentioned in my post above I had deleted the existing IOS image and tried to use the "archive" command to extract the .tar file to the switch, but it said there was not enough space after. What I was planning on doing then was un-TARing the .tar file on my machine and uploading the individual files via TFTP after I had erased the existing IOS image and directory structure to see if there was enough space for that to happen. However we had a power surge and it reset the switch, forcing me into the boot loader because there was no IOS image. In the boot loader I uploaded the extracted IOS .bin file into the switch via 1k xmodem. This took several hours, but once it was done I reloaded the switch and it booted to the new 12.1(19)EA1 image.

Next step was to upload the CMS files. I created the following directory structure in IOS to mimick what was un-TAR'd onto my system:

c2940-i6q4l2-mz.121-19.EA1

c2940-i6q4l2-mz.121-19.EA1/html

c2940-i6q4l2-mz.121-19.EA1/html/ximages

I copied the IOS image file from the root into the "c2940-i6q4l2-mz.121-19.EA1" directory then deleted the one in the root again to mimick what was un-TAR'd on my machine. Then I had to upload each file via TFTP from the /html dir on my machine to the /html dir on the switch, and do the same for ximages. Once this was done, I rebooted the switch and was able to access CMS.

The files uploaded fine, and there are still 1608192 bytes free. So I'm going to assume there is a bug in the prior version of IOS that prevents uploading. Or perhaps there isnt enough room on the switch for it to take the .tar file and extract it on its own. But I dont know enough about IOS's filesystem to know if this is a possibility.

Either way...Cisco, good job on the QA with this release...

If anyone needs the script I used to upload all 77 individual files email me and I'll send it to you.

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

Hi,

based on your message I've found a more comfortable way (no need to copy html files manually):

1) Clear the flash deleting everything except config.text, private-config.text and vlan.dat using cd, delete *, rmdir commands.

2) Copy c2940-i6q4l2-mz.121-19.EA1.bin to the flash via tftp

3) Reload the switch

4) Delete c2940-i6q4l2-mz.121-19.EA1 from the flash

5) archive download-sw /overwrite tftp://tftp_Server_IP/c2940-i612-tar.121-19.EA1.tar

6) Reload the switch again.

The untar procedure work correctly when the flash is empty.

So I think there is really a bug in the upgrade procedure.

My switch seems to be running IOS 12.1-19.EA1 fine with http access fine now.

Regards,

Milan

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

I opened a TAC case and here is the response:

"It seems there's a problem in the description file in the tar image.

It says it needs 32 meg, when it should say 16 meg.

No bug has been filed yet but a possible workaround is to copy the description file off,

change it to say 16 meg and then copy it back and try to load that image again."

So I untared the c2940-i612-tar.121-19.EA1.tar file, edited the 3 info files included, tared the files back.

And the upgrade procedure worked with no problem with the files modified!!!

So I hope Cisco guys will correct the c2940-i612-tar.121-19.EA1.tar file in CCO Software Center asap.

Regards,

Milan

New Member

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

Bug ID: CSCec11178

Work around provided.

Bug toolkit

http://www.cisco.com/cgi-bin/Support/Bugtool/launch_bugtool.pl

Re: Cat2940 upgrade to IOS 12.1(19)EA1 problem

Hi,

if you read carufully, you'd find that workaround method #2 if very similar to the method I described Nov 23rd 2003.

But what I really don't understand is why the TAC guys don't simlpy correct the info files?

Regards,

Milan

187
Views
4
Helpful
7
Replies
CreatePlease to create content