Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Cat4000 changing it's config

Has anybody noticed a Cat4000 changing it's config?

Two of my Cat4000s running CatOS 7.2(1) are changing config lines concerning set spantree portcost and set spantree portvlancost.

Example:

I've noticed

set spantree portcost 3/7 3100

set spantree portvlancost 3/7 cost 3099

lines in sh config output. I'm sure I've not written them.

The strange thing is that using sh config all the values shown for this port are the same as values shown for other ports which have no output in sh config (i.e. their values are default).

I've got a feeling that the lines even disapear from the sh config output after port disconnecting (I'm not 100% sure).

The only switches with this strange behaviour are two Cat4003 with UplikFast enabled. Is it possible that this is the reason?

Regards,

Milan

2 REPLIES
Cisco Employee

Re: Cat4000 changing it's config

Check to see if Uplinkfast is enabled on this switch. With uplinkfast enabled, the port cost and portvlancost of all ports set to above 3000.

http://www.cisco.com/warp/public/473/51.html

cs-c4003-8a> (enable) set spantree uplinkfast enable

VLANs 1-1005 bridge priority set to 49152.

The port cost and portvlancost of all ports set to above 3000.

Station update rate set to 15 packets/100ms.

uplinkfast all-protocols field set to off.

uplinkfast enabled for bridge.

cs-c4003-8a> (enable)

Re: Cat4000 changing it's config

I know that "With uplinkfast enabled, the port cost and portvlancost of all ports set to above 3000".

But why do I see the portvlancost statement just for some ports in sh config output and why is it changing during the time (some new lines, some are being removed automatically)?

Regards,

Milan

87
Views
0
Helpful
2
Replies
CreatePlease to create content