Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Catalyst 1900 Switch Error

When I telnet to this switch via the console port, when the switch has loaded I get the following line

" ATQ0H0 " and I can not get to the menu options

Any ideas

Thanks

18 REPLIES
Bronze

Re: Catalyst 1900 Switch Error

It looks like the switch is configured to have a modem on the console port.

Can you telnet to the switch via the network? If yes, log in via that way and remove any modem config on line vty 0.

If you can't login via telnet, you can do a password recovery procedure, but instead of changing the password, remove the modem config. Search for "password recovery 1900" on cisco.com.

hth

Herbert

New Member

Re: Catalyst 1900 Switch Error

Thanks for the reply, I have got to the password recover screen not sure how I remove the modem config though

any tips

Regards

Peter

Bronze

Re: Catalyst 1900 Switch Error

It has been a while since I worked with 1900's... Are you at an IOS prompt ("switch>")?

If you find yourself at a menu saying something like

User Interface Menu

[M] Menus

[K] Command Line

then choose K to get to an IOS command line prompt. Then issue the command "show run". This will show the entire configuration of the switch. Somewhere near the bottom is a section that begins with "line console". If you can copy-paste that section here, we can tell what needs to be removed or changed.

hth

Herbert

New Member

Re: Catalyst 1900 Switch Error

I keep getting the following data

Diagnostic Console - Systems Engineering

Operation firmware version: 0.00 Status: Invalid

Boot firmware version: 1.10

WARNING!!! Operation Firmware is invalid.

Upgrade firmware to enable switch operation.

[U] Upgrade operation firmware (XMODEM)

[S] System Debug Interface

Enter Selection:

I have pressed selection [u] to upgrade the firmware and it goes through the steps and then goes back to the above screen each time

Thanks for any help

Bronze

Re: Catalyst 1900 Switch Error

When you say it goes through the steps, do you mean you actually uploaded new firmware to the switch via xmodem?

New Member

Re: Catalyst 1900 Switch Error

Yes I think so, It erases the flash. than asks for the baud rate I choose 9 (for 9600) then a series of $ signs appear. it then goes back to the above screen

(shown in last post)

Thanks

Bronze

Re: Catalyst 1900 Switch Error

I see. Well, when it shows the $ signs, it is waiting for you to upload the firmware image. So when it does that, you need to activate xmodem in your terminal emulator and upload the image.

New Member

Re: Catalyst 1900 Switch Error

I thought ATQ0H0 ment that you are using the wrong RS232 cable. I had the same problem with a 1900 and used a NULL Modem cable to connect to the console port. Was the only way I could update the IOS after it was erased.

New Member

Re: Catalyst 1900 Switch Error

I am a bit new to this. I have a Null modem Cable (I take that is serial) and the switch will not got in to the normal screen where by I can choose K for command line Etc. The screen says to press (u) to upgrade the firmware so I do. After selecting the baud rate a series of dollor signs appear and the it says (down load failed)

Operation firmware version: 0.00 Status: Invalid

Boot firmware version: 1.10

WARNING!!! Operation Firmware is invalid.

Upgrade firmware to enable switch operation.

[U] Upgrade operation firmware (XMODEM)

[S] System Debug Interface

Am I suppose to have a disc or where do I down load the firmware from to get the switch working

An help would be great

Thanks

New Member

Re: Catalyst 1900 Switch Error

Hi,

You can do the upgrade as below:

Press U and in the next menu, press 9 for selecting 9600 as console speed. Then you will get another prompt saying 'waiting for image'.

On the Hyperterminal (the speed should be set as 9600), select 'Send' option under 'Transfer' menu. On the menu choose your file and select XMODEM as the protocol.

This will carry out the upgradation.

Pls. refer the below link for any clarification:

http://www.cisco.com/en/US/products/hw/switches/ps574/products_installation_and_configuration_guide_chapter09186a008007f0fe.html#xtocid129887

New Member

Re: Catalyst 1900 Switch Error

hi,

Thanks for the help. I take it the file that I have to send is the firmware. But I don;t actually have that , can I down load it from anywhere.

hope you can help

Thanks

(how come u dont select Recieve?)

New Member

Re: Catalyst 1900 Switch Error

You can login and download the switch IOS from here: http://www.cisco.com/pcgi-bin/tablebuild.pl/cat1900STD

You want to select "Send" because you will be sending the file to the switch.

Hope this helps.

New Member

Re: Catalyst 1900 Switch Error

Thanks for the downloads, but each time I try to send the file to the switch I get this message

"Transfer Cancelled by remote System"

Any Ideas

Thanks

New Member

Re: Catalyst 1900 Switch Error

You are getting the message bcoz u have not initialised the switch to accept the xmodem command.

Use the following command in the switch while transfering using xmodem.

copy xmodem: flash:image_filename.bin

Please refer the URL below:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2970/12111ax/2970scg/swtrbl.htm

New Member

Re: Catalyst 1900 Switch Error

how do I type in the command though, as soon as I turn the switch on I get an orange light and then the following screen appears

Operation firmware version: 0.00 Status: Invalid

Boot firmware version: 1.10

WARNING!!! Operation Firmware is invalid.

Upgrade firmware to enable switch operation.

[U] Upgrade operation firmware (XMODEM)

[S] System Debug Interface

New Member

Re: Catalyst 1900 Switch Error

Try all the options as described in the below URL. It clearly mentions a message

"WARNING!!! Operation Firmware is invalid."

http://www.cisco.com/univercd/cc/td/doc/product/lan/28201900/1928v5x/icg5x/cstrbl.htm

Bronze

Re: Catalyst 1900 Switch Error

Just a guess: perhaps you are not fast enough?

When the dollar signs appear you have to select Transfer - Send and then choose the file, before the switch stops displaying the dollarsigns and says download failed.

New Member

Re: Catalyst 1900 Switch Error

I have tried all of the above and still it refuses to transfer the file

Any other suggestions

Thanks

615
Views
0
Helpful
18
Replies
CreatePlease to create content