Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Catalyst 2924 issues

I have a Catalyst 2900 series (model WS-C2924C-XL) switch that I wanted to update the software on. I downloaded c2900XL-c3h2s-mz.120-5.WC2.tar, which is evidently the WRONG software to put on this model switch, and after I loaded it and rebooted the switch, I could no longer manage the switch via Web Browser, but I could still Telnet to it. I had backed up the previous software but inadvertantly deleted it in the process.

So my only alternative that I saw was to load the ORIGINAL 4Mb software for the switch (c2900XL-hs-mz-112.8.6-SA6.tar). After I got that successfully loaded, I had to re-configure the switch, and it never prompted me for a Telnet password, only a "secret" Administrative password. I can now manage it via the web browser again, but now I can't telnet to the switch. When I try to Telnet, i get "Password required, but None Set".

So my questions are:

1. What is the latest version of software for this switch and/or how do I find the previous version that was on here before I messed it up? (It's not listed on site!)

2. How do you recover a TELNET password? Does it have something to do with the version of software that I installed on the switch?

1 REPLY
Community Member

Re: Catalyst 2924 issues

just do this from the console port:

prompt>en

prompt# conf t

prompt# line vty 0 4

prompt# password "yourpass"

that will set your telnet pass. it is recommended that you use your command line to config switches and turn off the web admin for cisco devices.

199
Views
0
Helpful
1
Replies
CreatePlease to create content