Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 2948G-L3 inter-Vlan routing

Hi,

I need to configure the Catalyst 2948G-L3 into 4 VLANs all using different IP segement. The question is how do I route from one VLAN Segment out to the other? I know we can configure a default gateway for the switch, but can we define a default gateway for each VLAN? Where should we route to? All I need is to setup 4 VLANs on the switch. There's no need for any trunk link at all. I'll just connect the other switches directly to 2948G L3 ports with no trunk link. Is this a good way? I've look through the sample configuration on the web for 2948G L3, but it doesn't meet my need.

Thanks.

Gim Siong

7 REPLIES

Re: Catalyst 2948G-L3 inter-Vlan routing

Use bridge irb and route between BVIs (Bridge Virtual Interfaces - groups of ports which are brindging each to the other but routing to the other BVIs).

HTH,

Milan

New Member

Re: Catalyst 2948G-L3 inter-Vlan routing

That mean, I've to group say port 1 to 10 as one BVI and 11 to 30, 31 to 40 and 41 to 48 as the other. So each BVI can have its own subnet. By doing this I'll have 4 VLANs? So what do I set for the default gateway for each BVIs or subnet? Do I have to manually specific the route? Do you have any sample on this? Thank you and have a merry Christmas.

Re: Catalyst 2948G-L3 inter-Vlan routing

See http://www.cisco.com/univercd/cc/td/doc/product/l3sw/4908g_l3/ios_12/7w515d/config/bridging.htm - a good expplanation.

I've created an example of config for you. This is for two VLANs (ports 1-4 and 5-8) with a default gateway (router) in one of them and one static route through a router in the other one. Don't think about default gateways in each VLAN - this is more router then switch configuration, so you define one default gateway for the whole router via route 0.0.0.0 0.0.0.0 command.

Regards,

Milan

!

version 12.0

no service pad

service timestamps debug datetime

service timestamps log datetime

ip subnet-zero

bridge irb

!

!

!

interface FastEthernet1

no ip address

no ip directed-broadcast

bridge-group 2

!

.

.

!

interface FastEthernet4

no ip address

no ip directed-broadcast

bridge-group 2

!

interface FastEthernet5

no ip address

no ip directed-broadcast

bridge-group 3

!

.

.

.

interface FastEthernet8

no ip address

no ip directed-broadcast

bridge-group 3

!

!

interface BVI2

ip address 10.2.0.0 255.255.0.0

no ip redirects

no ip directed-broadcast

!

interface BVI3

ip address 10.3.0.0 255.255.0.0

no ip redirects

no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.2.1.1

ip route 10.4.0.0 255.255.0.0 10.3.1.1 permanent

bridge 2 protocol ieee

bridge 2 route ip

bridge 3 protocol ieee

bridge 3 route ip

New Member

Re: Catalyst 2948G-L3 inter-Vlan routing

Milan:I did have a situation very similar to this but wanted to create only two VLANs, I already configured two different BVI interfaces and separated some fast ethernet ports to bridge-group 1 and others for bridge-group 2. This works OK with static IPs. Do you have any idea how I can enable DHCP in this switches in order to have only one DHCP server to assign addresses to both ip segments? I just tried using command ip bootp server (which apparently enables bootp, but this did not work. DHCP server works OK but only assings IPs to the same segment it belongs to. I connect catalists 3548 to the 2948 and neither stations connected to these switches are assigned an IP (only if the 3548s belong to the same VLAN segment than the DHCP server is. I am desperate. Do you have any suggestion? I´d really appreciate your help and sorry for interrupting you.

Thanks, Socorro Guerrero.

New Member

Re: Catalyst 2948G-L3 inter-Vlan routing

first you have to setup your dhcp server right and add the ip-helper command.

New Member

Re: Catalyst 2948G-L3 inter-Vlan routing

Hi Milan,

this means that after creating the 2 BVIs, I could connect switches(with PCs connected) to the BVIs Ports as though they are in 2 physical device(and subnet) connected by a router. One thing to clearified is that do all the PCs in the BVI have to set their default gateway to the BVI interface ip address in order to route to other subnet?

As for the Windows login, all I have to do is to setup WINS for the PC to login into the Windows Server if they are in a different BVIs right?

Thanks a lot.

Regards,

Gim Siong

New Member

Re: Catalyst 2948G-L3 inter-Vlan routing

yes you would have to set the pc's default gateway to the bvi interface ip address this will allow the pc's to know where to send data dest. for another subnet. info found for what you need is at http://www.cisco.com/warp/public/473/40.html

925
Views
0
Helpful
7
Replies
CreatePlease login to create content