Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 2950T Bandwidth Limiting fails big time

I have tried a few diferent configurations of the C2950T switch in order to have it limit the bandwidth on a given interface. So far in vain.

I first created a profile that limited all incomming packets on fa01 to 1mbps - 4kbps burst - with some success. However, the actual throughput was no way near the 1mbps limit. Not even avage throughput calculations could explain how a 1 mbps limit would allow only about 40-60kBps. I then raised the limit to 2mbps - 4kbps burst - and to my surprise, I saw the actual throughput drop to about 28kBps.

I then consulted this site looking for explanations or guidelines on how to configure the switch properly, just to find an example showing how to do things exactly the way I did it.

Does anyone have any experience on the QoS-configuration and who ran into similar problems?

The test-setup was

2 servers directly connected through the C2950T. No uplink to anything else. Servers running FreeBSD, standard ftpd.

Config of C2950T

class-map match-all testclass1

match access-group 1

!

policy-map testpolicy1

class testclass1

police 1000000 4096 exceed-action drop

!

access-list 1 permit any

!

At the second test - resulting in lower throughput

class-map match-all testclass1

match access-group 1

!

policy-map testpolicy1

class testclass1

police 2000000 4096 exceed-action drop

!

access-list 1 permit any

!

Version info

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(11)EA1, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Wed 28-Aug-02 10:25 by antonino

Image text-base: 0x80010000, data-base: 0x80528000

It all seems extremely simple, and I really cant see what on earth Im doing wrong. Least to say, why on earth the bandwidth drops when I increase the limit?!?

3 REPLIES
Silver

Re: Catalyst 2950T Bandwidth Limiting fails big time

What is the time interval configured on your interface ?

You may be hitting the limit and not realizing it , the load intervals on the interfaces (default 5 minute)are just an average , you may be peaking above it .

try to change the setting to load-interval 30

New Member

Re: Catalyst 2950T Bandwidth Limiting fails big time

Ok, I've now set the load-interval to 30 seconds, but still without any effect. I'll give you a little more information.

I've created two policy-maps, each using a diferent class-map:

class-map match-all testclass1

match access-group 1

class-map match-all testclass2

match access-group 1

!

!

policy-map testpolicy2

class testclass2

police 4000000 8192 exceed-action drop

policy-map testpolicy1

class testclass1

police 2000000 4096 exceed-action drop

!

....

access-list 1 permit any

!

Ok, I then try to set up int fa0/1 with service-policy 1 (testpolicy1)

Test#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Test(config)#int fa0/1

Test(config-if)#service-policy input testpolicy1

Test(config-if)#end

Test#wr

Building configuration...

19:45:59: %SYS-5-CONFIG_I: Configured from console by console[OK]

Ok, that should do the trick. I already set the load-interval to 30 as suggested.

A show conf reveals:

class-map match-all testclass1

match access-group 1

class-map match-all testclass2

match access-group 1

!

!

policy-map testpolicy2

class testclass2

police 4000000 8192 exceed-action drop

policy-map testpolicy1

class testclass1

police 2000000 4096 exceed-action drop

!

....

interface FastEthernet0/1

no ip address

load-interval 30

duplex full

speed 100

service-policy input testpolicy1

no cdp enable

.....

access-list 1 permit any

Great ... everything seems in order now. I'll go on and try with a simple binary FTP-transfer. (There are two servers connected to the switch and nothing else. No other services taking up bandwidth at all)

After 5 minutes (a little more than the 30 seconds, just to ensure that avarages are more precise) I terminate the transfer and gets:

881832 bytes received in 303.79 seconds (2.83 KB/s)

Not exactly the 2mbps I should rightfully achieve according to the service-policy. Well ... let's see what happens if I use service-policy testpolicy2 insted. This should double the bandwidth if everything works as expected.

Test#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Test(config)#int fa0/1

Test(config-if)#no service-policy input testpolicy1

Test(config-if)#service-policy input testpolicy2

Test(config-if)#end

Test#wr

Building configuration...

19:57:53: %SYS-5-CONFIG_I: Configured from console by console[OK]

A show conf then reveals:

class-map match-all testclass1

match access-group 1

class-map match-all testclass2

match access-group 1

!

!

policy-map testpolicy2

class testclass2

police 4000000 8192 exceed-action drop

policy-map testpolicy1

class testclass1

police 2000000 4096 exceed-action drop

!

...

interface FastEthernet0/1

no ip address

load-interval 30

duplex full

speed 100

service-policy input testpolicy2

no cdp enable

...

access-list 1 permit any

...

Great ... let's have another go at the FTP-transfer and see what happens....

Again I'll let it run for 5 minutes before I abort the transfer.

2266120 bytes received in 303.99 seconds (7.28 KB/s)

Ok, this time I actually saw an increase in the bandwidth, but still, there seems to be quite some inconsistency in the bandwidth I should expect, and the bandwidth I actually do see.

Ofcourse, I could simply alter the bandwidth to have it fit what I need, but it seems a bit strange that I have to do bandwidth tests to find out how to hit a bandwidth limit of let's say 2mbps. It might be, I have to have it configured to about 60mbps to actually get a 2mbps limit? Is this really the case?

Does anyone here have positive experience with using the bandwidth limitation on the C2950T? If so, can I have a peak at the relevant parts of the config?

Thanks in advance

Service Engineer

Casper Niebe

Arrownet A/S

Denmark

New Member

Re: Catalyst 2950T Bandwidth Limiting fails big time

I have a same problem last time. We use cat2950t for our subscribers in the building. Subscriber connected to the ethernet port and we offer 128,256,512,1024 kbps. We did the policy map and play around the figures. We use qcheck software just to see the bandwidth and speed between customer LAN port to our Network point. ( tested conducted in LAB)

U can try our config.

User Access Verification

Password:

floor_sw_1_ctss>en

Password:

floor_sw_1_ctss#

floor_sw_1_ctss#

floor_sw_1_ctss#sh run

Building configuration...

Current configuration : 3547 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname floor_sw_1_ctss

!

enable secret xxxxx

enable password xxxx

!

!

class-map match-all 2048kbps

description 2048kbps

match ip dscp 0

class-map match-all 1536kbps

description 1536kbps

match ip dscp 0

class-map match-all 1024kbps

description 1024kbps

match ip dscp 0

class-map match-all 128kbps

description 128kbps

match ip dscp 0

class-map match-all 256kbps

description 256kbps

match ip dscp 0

class-map match-all 512kbps

description 512kbps

match ip dscp 0

!

!

policy-map 2048kbps

description 2048kbps

class 2048kbps

police 20000000 32768 exceed-action drop

policy-map 1536kbps

description 1536kbps

class 1536kbps

police 2000000 524288 exceed-action drop

policy-map 1024kbps

description 1024kbps

class 1024kbps

police 1000000 131072 exceed-action drop

policy-map 128kbps

description 128kbps

class 128kbps

set ip dscp 0

police 1000000 4096 exceed-action drop

policy-map 256kbps

description 256kbps

class 256kbps

police 1000000 16384 exceed-action drop

policy-map 512kbps

description 512kbps

class 512kbps

police 1000000 32768 exceed-action drop

!

ip subnet-zero

ip name-server 192.168.1.34

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

description to subscriber_vlan2_AeroTrends_10th floor

switchport access vlan 2

switchport mode access

no ip address

service-policy input 128kbps

spanning-tree portfast

!

interface FastEthernet0/2

description to subscriber_vlan3_DeltaKnot_9th floor

switchport access vlan 3

switchport mode access

no ip address

service-policy input 512kbps

spanning-tree portfast

!

interface FastEthernet0/3

description to subscriber_vlan4

switchport access vlan 4

switchport mode access

no ip address

spanning-tree portfast

!

interface FastEthernet0/4

description to subscriber_vlan5

switchport access vlan 5

switchport mode access

no ip address

spanning-tree portfast

!

interface FastEthernet0/5

description to subscriber_vlan6

switchport access vlan 6

switchport mode access

no ip address

spanning-tree portfast

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan1000

description to management_vlan1000

ip address 10.2.250.18 255.255.255.248

no ip route-cache

!

ip default-gateway 10.2.250.17

no ip http server

!

!

line con 0

line vty 0 4

password xxxx

login

line vty 5 15

password xxxx

login

!

end

116
Views
0
Helpful
3
Replies