Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst (3750 24 10/100/1000T) and (3750 12 SFP) Stacking Problems

Dear all

I'm having a very strange situation here (at least for me)

we have 4 core switches

2 x   WS-C3750G-24T-S Catalyst 3750 24 10/100/1000T + IPB Image

and

2 x   WS-C3750G-12S-S Catalyst 3750 12 SFP + IPB Image


Stack configuration is done this way

stack configuration.JPG

when the switches are powered on, the first two SFP core switches are seen as a single stack with the stack master LED turned green on the first switch

the other two (24 10/100/1000T) switches have the RPS LEDs always green, mode cannot be changed, and cannot be accessed by Console connection

but when the (24 10/100/1000T) are powered off, the first (SFP) switch in the stack reports that " Switch 3 and 4 has been removed from Stack "

which means they are stacked but there's something wrong, because

only the SFP ports are shown in the " Show interfaces status " , the ethernet ports of the bottom switches are not present !!!

can you please tell me what's the poblem ?

2 REPLIES
New Member

Re: Catalyst (3750 24 10/100/1000T) and (3750 12 SFP) Stacking P

Hi Amr,


If you do a show switch detail do you see ALL four switches listed....and are their state's set to Ready? Here's an example of what it should look like;

router#show switch detail
Switch/Stack Mac Address : 2893.fedd.2780
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 2893.fedd.2780       10     0          Ready              
2       Member 0023.ea4b.c380     1      0          Ready              
3       Member 0023.ea4b.c500     1      0          Ready            

         Stack Port Status           Neighbors    
Switch#  Port 1    Port 2         Port 1   Port 2
--------------------------------------------------------
     1        Ok         Ok                2        3
     2        Ok         Ok                3        1
     3        Ok         Ok                1        2

If you do see all 4 switches listed in Ready state, then it's most probably a configuration issue. If you cannot see the interfaces on the third and forth switch when you do a show int status form the master switch, you might need to renumber the third and forth switch [ router(config)#switch 1 renumber 3 ]. However, you might have to console onto the third and forth switch to do it. Once you renumber it, you'll need to un-provision the old switch number that was assigned to it [ router(config)#no switch 1 provision ].

To make sure you've renumber it correctly, if you stay consoled onto the third switch and do a show int status, your interfaces should now be seen as 3/0/1

3/0/2

3/0/3 etc etc.


The same applies to the forth switch.

DK

New Member

Re: Catalyst (3750 24 10/100/1000T) and (3750 12 SFP) Stacking P

Dear Daniel

Sorry for my delayed response but i was actually quite busy

but the problem was actually in another sense

the default profile for the Catalyst 3750 SFP is the Aggregate SDM Template

while the 3750 10/100/1000 ethernet Switch Default SDM profile was Desktop profile

so i had an SDM mismatch

DATACENTER#sh switch detail
Switch/Stack Mac Address : 081f.f3cf.1c80
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 081f.f3cf.1c80     1      0       Ready              
2       Member 081f.f3cf.5900     1      0       Ready              
3       Member aca0.16ac.0180     1      2       SDM Mismatch       
4       Member aca0.16a3.bc80     1      2       SDM Mismatch 


         Stack Port Status             Neighbors    
Switch#  Port 1     Port 2           Port 1   Port 2
--------------------------------------------------------
  1        Ok         Ok                2        4
  2        Ok         Ok                3        1
  3        Ok         Ok                4        2
  4        Ok         Ok                1        3 

________________________________________________________________

all i did was changing the default profile of the SFP switches into the Desktop Profile and problem was solved

switch 1 provision ws-c3750g-12s
switch 2 provision ws-c3750g-12s
switch 3 provision ws-c3750g-24t
switch 4 provision ws-c3750g-24t
system mtu routing 1500
ip subnet-zero
!
!

no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet3/0/1
!
interface GigabitEthernet3/0/2
!
interface GigabitEthernet3/0/3
!
interface GigabitEthernet3/0/4
!
interface GigabitEthernet3/0/5
!
interface GigabitEthernet3/0/6
!
interface GigabitEthernet3/0/7
!
interface GigabitEthernet3/0/8
!
interface GigabitEthernet3/0/9
!
interface GigabitEthernet3/0/10
!
interface GigabitEthernet3/0/11
!
interface GigabitEthernet3/0/12
!
interface GigabitEthernet3/0/13
!
interface GigabitEthernet3/0/14
!
interface GigabitEthernet3/0/15
!
interface GigabitEthernet3/0/16
!
interface GigabitEthernet3/0/17
!
interface GigabitEthernet3/0/18
!
interface GigabitEthernet3/0/19
!
interface GigabitEthernet3/0/20
!
interface GigabitEthernet3/0/21
!
interface GigabitEthernet3/0/22
!
interface GigabitEthernet3/0/23
!
interface GigabitEthernet3/0/24
!
interface GigabitEthernet4/0/1
!
interface GigabitEthernet4/0/2
!
interface GigabitEthernet4/0/3
!
interface GigabitEthernet4/0/4
!
interface GigabitEthernet4/0/5
!
interface GigabitEthernet4/0/6
!
interface GigabitEthernet4/0/7
!
interface GigabitEthernet4/0/8
!
interface GigabitEthernet4/0/9
!
interface GigabitEthernet4/0/10
!
interface GigabitEthernet4/0/11
!
interface GigabitEthernet4/0/12
!
interface GigabitEthernet4/0/13
!
interface GigabitEthernet4/0/14
!
interface GigabitEthernet4/0/15
!
interface GigabitEthernet4/0/16
!
interface GigabitEthernet4/0/17
!

interface GigabitEthernet4/0/18
!
interface GigabitEthernet4/0/19
!
interface GigabitEthernet4/0/20
!
interface GigabitEthernet4/0/21
!
interface GigabitEthernet4/0/22
!
interface GigabitEthernet4/0/23
!
interface GigabitEthernet4/0/24

that's it !

: D

cheers

1801
Views
0
Helpful
2
Replies
CreatePlease to create content