Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Catalyst 3750 static route update delay

Hi,

When I update or remove a static route on the catalyst 3750, it takes somewhere between 1-10 minutes before the route becomes active on the workstations.

Is there a process that runs every x minutes which updates the table or am I just not seeing it? I would like to get the table updated right away.

running IOS (C3750-IPBASEK9-M), Version 12.2(25)SEB

thanks in advance - have a good weekend..

4 REPLIES
Super Bronze

Re: Catalyst 3750 static route update delay

Hi

If you can verify the route is in the 3750s' route table, and the clients are usign the 3750 as the default gateway, then it's worth checking the cleint's route table...

If they're Windows do a

route print

And look for any references to the route (or supernets of the route) you've just added...

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Silver

Re: Catalyst 3750 static route update delay

Changing the route on the 3750 should not take that long. It is instant on the switch side. Issue the command show ip route and check if the static route is installed in the routing table,

If you want to trigger an the update directly also you can issue the command " clear ip route *" This will flush the table and build it again.

Please rate if I could help,

Regards,

Re: Catalyst 3750 static route update delay

can you juz try to tracroute from your workstation to the destination network IP address, so that i will show the path how it is getting routed.

eg. ur windows ip 192.168.1.1

destination pc ip 10.2.1.1

tell me the path how it is getting reached.

New Member

Re: Catalyst 3750 static route update delay

Hi Guys,

Thanks for all your responses.

But this morning it worked as it should.

Still no idea why, but i'm gonna try to recreate the problem, solve it and post it as soon as i find it out.

Thanks.

200
Views
0
Helpful
4
Replies