Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Catalyst 3750 Switches

I have 6 Catalyst 3750 switches in stacked configuration running IOS version 12.1(19) EA1.

I need to know if EtherChannel can be configured between ports from different switches. It took the configuration, For example, here is the config

interface Port-channel1

switchport trunk encapsulation isl

switchport trunk allowed vlan 2-4,9,254

switchport mode trunk

no ip addres

interface GigabitEthernet1/0/1

switchport trunk encapsulation isl

switchport trunk allowed vlan 2-4,9,254

switchport mode trunk

no ip address

channel-group 1 mode on

interface GigabitEthernet2/0/1

switchport trunk encapsulation isl

switchport trunk allowed vlan 2-4,9,254

switchport mode trunk

no ip address

shutdown

channel-group 1 mode on,

-----------------------------------------------

Now, observe the Spanning Tree outputs on port-channel, gig 1/0/1, and 2/0/1

show spanning-tree interface port-channel 1

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------

VLAN0002 Root FWD 3 128.472 P2p

VLAN0003 Root FWD 3 128.472 P2p

VLAN0004 Root FWD 3 128.472 P2p

VLAN0009 Root FWD 3 128.472 P2p

VLAN0254 Root FWD 3 128.472 P2p

show spanning-tree interface gigabitEthernet 1/0/1

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------

VLAN0002 Root FWD 3 128.472 P2p

VLAN0003 Root FWD 3 128.472 P2p

VLAN0004 Root FWD 3 128.472 P2p

VLAN0009 Root FWD 3 128.472 P2p

VLAN0254 Root FWD 3 128.472 P2p

show spanning-tree interface gigabitEthernet 2/0/1

no spanning tree info available for GigabitEthernet2/0/1

Why int gig 2/0/1 wouldn't give any info on spanning-tree. Really Wierd.

Any idea?

Thanks,

3 REPLIES
Bronze

Re: Catalyst 3750 Switches

Yes it is possible to configure an etherchannel across the stack. It is known as a cross-stack etherchannel and is described in the "Configuring Etherchannel " section of the 3750 Config Guide.

URL: http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12119ea1/3750scg/swethchl.htm

Bronze

Re: Catalyst 3750 Switches

oh, gig2/0/1 is not providing any STP info because it is shutdown. At least that is what is shown in the output you submitted.

New Member

Re: Catalyst 3750 Switches

I sent the configs with the port shutdown. But I unshut it, and still no information on STP.

201
Views
0
Helpful
3
Replies
CreatePlease to create content