Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Catalyst 4006 L3 and L2 problem

I have just brought up a Cat 4006 switch up with WS-4232-L3 module and Sup Engine ii WS-X4013.Configured L2 sc0 interface and L3 module in same vlan, but not able to ping each other's IP address.

Example: IP on L3 portchannel 1.1 is 10.100.1.1

IP on Sc0 of L2 is 10.100.1.2 and sc0 is pointing default to L3 IP.

Anything else to be done.Please help.

3 REPLIES
Community Member

Re: Catalyst 4006 L3 and L2 problem

My doubt is do I need to connect Gigabit links on L2 and L3 for IP connectivity to be successful. Or since the L3 is internally connected to L2 Backplane. thats enough.

Community Member

Re: Catalyst 4006 L3 and L2 problem

This is a tough one. We messed with it forever and even opened a TAC case on it (I looked and looked for the config. we finally came up with but no luck). First take a look at this page, it talks about the L3 blade.

http://www.cisco.com/warp/customer/473/28.html

The L3 Gig ports are router ports (if you try to use them as switch ports with CRB or IRB the results can be unpredictable and inconsistent). They are GIG1 and 2 on the front of the blade. 3 and 4 are internal, they connect to the backplane (on the router side).

What you are trying to do we managed once, but were unable to duplicate when we needed it later on. The TAC will tell you the CRB and IRB are not supported by the 4232-L3 SW. It does say it in the release notes but I tell you it worked once for a converged network test we did. The key was to remove as many of the IPs as you can from the router configs.

The ports that are on the sh port command are the internal switch side connections (mod #/1 and mod#/2). This piece of the router config might help you some. The switch side follows. Some stuff has been deleted but it is all default or our network specfic. If I come across THE config I will post it.

GOOD LUCK

Charlie

bridge crb

!

!

!

interface Port-channel1

no ip address

no ip directed-broadcast

hold-queue 300 in

!

interface Port-channel1.1

encapsulation dot1Q 1 native

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface Port-channel1.100

encapsulation dot1Q 100

no ip redirects

no ip directed-broadcast

bridge-group 100

!

interface FastEthernet1

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet1

no ip address

no ip directed-broadcast

!

interface GigabitEthernet1.1

encapsulation dot1Q 1 native

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet1.100

encapsulation dot1Q 100

no ip redirects

no ip directed-broadcast

bridge-group 100

!

interface GigabitEthernet2

no ip address

no ip directed-broadcast

!

interface GigabitEthernet2.1

encapsulation dot1Q 1 native

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet2.100

encapsulation dot1Q 100

no ip redirects

no ip directed-broadcast

bridge-group 100

!

interface GigabitEthernet3

no ip address

no ip directed-broadcast

no negotiation auto

channel-group 1

!

interface GigabitEthernet4

no ip address

no ip directed-broadcast

no negotiation auto

channel-group 1

!

ip classless

!

arp 127.0.0.2 0030.8510.7400 ARPA

bridge 1 protocol ieee

bridge 100 protocol ieee

!

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

The switch side looks like this:

****************** show port ******************

Port Name Status Vlan Level Duplex Speed Type

----- ------------------ ---------- ---------- ------ ------ ----- ------------

1/1 connected trunk normal full 1000 1000-LX/LH

1/2 connected trunk normal full 1000 1000-LX/LH

2/1 BACKPLANE connected trunk normal full 1000 No Connector

2/2 BACKPLANE connected trunk normal full 1000 No Connector

#module 1 : 2-port 1000BaseX Supervisor

set trunk 1/1 on dot1q 1-1005

set trunk 1/2 on dot1q 1-1005

!

#module 2 : 34-port Router Switch Card

set port name 2/1 BACKPLANE

set port name 2/2 BACKPLANE

set trunk 2/1 nonegotiate dot1q 1-1005

set trunk 2/2 nonegotiate dot1q 1-1005

!

#module 3 : 48-port Inline Power Module

set port disable 3/2,3/4,3/6,3/8,3/10-48

set port speed 3/1 10

set port speed 3/2-48 100

set port duplex 3/1-48 full

set port name 3/1 Gowen_Router

set port name 3/3 BDC_Server

set port name 3/5 Print_Server

set spantree portfast 3/23 enable

!

#module 4 : 6-port 1000BaseX Ethernet

set trunk 4/1 on dot1q 1-1005

set trunk 4/4 on dot1q 1-1005

set trunk 4/5 on dot1q 1-1005

set trunk 4/6 on dot1q 1-1005

!

#module 5 : 48-port Inline Power Module

!

#module 6 empty

Community Member

Re: Catalyst 4006 L3 and L2 problem

Here is the config that works.

L2 : set int sc0 1 10.100.1.2/255.255.255.0 10.100.1.255

set ip route 0.0.0.0 0.0.0.0 10.100.1.1

L3: int port channel 1.1

ip address 10.100.1.1 255.255.255.0

encap dot1q 1 native

" native" was missing before.

Thanx for your suggestions.

90
Views
0
Helpful
3
Replies
CreatePlease to create content