Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Catalyst 5505 boot problem

Ive got a Cat5505 with a corrupt image in flash so I cannot boot from the supervisor flash. I bought a pcmcia flash card because of this, preloaded with an image so i could boot in rommon mode from the flash card. However, when I try this I get a 'bad file magic number' error. The full out put is below...

rommon 1 > dir slot0:

File size Checksum File name

3197488 bytes (0x30ca30) 0xdf2eab5c cat5000-sup.5-5-10.bin

5281067 bytes (0x50952b) 0xcbbebc94 cat5000-sup3_6-2-2.bin

rommon 2 > boot slot0: cat5000-sup3_6-2-2.bin

loadprog: bad file magic number: 0x0

boot: cannot load "slot0: cat5000-sup3_6-2-2.bin"

rommon 3 >

rommon 3 >

6 REPLIES
New Member

Re: Catalyst 5505 boot problem

Hi Samantha,

I think you can intall the Cat IOS by using "xmodem". What you need to do is you have to have TFTP server with the Cat IOS image on it, then from you console which is rommon 1> xmodem PLEASE DON'T ENTER YET. From your Hyper terminal menu tab go to "Transfer" and choose "Send file" then click the browse and select the "cat5000-sup.5-5-10.bin" with out the quote of course. Click send and you will see a new window then you go to your rommon 1> xmodem command line and press enter. I takes a lot of time to copy but it is possible to do it. good luck

New Member

Re: Catalyst 5505 boot problem

Hi Samantha,

Check your hardware and verify that you have a Supervisor 3 module in the Cat5505. The image you tried to load was a SUP3 image (cat5000-sup3_6-2-2.bin). The old image was for a Supervisor 1 module (cat5000-sup.5-5-10.bin).

If your hardware is correct, you may also want to verify the 6.2.2 image size. You may have a corrupted image on the PCMCIA card too.

Hope this helps

JK

Re: Catalyst 5505 boot problem

thanks for the replys.

I cannot use the xmodem download because you need version 5.1.1 (or something) Rom monitor, whereas I only have 3.1.2.

The Supervisor Card is definitely III, and the Flash card is brand new, I bought it to recover this switch! Itd preloaded with two images, one for Sup2 and one for Sup3. Anymore ideas?

Purple

Re: Catalyst 5505 boot problem

I am guessing that you are running a Sup 1 card , you are trying to load a sup3 version which will not load .

Even if you get a valid sup 1 image your code is so old that it will be a 2 hop process to get into the 4.X train . I believe you have to upgrade to 3.2.4 first then into the "4" train , the last version for sup 1 is 4.5.13 . Do not believe the Sup 1 card supports 5.X code . Look at the module number for the supervisior and verify what Sup you are running .

Purple

Re: Catalyst 5505 boot problem

Also check your RAM requirements , 5.X train needs 32 meg of DRAM , 6.X train requires 64 meg of DRAM .

Re: Catalyst 5505 boot problem

no, its a sup3 card.

ive fixed it now by not putting a space before the file name! Typical...

boot slot0:cat5000-sup3_6-2-2.bin

194
Views
0
Helpful
6
Replies
CreatePlease to create content