Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Catalyst 6500 L3 interface trunk

We have a catalyst 6509 with IOS version 12.1(26)E6. On a layer 3 interface can we configure trunking as normal router?

12 REPLIES

Re: Catalyst 6500 L3 interface trunk

why dont you configure a SVI (interface vlan) and make this routed port a trunk?

ex:

vlan 10

vlan 20

int gi0/1

no swithport

ip address 10.1.1.1 255.255.255.0

---

then

int vlan 10

ip address 10.1.1.1 255.255.255.0

int gi0/1

switchport mode trunk

this way you can have trunk and still have your l3 routed interface, this is the good thing about Multilayer switches.

HTH,

vlad

Re: Catalyst 6500 L3 interface trunk

yes you can but can you tell me your exact requirement...

if you want to configure your layer 3 interface as trunk then you can use the same configuration as in your previous post...

regards

Devang

Community Member

Re: Catalyst 6500 L3 interface trunk

In my previous post, i was testing the Catalyst espress 500 with cisco router 2801 and it works well. Then i want to deploy this solution to my production environment with catalyst 6509. What i want to do is : on the express 500 there are several vlans and i must give them routing capability over catalyst 6509. On cat 6509 i cant configure L3 as trunking as cisco 2801. It denies the command in the form "interface g2/1.1".

Re: Catalyst 6500 L3 interface trunk

So, use interface vlans, and use interface gi2/1 as trunk.

int gi2/1

no switchport

switchport mode trunk

switchport trunk encap dot1q

take the IP address of this interface and create a vlan for it:

vlan 10

then create and SVI

interface vlan 10

ip address of int gi2/1

All vlans are inside the same subnet? if so you are good to go...all vlans will now have routing capability

HTH,

please remember to rate all posts.

Vlad

Community Member

Re: Catalyst 6500 L3 interface trunk

No all vlans have different subnet...

Re: Catalyst 6500 L3 interface trunk

if you have the multiple vlan with the different subnet then you need to creat multiple svi by following the same procedure...do it...

regards

Devang

Re: Catalyst 6500 L3 interface trunk

So, then you need to create 1 interface vlan for each subnet

int vlan 10

ip address 10.10.1.0 255.255.255.0

int vlan 20

ip address 10.10.2.0 255.255.255.0

create the vlans

vlan 10

vlan 20

use trunk on the interface giga...

and you'll have inter-vlan routing.

check this link:

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008015f17a.shtml

Please rate all helpful post.

Vlad

Community Member

Re: Catalyst 6500 L3 interface trunk

Vlad,

Was there a typo in the example you gave above?

//

int gi2/1

no switchport

switchport mode trunk

switchport trunk encap dot1q

//

Right after "no switchport", you wouldn't be able to issue any command related to "switchport", since you've already negated it and made it a routed port.

Re: Catalyst 6500 L3 interface trunk

routed interface

Yes, thanks for bringing that to my attention

It should be

switchport , meaning no longer a routed interface

thanks

Vlad

Re: Catalyst 6500 L3 interface trunk

http://www.cisco.com/en/US/products/hw/switches/ps700/products_configuration_example09186a008010f615.shtml

look at this example for creating trunk...

rate this post if it helps

regards

Devang

Community Member

Re: Catalyst 6500 L3 interface trunk

I have a similar question, where I have extended vlans on a 6513 out a trunked port (gi1/3) and now I need to bring additional remote sites that do not have layer 3 switches, only 2821 routers. I can't seem to think of a way to attach the 2821 without an access port at the remote site other than changing the 6513 to an access port or a routed port.

Do you have any suggestions?

Thanks,

Greg

Community Member

Re: Catalyst 6500 L3 interface trunk

What do you have at the remote sites, 2821 router and layer 2 switches?

Connect a trunk link from the switch to the router, and configure sub-interfaces on the router.

Basically you'll need to do router-on-a-stick for that site.

349
Views
0
Helpful
12
Replies
CreatePlease to create content