Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CBWFQ not working on 1603

Hi ,

I have been trying to implement CBWFQ between two cisco 1603 routers.

PC

|

OAHO(router1)(serial0)------backtoback-------(serial0)OAREMOTE(router2)----VOIPBOX1(10.66.6.126)

| (64 Kbps) |

| PC

VOIPBOX2

(10.66.6.35)

Now the default queing for the two routers is Weighted fair quwing .

Now i have reserved 30 Kbps bandwidth between the two router for the voice traffic , the voipbox is uing UDP ports greater than 20000.

So after configuring the routers , i do a multiple ftp sessions between the two PC, so that the traffic between the two serial interfaces touches 62 Kbps .

Now when i start talking between the two VOIP boxes , i dont see the CBWFQ kicking in & reserving the necessary bandwidth as i have provisioned .

I am enclosing both the router configuration :

CONFIG OF OAHO

OAHO

sh ru

Building configuration...

Current configuration : 1146 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname OAHO

!

!

!

class-map voice

match access-group 101

!

!

policy-map test

class voice

priority 40

!

ip subnet-zero

ip tftp source-interface Ethernet0

!

!

interface Ethernet0

description connected to EthernetLAN_1

ip address 10.66.6.33 255.255.255.248

no cdp enable

!

interface Serial0

description connected to Internet

bandwidth 64

ip address 10.66.2.98 255.255.255.252

no ip route-cache

no ip mroute-cache

service-policy output test

load-interval 30

max-reserved-bandwidth 90

!

interface BRI0

no ip address

shutdown

ip classless

ip route 0.0.0.0 0.0.0.0 10.66.2.97

no ip http server

!

access-list 101 permit ip host 10.66.6.35 host 10.66.6.126

access-list 101 permit udp host 10.66.6.35 gt 20000 host 10.66.6.126 gt 20000

dialer-list 1 protocol ip permit

tftp-server flash:c1600-sy-mz.121-15.bin

!

line con 0

exec-timeout 0 0

password vpn

login

line vty 0 4

exec-timeout 60 0

password vpn

login

transport preferred none

!

end

OAHO# show po

OAHO# show policy-map

Policy Map test

Weighted Fair Queueing

Class voice

Strict Priority

Bandwidth 40 (kbps)

OAHO#show policy-map

Policy Map test

Weighted Fair Queueing

Class voice

Strict Priority

Bandwidth 40 (kbps)

OAHO#show policy-map int se 0

OAHO#show int se 0

Serial0 is up, line protocol is up

Hardware is QUICC Serial

Description: connected to Internet

Internet address is 10.66.2.98/30

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 3/255, rxload 3/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:08:54

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

30 second input rate 1000 bits/sec, 4 packets/sec

30 second output rate 62000 bits/sec, 3 packets/sec

816 packets input, 39184 bytes, 0 no buffer

Received 69 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

717 packets output, 46507 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

6 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

--

OAHO#show queue se 0

Show queue not supported with FIFO queueing

OAREMOTE CONFIG

sh ru

Building configuration...

Current configuration : 1316 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname OAREMOTE

!

enable secret 5 $1$r1WR$YWvapuJdPcjur/4S6MRKv.

!

username dlinpc password 0 npc

username noidad32 password 0 d32

!

class-map voice

match access-group 101

!

!

policy-map test

class voice

priority 40

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 10.66.6.121 255.255.255.248

ip nat inside

no cdp enable

!

interface Serial0

description connected to Infinet 64K leased line for vpn

bandwidth 64

ip address 10.66.2.122 255.255.255.252

no ip route-cache

no ip mroute-cache

load-interval 30

max-reserved-bandwidth 90

service-policy output test

clockrate 64000

!

interface BRI0

description connected to NPC/D32

no ip address

encapsulation ppp

isdn switch-type basic-net3

no fair-queue

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.66.2.121

no ip http server

!

access-list 101 permit ip host 10.66.6.126 host 10.66.6.35

access-list 101 permit udp host 10.66.6.126 gt 20000 host 10.66.6.36 gt 20000

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 0 0

password 111

login

line vty 0 password 111

login

!

end

OAREMOTE# show po

OAREMOTE# show policy-map

Policy Map test

Weighted Fair Queueing

Class voice

Strict Priority

Bandwidth 40 (kbps)

OAREMOTE#show po

OAREMOTE#show policy-map int se 0

Serial0 output : test

Weighted Fair Queueing

Class voice

Strict Priority

Output Queue: Conversation 24

Bandwidth 40 (kbps) Packets Matched 40

(total drops/bytes drops) 5/380

OAREMOTE#sjh ÿ

User Access Verification

Password: ÿ

OAHO>telnet 10.66.6.12 121

Trying 10.66.6.121 ... Open

OAREMOTE#show policy-map

Policy Map test

Weighted Fair Queueing

Class voice

Strict Priority

Bandwidth 40 (kbps)

OAREMOTE#show po

OAREMOTE#show policy-map int se 0

Serial0 output : test

Weighted Fair Queueing

Class voice

Strict Priority

Output Queue: Conversation 24

Bandwidth 40 (kbps) Packets Matched 40

(total drops/bytes drops) 5/380

Now when i even see the access-list 101 , i dont see any match for the UDP packets while talking , i fail to undertand that because when i do debug ip packet detail , i see the udp ports been used while talking between the voip box .

Any suggestions on this

Rgds

Anu

3 REPLIES

Re: CBWFQ not working on 1603

I guess, this is what is happening to the CBWFQ.

First check your VOIP boxes, which port range they are using. Then you can use an access list to match them, as follows....

access-list 101 permit udp any any range xxxxx yyyyy

where xxxxx is starting range yyyyy is ending range. This should match all packets sourced from one end (OAHO side) to the other side, which are voice traffic.

Since your policy maps defines only how much bandwidth is reserved for your voice traffic ( you have said priority "40" - which means use strict priority queueing for voice traffic ). Now the remaining traffic (data) doesnt match the access list and doesnt get restricted. So you should restrict the non voice traffic too.

for this try redefining your policy map and class map as follows.

policy-map test

class voice

priority 40

class class-default

fairqueue

or

policy-map test

class voice

priority 40

class data

bandwidth 16

In the first case, all those traffic which are not voice, will go through WFQ.

In the second case, you are restricting data bandwidth to be not more than 16 kbps. For this you will have to define a class map by the name data. In that use an access-list to match data traffic. Either should work.

Community Member

Re: CBWFQ not working on 1603

Hi

I have tried that part too,it is till not working inspite i have put the class class-default at 16 kbps , i would redescribe the setup :

VOIP BOX(erricson)----HUB-----Router

(1603)-----backtoback(2601)--------backtoback(1603)----HUB---VOIPBOX(erricso

n).

First step i took was to debug ip packet detail : When i talk between the

voice boxes it uses exactlt 30000 series of udp ports & Ip ports.

Now this is a test setup , so there is no other traffic coming on the above

described network.

The CBWFQ is configured on the serial interface connected to 2601 router .

The classification of the pakets is done by using the access-list .

The ip address of the VOIP boxes are 10.66.6.36/29 & 10.66.6.124/29.

The output of the show access-list is s follows :

Extended IP access list 102

permit udp host 10.66.6.124 gt 20000 host 10.66.6.36 gt 20000 (20315

matches)

Now my objective is that whenever i am doign a voice conversation , a

guranteed bandwidth is reserved for the voice , say 30 Kbps , actually the

codes used in the voip boxes is G 729 , which utilizes 12 Kbps , which i

have tested by talking between two voip boxes with no other traffic .

Other than the above setup two pc are connected to the network diagram to

generate the ftp data between the two , so that the load can be put on the

serail link .

Once that happens the voice starts breaking & cant hear the other person

clearly.

Now i am wondering if i am doing the things properly , i.e is theCBWFQ needs

to be done on the serial port of the end routers only or also in the

internediarly routers, do i need to put CBWFQ on the ethernet ports of both

the 1603 routers.

I have not been able to found any doc on CBWFQ which states that the CBWFQ

needs to be done on the intermediary routers too.

Pls suggest.

The config of the routers are as mentioned in my previous mail.

how do i know that CBWFQ is working , also the bandwidth part is not working as it shd be , inspite of the fact that i have reserved 40 Kbps for the voice which actually utilizes 12 Kbps & rest 12 Kbps .

Pls do let me know incase i am missing here something

Thanks

Anu

Re: CBWFQ not working on 1603

UDP is being hit by the first entry in the access-list.

IP = icmp, udp, or tcp traffic

If you flip your Access-list lines around then you'll see hits on both lists.

99
Views
0
Helpful
3
Replies
CreatePlease to create content