Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

CBWFQ on ATM VCs

I have implmented CBWFQ on a 3640 with an 8 port ima interface (4 of which are in service).The IOS is 12.2(1). I created:

Class-Map match-all citrix

match input-interface FastEthernet0/0

match protocol citrix

Policy-map citrix

class citrix

bandwidth percent 50

queue-limit 50

class class-default

fair-queue

I appled the service policy to one of my ATM VCs. When I sho policy-map int atm1/ima0.100 I see:

ATM1/IMA0.100: VC 1/100 -

Service-policy output: citrix

Class-map: citrix (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: input-interface FastEthernet0/0

Match: protocol citrix

Match: protocol telnet

Weighted Fair Queueing

Output Queue: Conversation 73

Bandwidth 50 (%) Max Threshold 50 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

290193 packets, 74476663 bytes

5 minute offered rate 170000 bps, drop rate 0 bps

Match: any

Weighted Fair Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 64

(total queued/total drops/no-buffer drops) 0/0/0

Why dont I see any packets matching the citrix class-map when the majority of the traffic traversing the circuit IS citrix traffic?

Thanks!

3 REPLIES
New Member

Re: CBWFQ on ATM VCs

I haven't done this for citrix just voice/video. Also haven't defined my criteria with the command match protocol citrix. However this would be an example of how I'd do it.

class-map match-all citrix

match access-group 103

policy-map qos-policy

class citrix

bandwidth 50

access-list 103 permit tcp any eq 1494 any

access-list 103 permit udp any eq 1604 any

interface ATM1/IMA0.9

ip address x.x.x.x x.x.x.x

pvc 0/40

service-policy output qos-policy

New Member

Re: CBWFQ on ATM VCs

I've done some CBWFQ at the ATM PVC level as you've mentioned but some how my configuration does not go into the router. That is the router does not complain when I input the configuration but when I do show run, the command does not show up. Eg.

interface ATM1/0.34 point-to-point

description *** ATM PVC to Brisbane - 512k CIR /1024 (MFRAD11677006) ***

mtu 1500

bandwidth 512

ip address 192.168.155.17 255.255.255.252

ip summary-address eigrp 112 0.0.0.0 0.0.0.0 5

pvc 3/34

vbr-nrt 1024 512 32

service-policy output QOS-Policy

I have a Cisco 3662 router running IOS version 12.2(2)T. What's your version? Can you email me to vincentn@mediamonitors.com.au with your answer. Thanks in advance.

New Member

Re: CBWFQ on ATM VCs

This bit of the output may be a clue...

Class-map: citrix (match-all)

...

Match: input-interface FastEthernet0/0

Match: protocol citrix

Match: protocol telnet

It looks like the class map is matching only traffic which is both Citrix AND telnet. This may be a relic from a previous configuration. Try deleting the class and re-creating it, or configuring

Class-Map match-all citrix

no match protocol telnet

Hope this helps.

160
Views
0
Helpful
3
Replies
CreatePlease to create content