Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cdp on trunk link, tagged or untagged?

[Cat3550]----802.1q trunk----[Cat2950]

The native vlan on the trunk is vlan 2, and vlan 1 is removed from trunk on both devices.

In this case, Catalyst3550 sends CDP frame with untagged, but Catalyst2950 sends CDP frame with vlan1 tagged over the trunk.

(not only the CDP frame, but also the DTP or ethernetLOOPBACK frames are in the same way on both switches)

So, Catalyst2950 can see CDP information of Catalyst3550 but Catalyst3550 can not see that of Catalyst2950.

Two switches can ping each other. Management vlan is vlan2.

Are there anything wrong with the configurations bellow?

If vlan 1 is allowed on the trunk, Catalyst3550 become to understand Catalyst2950's CDP information.

Also, Catalyst3550 begin to send the frames with vlan 1 tagged, for example PVST BPDU for VLAN 1 etc,.

------------------------------------------------

2950#sh run

!

interface FastEthernet0/1

switchport trunk native vlan 2

switchport trunk allowed vlan 2-4094

switchport mode trunk

no ip address

!

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 172.33.0.100 255.255.255.0

no ip route-cache

!

ip default-gateway 172.33.0.254

ip http server

!

!

end

2950#

2950#sh int trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 2

Port Vlans allowed on trunk

Fa0/1 2-4094

Port Vlans allowed and active in management domain

Fa0/1 2-3,20,33,49-50,70-73,75,191,200,230,240,250

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 2-3,20,33,49-50,70-73,75,191,200,230,240,250

2950#

2950#sh cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

C3550_pri Fas 0/1 147 R T S I WS-C3550-1Gig 0/2

2950#

2950#sh int switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 2 (VLAN0002)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: 2-4094

Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)

Appliance trust: none

------------------------------------------------

C3550_pri#sh run

!

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport trunk allowed vlan 2-4094

switchport mode trunk

no ip address

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 172.33.0.1 255.255.255.0

ip broadcast-address 172.33.0.255

no ip redirects

no ip mroute-cache

standby 2 ip 172.33.0.254

standby 2 timers 5 15

standby 2 priority 120

standby 2 preempt

standby 2 authentication vlan2

!

interface Vlan3

ip address 172.33.1.1 255.255.255.0

ip broadcast-address 172.33.1.255

no ip redirects

no ip mroute-cache

standby 3 ip 172.33.1.254

standby 3 timers 5 15

standby 3 priority 120

standby 3 preempt

standby 3 authentication vlan3

!

end

C3550_pri#

C3550_pri#sh int trunk

Port Mode Encapsulation Status Native vlan

Gi0/2 on 802.1q trunking 2

Port Vlans allowed on trunk

Gi0/2 2-4094

Port Vlans allowed and active in management domain

Gi0/2 2-3,20,33,49-50,70-73,75,191,200,230,240,250

Port Vlans in spanning tree forwarding state and not pruned

Gi0/2 2-3,20,33,49-50,70-73,75,191,200,230,240,250

C3550_pri#

C3550_pri#sh cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

C3550_pri#sh int switchpo

Name: Gi0/2

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 2 (VLAN0002)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: 2-4094

Pruning VLANs Enabled: 2-1001

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Voice VLAN: none (Inactive)

Appliance trust: none

------------------------------------------------

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: cdp on trunk link, tagged or untagged?

Hi,

generally

"CDP, VTP, and PAgP updates are always forwarded on trunks with a VLAN 1 tag. This is the case even if VLAN 1 has been cleared from the trunks and is not the native VLAN. Clearing VLAN 1 for user data has no impact on control plane traffic that is still sent using VLAN 1."

See http://www.cisco.com/en/US/customer/products/hw/switches/ps663/products_tech_note09186a0080094713.shtml#cat_control

But there is a bug in Cat3550

"If VLAN 1 or VLANs 1002 to 1005 are removed from a trunk port, the switch no longer receives CDP or VTP frames. VLAN 1 minimization is not supported on the Catalyst 3550 switch. You cannot remove VLAN 1 or VLANs 1002 to 1005 from the allowed VLAN list. (CSCdz22629)"

See Release Notes for the Catalyst 3550 Multilayer Switch Cisco IOS Release 12.1(12c)EA1.

Regards,

Milan

2 REPLIES

Re: cdp on trunk link, tagged or untagged?

Hi,

generally

"CDP, VTP, and PAgP updates are always forwarded on trunks with a VLAN 1 tag. This is the case even if VLAN 1 has been cleared from the trunks and is not the native VLAN. Clearing VLAN 1 for user data has no impact on control plane traffic that is still sent using VLAN 1."

See http://www.cisco.com/en/US/customer/products/hw/switches/ps663/products_tech_note09186a0080094713.shtml#cat_control

But there is a bug in Cat3550

"If VLAN 1 or VLANs 1002 to 1005 are removed from a trunk port, the switch no longer receives CDP or VTP frames. VLAN 1 minimization is not supported on the Catalyst 3550 switch. You cannot remove VLAN 1 or VLANs 1002 to 1005 from the allowed VLAN list. (CSCdz22629)"

See Release Notes for the Catalyst 3550 Multilayer Switch Cisco IOS Release 12.1(12c)EA1.

Regards,

Milan

New Member

Re: cdp on trunk link, tagged or untagged?

Milan,

Thanks a lot for your assistance!

1609
Views
5
Helpful
2
Replies