Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Changing Native VLAN

I have a network with 2 VLANs (VLAN10, VLAN192). Right now VLAN192 is the native VLAN. I want to change the native VLAN from VLAN192 to VLAN10. However, when I make that change, I loose all connectivity accross my network. I am running a 2611(dot1q) and 7 2950s. 4 in VLAN10 and 3 in VLAN192. My trunk is on one of the VLAN10 switches. I have used the switchport trunk native vlan command on that trunk port, but still, as soon as I make the change, I loose all connectivity. What am I missing here? I can provide configs if needed.

Thanks!

8 REPLIES

Re: Changing Native VLAN

Hi,

native VLAN is always local on the trunk. So changing it should not brake connectivity across the network.

But you have to change it on both trunk sides.

If you are doing Telnet to a remote switch via the trunk you are changing it is necessary to change the remote side first - native VLAN change can disconnect your Telnet. Then change the local side of the trunk.

Regards,

Milan

Community Member

Re: Changing Native VLAN

Thanks Milan

I changed the router side first, on s0/1.1 I used the command 'encapsulation dot1q 10 native' then changed the trunk port on the switch using 'switchport trunk vlan 10 native' and it is at that point I loose connectivity (client server, internet, email) I am doing all this via console cable.

Thanks!

Re: Changing Native VLAN

When you do "sh int ... switchport" on the switch side do you see the trunk working OK?

What do you mean exactly by "I loose connectivity"? It means that routing between VLANs is not working? Are you able to ping from VLAN10 to any other VLAN? Are you ablo to ping the router interface inside VLAN10?

What is the original native VLAN? VLAN192? And everything is OK with it?

Can you provide the configs regarding s0/1 and subinterfaces and the trunk part of the switch config?

Regards,

Milan

Community Member

Re: Changing Native VLAN

Exactly, I loose routing between VLAN10 and VLAN192. Here are configs:

Switch

interface FastEthernet0/24

duplex full

speed 100

switchport mode trunk

spanning-tree portfast

!

interface VLAN1

no ip address

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN2

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN10

ip address 10.0.2.206 255.255.255.0

no ip directed-broadcast

Router:

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 192 native

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.1

encapsulation dot1Q 10

ip address 10.0.2.1 255.255.255.0

ip helper-address 192.168.2.25

Community Member

Re: Changing Native VLAN

Not sure if this is exactly and only your problem based on the information you have provided, but here is something I recently found within my network that may be part of your problem. On the 2950 switches, as soon as you create another vlan interface (to change the management VLAN), the current active VLAN interface shuts itself. This effectively drops all connectivity to the switch remotely. It's due to a bug in the IOS code on 2950 switches that is not fixed yet.

Hope this helps

Community Member

Re: Changing Native VLAN

Hi

I am also having the same problem. Please how did you solve it.

We already have a standard network with management VLAN 5. and naive VLAN on the trunks 1. When I now configure a 2950 to join, for me to be able to connect I put in a management van for 5 but this shut down vlan1.

And If I remember, it does need VLAN 1 to communicate to the devices on the other switches. Please how did you solve this

Thanks

Community Member

Re: Changing Native VLAN

It is not resolveable... according to the bug report (CSCdt48569) it has not been fixed yet. The only thing you can do is have one active VLAN on the switch.

Re: Changing Native VLAN

Hi,

there are two strange things in your configs:

Switch:

interface FastEthernet0/24

switchport trunk native vlan 192 - without this command the native VLAN has default value VLAN1.

Router:

you configure

interface FastEthernet0/0.1

encapsulation dot1Q 192 native

BUT

interface FastEthernet0/1.1

encapsulation dot1Q 10

Fa0/0 and Fa0/1 are different physical intefaces!!!

So there should be probably

interface FastEthernet0/0.2

encapsulation dot1Q 10

or

interface FastEthernet0/1.2

encapsulation dot1Q 192 native

Regards,

Milan

115
Views
0
Helpful
8
Replies
CreatePlease to create content