Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Checking the correct function of an etherchannel

Hi

I have two Switches (4948) i want to connect via 2 GigabitEthernet Ports. The two Ports should build a Channel and forward all VLANs.

Heres the config i enterd on both switches:

!

interface Port-channel1

switchport

!

interface GigabitEthernet1/47

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode auto

!

interface GigabitEthernet1/48

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode auto

The two Switches are already connected, but i don't think that the channel is working correct cause this:

Port-channel1 is down, line protocol is down (notconnect)

Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed, media type is N/A

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Both channel Ports are up and show a mediaspeed of 1000Mbit full-duplex. But just one of them has an significant Traffic.

I think that the Channel-Group has to be up and not down. I also wonder why the mediaspeed is just set to 100Mbit

If the Channel is working (in this or a little modified configuration) how will the traffic flow?

Balanced over both Ports? Just one Port and if the Traffic is too high also over the second port?

Thank you very much for helping me!

2 REPLIES
Super Bronze

Re: Checking the correct function of an etherchannel

Hi

Try using channel-group 1 mode desirable on the ports instead.

Load balancing is done based on the source MAC by default - the following command shows your load -balance method:

show etherchannel load-balance

The switch will put some traffic over one link and some over the other, but depending on your network it might be uneven.

Regards

Aaron

p.s. please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Purple

Re: Checking the correct function of an etherchannel

The etherchannel is not working if the portchannel is down . Do a "show etherchannel detail and see what state the channel is in , though it should show that it is down if the port channel is down . You have the ports set as auto on the channel so in order for that to work the far cisco switch has to be set as desirable (otherwise it won't come up) and it is recomended that it be mode non-silent between cisco devices . Also I would pull the speed/duplex settings and leave it as auto , it will negotiate the highest available speed between the switches . Both ends should be auto for speed/duplex .

231
Views
0
Helpful
2
Replies
CreatePlease login to create content