Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1004 and MD compare failed

I’m configuring a Cisco 1004 and a 3Com ISDN LAN router. On the 3com you have to create a user. I believe that I have configured my router correctly, no error for layer 1 and 2. What I do get are errors on authentications. I think it’s a bad password somewhere could anyone check out my config and are there any errors?

01:30:18: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

01:30:19: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

01:38:53: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

01:38:53: BR0:1 PPP: Treating connection as a callin

01:38:54: BR0:1 PPP: Phase is AUTHENTICATING, by this end

01:38:54: BR0:1 CHAP: O CHALLENGE id 213 len 26 from "laval"

01:38:54: BR0:1 CHAP: I RESPONSE id 213 len 28 from "decarie"

01:38:54: BR0:1 CHAP: O FAILURE id 213 len 21 msg is "MD compare failed"

Current configuration:

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname laval

!

enable secret 5 $1$.pMi$Tx2SQzfCrJQb.BGf5Tlsp0

enable password nwdma

!

username montreal password 0 decarie

username decarie password 0 montreal

username laval password 0 no12hack

ip subnet-zero

isdn switch-type basic-dms100

!

!

interface Ethernet0

ip address 172.16.100.5 255.255.252.0

!

interface BRI0

ip unnumbered Ethernet0

encapsulation ppp

shutdown

dialer map ip 192.168.1.0 95147330440

dialer map ip 192.168.1.0 95147336776

dialer-group 2

isdn spid1 450681339000 6813390

isdn spid2 450681335600 4506813356

ppp authentication chap pap

ppp multilink

!

ip classless

ip route 172.16.100.0 255.255.252.0 172.16.100.2

ip route 192.168.1.0 255.255.255.255 BRI0 permanent

!

access-list 101 permit ip any any

access-list 102 permit ip any any

dialer-list 2 protocol ip list 102

!

line con 0

password nwdma

login

line vty 0 4

password nwdma

login

!

end

laval#

  • Other Network Infrastructure Subjects
1 REPLY
New Member

Re: Cisco 1004 and MD compare failed

Probably your username/password config. You have this:

username decarie password 0 montreal

username laval password 0 no12hack

And your debug:

01:38:54: BR0:1 CHAP: O CHALLENGE id 213 len 26 from "laval"

01:38:54: BR0:1 CHAP: I RESPONSE id 213 len 28 from "decarie"

01:38:54: BR0:1 CHAP: O FAILURE id 213 len 21 msg is "MD compare failed"

You should probably take out the username leval statement. Does the "decarie" router have "username leval password montreal" configured?

Josh

85
Views
0
Helpful
1
Replies