Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Hello all, I am new at configuring routers (just finished CCNA classes) and have had my instructor look over my configuration and even let my instructor take home my router to see that it worked at his home and it does. It seems to be able to connect to the ISP because it does assign it an IP address but I am not able to get on the internet. I will post my config info for evaluation plus other read outs that I have taken. Any help would be great.

16 REPLIES
Silver

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Type ipconfig on the computer and check if you are getting an ip address and dns server addresses on the computer. Check with yopur ISP if you dont get an ip address or DNS server address. Check if you are able to ping the DNS servers. Check for firewall and antivirus on your computer . Disable them for the time being.

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Thanks for the reply I didn't think anyone was going to respond. =) I am sorry but I posted a similar link in the "LAN, Switching and Routing:" section of these forums.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cbe6b44

Q: Type ipconfig on the computer and check if you are getting an ip address and dns server addresses on the computer

A: I did ipconfig on my workstation and I get proper IP address for LAN (192.168.xxx.xxx) and I get proper DNS address for Verizon. Primary DNS 1: 68.238.64.12 Secondary DNS 2: 68.238.128.12

Q: Check if you are able to ping the DNS servers.

A: I am not able to ping the DNS's from my workstation or the con 0 connection from my server for some reason. But I am able to ping the assigned address to the Routers ADSL WAN connection (71.105.142.101) the Router LAN (192.168.xxx.xxx) and the workstation (192.168.xxx.xxx) from the workstation ethernet or the servers con 0 or ethernet

Note* Server is just local file server not required for internet access.

Q: Check for firewall and antivirus on your computer

A: They are disabled/not Installed. Don't use winxp sp2 firewall and AVG is only antivirus I have but it is disabled/not Installed.

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

irisrios are you still able to assist me? If not can anyone help with this problem?

Hall of Fame Super Gold

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Hi,

please configure

ip route 0.0.0.0 0.0.0.0 dhcp

also configure

ip domain-lookup

ip dns server

and router's address as dns in dhcp pool.

hope this helps, please rate post if it does!

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

I will try it and let you know thanks.

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

I entered the information you suggested but it is still not working. The following is a copy of the current running config now. I hope they are setup right.

Building configuration...

Current configuration : 1324 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MYHOST

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

logging console informational

!

no aaa new-model

memory-size iomem 10

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.10

!

ip dhcp pool MYPOOL

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.1.1

!

!

ip domain lookup source-interface BVI1

!

!

!

!

!

!

!

bridge irb

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

bridge-group 1

pvc 0/35

encapsulation aal5snap

!

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

!

interface BVI1

mac-address xxxx.xxxx.xxxx

ip address dhcp client-id FastEthernet0

ip nat outside

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 dhcp

!

ip dns server

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface BVI1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

!

!

!

!

!

!

!

line con 0

logging synchronous

speed 115200

line aux 0

line vty 0 4

login

!

end

Hall of Fame Super Gold

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Hi,

please configure:

interface ATM0

no pvc 0/35

no bridge-group 1

interface ATM0.1 point-to-point

pvc 0/35

bridge-group 1

Then, from router, can you ping 4.2.2.1 ?

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

I appreciate the help. I edited the script as per your instructions and I was not able to connect but, I did notice a difference in the way the ADSL obtained it's address from Verizon. The old configuration I had it was only a second or two before I was able to obtain IP from Verizons network. Once I edited with you suggestions, I obtained an address but it took about 1hr. to an 1 1/2 hrs before I was able to get an IP.

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Does anyone have any other suggestions that may help??

Hall of Fame Super Gold

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Can you send the revised configuration and output of "show ip int brief" ?

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

I am going to have to hook up the router again to the DSL connection. Upon doing so I will get the info your are requesting but it may take a few hours to get back online seeing as it takes so long for my linksys to pull an ip again after.

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

DSLR#sh ip int brie

Interface IP-Address OK? Method Status Protocol

ATM0 unassigned YES NVRAM up up

ATM0.1 unassigned YES unset up up

BVI1 unassigned YES DHCP up up

FastEthernet0 192.168.1.1 YES NVRAM up up

NVI0 unassigned NO unset up up

DSLR#

*Mar 5 02:43:15.451: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 71.105.2

25.181, mask 255.255.255.0, hostname DSLR

*UPDATE** I did "sh ip int brie" before the interface got an ip and just after it got assigned an IP as you can see at the end but I was still not able to ping any addresses outside except 71.105.225.181

Hall of Fame Super Gold

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Please configure "ip route 0.0.0.0 0.0.0.0 dhcp".

Failing that, please send config again.

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

DSLR#sh run

Building configuration...

Current configuration : 1359 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MYHOST

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

logging console informational

!

no aaa new-model

memory-size iomem 10

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.10

!

ip dhcp pool MYPOOL

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.1.1

!

!

ip domain lookup source-interface BVI1

!

!

!

!

bridge irb

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no snmp trap link-status

bridge-group 1

pvc 0/35

!

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

!

interface BVI1

mac-address xxxx.xxxx.xxxx

ip address dhcp client-id FastEthernet0

ip nat outside

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 dhcp

!

ip dns server

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface BVI1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

!

!

!

!

!

!

!

line con 0

logging synchronous

speed 115200

line aux 0

line vty 0 4

login

!

end

Hall of Fame Super Gold

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

Hi,

config seems correct, except that probably you don't need "mac-address x.x.x" and "client-id FastEthernet0" under BVI 0. For safety, please add "ip nat outside" under int ATM0. Technically that should not be necessary, but I've seen cases in which it was.

In any case you should be able to ping any address once BVI1 get an address as you shown above. And, "show ip route" should reveal which is the default gateway, etc..

New Member

Re: Cisco 1721 Router with ADSL-WIC Connection Problem w/Verizon

IT WORKS!!! Thanks for your time with this I really appreciate it. I will post a rating for you.

1402
Views
5
Helpful
16
Replies
CreatePlease to create content