Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 1812 with redundant connections to a two-member 3750 stack

I run two 3750G in a stack config and a 1812 router as gateway to the outside world (inet, vpn). I'd love to hook the 1812 to both the 3750 members to be redundant in case one of the 3750 breaks.

Now there are quite a few vlans configured on the 3750 and in the current setup with RSTP active and two links connected (trunks) the 1812 gives me warnings about a vlan limit that is reached (8 I believe).

Now what I would love to know is the "best-practice"-way to connect the 1812-K9 redundantly to the 3750.

I'd love to use an etherchannel, but that is not supported by the 1812 I believe.

THX a lot !

6 REPLIES

Re: Cisco 1812 with redundant connections to a two-member 3750 s

Hi there,

Are you using the 1812 for the inter-vlan routing? The 3750's would make a much better job of it.

I would move the default-gateways from the 1812 to the 3750's, probably using GLBP or HRSP. Then I would put a routed ink between each 3750 and the 1812.

I would then put a static route on the 3750's pointing a default gateway to each of the routed addresses of the 1812.

!! OR !!

If your 1812 has got the 8 port switch on the back, then you can connect a port to each of the 3750's and create a vlan on the router, give it an IP address and make that the default gateway for the 3750's. You would still move the vlan default-gateways to the 3750's. This would involve spanning tree though, but it would not be a problem.

Hope that helps,

LH

New Member

Re: Cisco 1812 with redundant connections to a two-member 3750 s

thx for the reply.

2nd possiblity is exactly how I did it. I created a vlan on the router as "transfer-lan" and then put a single port of each 3750-stack-member in this vlan ... now they both have the same transfer net to use, with RSTP of course.

The only problem is that with a trunk enabled the router doesn't like the amound of vlans ... I might just disable the trunk feature and put the router-ports as well as the switch (3750) ports in just that single vlan.

I thought there might be a better, cleaner way of doign this "transfer-net" thing on layer3.

thx for your reply again

Re: Cisco 1812 with redundant connections to a two-member 3750 s

Hey there,

Try this for a configuration:-

3750 stack - - - - - 1800

On the interface between the 3750 and the 1800:-

int f1/0/1 (or whichever)

no switchport

des ** Link to 1800 **

ip add 1.1.1.1 255.255.255.252

exit

ip routing

ip route 0.0.0.0 0.0.0.0 1.1.1.2

On the 1800 port, put in this sort of thing:-

int f0/0

des ** Link to 3750 stack **

ip add 1.1.1.2 255.255.255.252

exit

ip route the.networks.on.3750stack 1.1.1.1

The on the 3750, you create a layer 3 vlan interface in each of the vlans and give them the IP address of the default gateways that are currently sitting on the 1800.

That way, the 3750 will do the intervlan routing, which it will do a lot faster than the 1800.

You can either run a static route to and from the 3750 and the 1800 or you could run a routing protocol - your choice, both would be fine, but you would need a default route to the 1800.

The link between the two nodes is not a trunk it would now be a routed (layer 3) link. All of the intervlan processing would be done on the 3750's and the 1800 would not complain about vlans, as it wold never see them.

Hope that helps,

LH

Please rate all posts

New Member

Re: Cisco 1812 with redundant connections to a two-member 3750 s

thx very much for your reply.

The intention was to hook the 3750 members redundantly to the 1812 router. I now use L2 and RSTP to do so ... well I was just unsure about this being the way to do it.

I don't quite get your suggestion about a "Layer 3 vlan" and all ...

1.There got to be two physical interfaces of the 3750 connected to ports of the 1812.

2.This would create a loop on layer 2

3.ways around it: 802.3ad, (R)STP, going up to layer3

Could you please explain your config a little further ...

thx again

Re: Cisco 1812 with redundant connections to a two-member 3750 s

Hi there,

You need to look at it in a different manner.

If you did not have the 1800, then it would still be possible to do the intervlan routing on the 3750:-

pc1 10.0.0.1 - - - 10.0.0.254 - 3750 - 11.0.0.254 - - - - pc2 11.0.0.1

In this setup, you would set the PC IP addresses and put the default gateways as show in the diagram (1x.0.0.254).

On the 3750, you would configure the vlans and the layer 3 vlans like this:-

conf t

! --- Create vlan 10

vlan 10

name Vlan_10_Users

state active

! --- Create vlan 11

vlan 11

name Vlan_11_Users

state active

! --- Setup layer 3 vlan for 10

interface vlan 10

ip add 10.0.0.254 255.255.255.0

des ** Default gateway for vlan 10 **

! --- Setup layer 3 vlan for 11

interface vlan 11

ip add 11.0.x.x.255.255.0

des ** Default gateway for vlan 11 **

! --- Setup port for PC 1

interface f1/0/1

des ** Link to vlan 10 User **

switchport mode access

switchport access vlan 10

! --- Setup port for PC 2

interface f2/0/1

des ** Link to vlan 11 User **

switchport mode access

switchport access vlan 11

! --- turn on routing and CEF

ip routing

ip cef

That will do it. You will then have the 3750 running as the default gateway for the vlans. , without the 1800, configuring like this will stop all of the vlan issues on the 1800 and will increase performance, as the 3750 will not have to pass data to the 1800 and will make a quicker job of inter vlan routing.

You will then need to add in the 1800, which I presume is the default gateway. There are a few ways of doing this and the best one will be the one that you're most comfortable with.

For connectivity you can either have 2 x switched ports connected, or 2 x routed ports connected. If you have switched links, then you will need to run spanning tree and will only get the use of 1 link at a time. If you run 2 x routed connections, then you will have twice the throughput - whichever you are most comfortable with is the best.

For end to end IP you will need to tell the 3750 about the routes/networks on the 1800 (or give it a default route) and tell the 1800 about the routes/networks on the 3750. You can either do this with static routes, or with a routing protocol, again - whichever you are most comfortable with is the best.

Personally, I would go for 2 x routed links and a routing protocol, probably ripv2, depending on the software version of your 3750.

As a test, configure up 2 new vlans on the 3750 and put in 2 test PC's to see how the 3750 config would work. Then when you're happy, have a look at the 1800 config.

Hope that helps,

LH

Please rate all posts

Silver

Re: Cisco 1812 with redundant connections to a two-member 3750 s

Best practice is to do an etherchannel between the router and 3750 stack switch. In this way you will load balance and failover from one link to the other in case of failure.

Regards,

507
Views
3
Helpful
6
Replies