cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
961
Views
0
Helpful
2
Replies

Cisco 2611 Async Modem Dial Configuration??

Domwilko_2
Level 1
Level 1

OK I'm trying to configure my 2611 to dial out on a modem connected to one of the serial interfaces on a WIC-2T module. So here is the scenario:

Cisco 2611 with a WIC-2T (Sync/Async) interface module fitted. CAB-SS-232MT cable fitted between Serial 0/1 and standard 56K modem.

So far I have configured Serial 0/1 as follows:

interface Serial0/1

physical-layer async

ip address negotiated

encapsulation ppp

dialer in-band

dialer-group 1

async mode dedicated

ppp authentication chap callin

Now I just need to work out how to configure the Dialer configuration. I know I need to configure the 'Chat-Script', which I believe contains the modem AT commands and somewhere I need to include the Username and Password details for the CHAP authentication.

The ultimate aim is for me to configure a static route something similar to below:

ip route 192.168.20.0 255.255.255.0 Dialer1

Whereby any traffic routed to the 192.168.20.0/24 network will cause Dialer1 to initiate the call on the modem connected to Serial 0/1, authenticate with the remote network and then route traffic.

Does anyone have any ideas? or sample configurations?

Any help appreciated.

2 Replies 2

tepatel
Cisco Employee
Cisco Employee

WIC-2T will not support Async connection..You may have WIC-2A/S card which is described in following url

http://www.cisco.com/warp/public/107/wic-2as.shtml

Now configuring it to dialout is just like configuring DDR using a modem connected to a router..You may not need a dialer interfcae, you can just configure the dialer map command if you know the name and ip address of the other side interface. Then just add one command under serial interface like

dialer map ip 1.1.1.1 name abcd 123456

where 1.1.1.1 is ip address of the other side interface and "abcd" is the name and 123456 is telephone number

Vwer similar config which is discused in following url for interface serial 2.

http://www.cisco.com/warp/public/793/access_dial/async_backup_14281.html

Or you can use the similar config as described in

http://www.cisco.com/warp/public/471/mod-aux-dialout.html

Tejal

Tejal,

I'm sorry to say that the WIC-2T does support Async connections. I actually managed to work out the config in the end. I've posted it below for your information. It works perfectly and provides a dial on demand solution for me.

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Cisco2610-England

!

enable password 7 xxxxxxxxxxxxx

!

!

!

!

!

memory-size iomem 20

ip subnet-zero

no ip domain-lookup

!

!

!

!

interface Ethernet0/0

description +++Connected To Local LAN+++

ip address 192.168.26.11 255.255.255.0

!

interface Serial0/0

description +++Connected To Cisco3620-Scotland+++

bandwidth 100000

ip address 10.100.200.9 255.255.255.252

!

interface BRI0/0

no ip address

shutdown

!

interface Serial0/1

physical-layer async

description +++Connected To 56K Modem+++

no ip address

encapsulation ppp

dialer in-band

dialer rotary-group 1

async mode dedicated

no cdp enable

!

interface Dialer1

description +++Modem Dialer To Private Network+++

ip address negotiated

encapsulation ppp

dialer in-band

dialer string 0800xxxxxxx

dialer hold-queue 10

dialer-group 1

pulse-time 3

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxx password 7 xxxxxxxxxxxxxxxxx

!

router eigrp 1

redistribute connected

passive-interface Dialer1

network 10.0.0.0

network 192.168.26.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.100.200.10

ip route 10.240.12.254 255.255.255.255 Dialer1

no ip http server

!

dialer-list 1 protocol ip permit

snmp-server engineID local 000000090200003080A6E3C0

snmp-server community xxxxxxxx RO

snmp-server packetsize 2048

snmp-server location xxxxxxxxxxx

snmp-server contact xxxxxxxxxxxx

!

line con 0

exec-timeout 0 0

password 7 xxxxxxxxxxx

login

transport input none

line 2

modem InOut

modem autoconfigure type default

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

password 7 xxxxxxxxxxx

login

!

no scheduler allocate

end

Regards,

Dominic Wilkinson

CCNA, CCDA