Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2950 / 2811 connectivity issue

I'm connecting a 2811 router to a 2950 switch with an 802.1q trunk carrying 4 Vlans. All is well if the router is booted before the switch. However if the switch is booted first, proper connectivity doesn't happen. Pings between the two devices are sporadic. Also if the router is rebooted after the switch is up, pings between the two again become sporadic.

Any ideas - I'm at a loss to solve this one.

2811 is running IPVOICE - IOS 12.4 (5)

2950 is running IOS 12.1 (22)EA6

Router config on flaky link:

-------------------------------------

interface FastEthernet0/0

description Trunk to P3BRSW

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.115

encapsulation dot1Q 115

ip address 10.3.115.1 255.255.255.0

ip helper-address 10.1.10.10

no snmp trap link-status

!

interface FastEthernet0/0.116

encapsulation dot1Q 116

ip address 10.3.116.1 255.255.255.0

ip helper-address 10.1.10.10

no snmp trap link-status

!

interface FastEthernet0/0.155

encapsulation dot1Q 155

ip address 10.3.155.1 255.255.255.0

ip helper-address 10.1.10.10

no snmp trap link-status

!

interface FastEthernet0/0.156

encapsulation dot1Q 156

ip address 10.3.156.1 255.255.255.0

ip helper-address 10.1.10.10

no snmp trap link-status

---------------

Cat 2950 config on flaky link:

interface FastEthernet0/24

description Trunk to P3BRR

switchport trunk allowed vlan 115,116,155,156

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

spanning-tree portfast

end

The switch's management address is in Vlan 115

Any / all ideas very welcome.

Thanks

2 REPLIES
Purple

Re: Cisco 2950 / 2811 connectivity issue

Hi,

Your interface config looks okay.. However, that may not be the issue.

When you say that you are getting sporadic pings, which 2 points are you pinging between ?

Paresh

VIP Purple

Re: Cisco 2950 / 2811 connectivity issue

Hello,

I wonder if turning off ´spanning-tree portfast´ on the 2950 trunk port makes a difference (´no spanning-tree portfast). Is the 2950 connected to another device ? If this is the only link between your devices, you might want to try and turn off spanning tree alltogether on the 2950 (no spanning-tree vlan x)...

Regards,

GP

496
Views
0
Helpful
2
Replies