Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 2950 IP address problems

Hello there

I wonder if anyone has experienced the same and if so would mind advising how they solved the problem! This is long, but please read through it, its a very, very strange one.

I have recently installed a 2950 onto my network it replaced a 2924 as we needed more switch ports. It is IOS version 12.1(9)EA1 and has a fairly simple configuration. VLAN1 interface is shutdown, VLAN10 is up and configured with an IP address for management. Gigabit0/1 interface is connected via SXfibre module to a 6509 chassis. This connection is configured as a Dot1q trunk. All fastethernet ports on 2950 are switchport access vlan10. Everything seems to work fine. I plug my laptop into anyone of the switchports and log onto our network fine. However after approx 2 hours Im unable to ping the IP address of VLAN10 on the 2950. Layer 2 is all working fine so if my connect my laptop to an ethernet port I log into the network with no problems. The remote 6509 still sees the neighbor as ok (we use CDP) and everything looks fine.

From the console port of the switch I see VLAN10 as UP UP and I even ping myself ok but only when consoled in. Im unable to ping out to any other device though and no other remote device can reach me with ping or telnet (so I think TCP/IP in general). If I simply reset the switch though everythings back to normal again and I can telnet in from my PC on my desk and ping the VLAN10 interface IP address from anywhere on the LAN.

Approx 2 hours later Im kicked out again and am unable to ping the VLAN10 interface once more. Switch ok though and happily switching so users plugged into it get no problems at all. I've found nothing conclusive at all by leaving some debugs on and while it isn't a major problem because it doesn't effect users, its driving me crazy as to why it happens and our snmp management console keeps paging me when it loses IP connection (as it uses ping to poll and so assumes its down!).

I've read so much about problems with 2950 management interfaces but I can't quite put my finger on why after a reboot I get about 2 hours TCP/IP service and then something goes wrong with it once again. I've tried replacing it with another 2950, same IOS, configured it up from scratch even gave the VLAN10 interface a different IP address - same problem occured.

I've also tried via the console port to shutdown the interface VLAN10 and bring it back up again, comes back and shows as line UP protocol UP but you aren't able to ping. Only the reboot brings it back for a fairly short time frame.

Any ideas or pointers, much, much appreciated.

Thanks in advance

Joe Good

network co-ordinator

Ipswich Hospital.

3 REPLIES
New Member

Re: Cisco 2950 IP address problems

Are you using Spanning-tree and\or HSRP at your distribution layer 6509's?

Anonymous
N/A

Re: Cisco 2950 IP address problems

Thanks for your reply - We do use spanning tree yes. Im not sure what spanning tree would do to the IP address though as we are talking about layer 2 here and that always functions fine. However any suggestion's most welcome!

We do have HSRP running between our pair of 6509's.

By default the switches default gateways are the HSRP address shared between the 6509's which is typically .1 of the relevant subnet. I've also tried pointing the switch's default gateway (the one Im having problems with) at the actual VLAN interface address of the MSFC card on one of the 6509's and not the shared address - however this made no difference.

Do you know what the particular issues are with HSRP and the 2950's ?

Thanks again

Joe Good

New Member

Re: Cisco 2950 IP address problems

Hello,

Exactly the same problem at customer (same version, same hardware).

Aftyer search, find bug here :

http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCdx26212&cco_product=IOS&fset=&swver=12.1&keyw=arp&target=9&train=EA1

Regards

251
Views
0
Helpful
3
Replies
CreatePlease to create content