Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 2950 using dhcp on the 2950 XL Switch

I have a basic question, having a cable modem is it possible to connect i w/ Cisco 2950 using dhcp on the 2950XL and distribute to a server and 9 wrkst without a cisco router connected ?

My client has a Linksys broadband router with a firewall builtin placed after the cable modem and bought this 2950 XL Switch that he wants to use.

Not sure how that works.

Thx

4 REPLIES
Bronze

Re: Cisco 2950 using dhcp on the 2950 XL Switch

If the Linksys router is acting as a DHCP server and is connected to the same VLAN on the 2950 that the workstations and server are connected to, you'll be good to go. I'd suggest enabling 'portfast' on the 2950's ports, however, to avoid the DHCP problems that it can sometimes cause. Check the documentation for more details.

New Member

Re: Cisco 2950 using dhcp on the 2950 XL Switch

Basically what you saying is the config on the 2950 would be just to enable VLAN 1 and all 24 ports without assigning any IP's, port 1 or 24 for the uplink and the rest of the ports for the LAN on the switch correct?

Preferable I was trying to eliminate the Linksys router since I have a set of 14 usable IP's from the ISP, but that didn't work without the Linksys since the ISP router is not manageable.

I was wondering if you could sugest or have a config on the 2950 that I could use for the purpose so I can use a fixed IP for the DMZ between the ISP router and the switch and a fixed IP for my tftp server as well.

I can still use the Linksys just as a DMZ (65.209.60.17) and not use as DHCP server the rest of the network will use 65.209.60.18 as gateway 19 for the server and so on.

Here is the IP's 65.209.60.17 to 31 mask 255.255.255.240.

Thx so much for your feedback

New Member

Re: Cisco 2950 using dhcp on the 2950 XL Switch

I didn't here any feedback to my question ...anyone ...please !!

I like to eliminate the Linksys router and use the 2950 only .....

Thx

New Member

Re: Cisco 2950 using dhcp on the 2950 XL Switch

The 2950 is not a router. Even with the enhanced image, it will not be able to move a packet from one subnet to another. Ignore DHCP in the question, since that is unrelated to your desire to not use the Linksys router.

You mentioned that you only had 14 addresses from your provider. If you need more addresses than that, you will need to use NAT or beg your provider for more. A DMZ would be nice, if you have external servers, but you might consider using NAT for your client machines that do not need external global IPs and private addresses for them, while reserving the 14 addresses for the DMZ.

Consider this... Connect your provider to fa 0/1. Connect the Linksys to fa 0/2 and fa 0/3. Configure the interface vlans as follows:

vlan 2

name DMZ

vlan 3

name Internal-Private

ip dhcp excluded-address 10.0.1.17

ip dhcp pool Internal-Private

default-router 10.0.1.1

dns-server

network 10.0.1.0 255.255.255.0

domain-name .private (or .local)

lease 5

exit

interface range fa 0/1 - 2

switchport access vlan 2

interface fa 0/3

switchport access vlan 3

end

wr

---

Now make sure the linksys external wan interface is connected to fa 0/2 and the internal interface is connected to fa 0/3, set up the linksys router so that it will route between the two interfaces and perform NAT. I would actually consider using the linksys device for dhcp, instead of the 2950. Make sure that the internal network address range matches on the linksys and the dhcp pool addresses.

Next, for DMZ hosts, connect them to the 2950 and put them in vlan 2, for all other hosts, put them in vlan 3. What you have now, is the best you will get with your current equipment. You could be a Cisco 800 router and connect it to the 2950 with an 802.1q trunk, and have a router on a stick. It can do your routing for you. You could have multiple internal subnets using NAT and RFC 1918 space, or you could subnet your 14 addresses into a few smaller subnets, not too many, though. You might be able to get four /30s. It would not be worth it, so I am not going to do the calculations to come up with the address ranges for that.

160
Views
5
Helpful
4
Replies