Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 3550-48-EMI VLAN routing issue...

Hi all,

Here's out network layout;

Nokia IP120 Firewall

| (10.140.100.254)

|

|(10.140.100.253) VLAN 100

+-----------------+

| 3550-48-EMI|--------VLAN90 (10.140.90.254)--------

+-----------------+

|(10.140.110.254) VLAN 110

|

I have two workstations at each subnet(VLAN110 & 100) has default gateway of their VLAN IP address. How can I make each VLANs routable? I tried to ping from the workstation at VLAN 110 to 90(or vice versa) but it's not working for some reasons. Could you please review its configuration and correct the issues? Thank you very much for your help in advance.

- Jon

!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname NPBC0001

!

enable secret xxxxx

enable password xxxx

!

ip subnet-zero

!

spanning-tree extend system-id

!

interface FastEthernet0/1

no switchport

no ip address

!

interface FastEthernet0/2

switchport access vlan 90

no ip address

!

interface FastEthernet0/3

switchport access vlan 90

no ip address

!

interface FastEthernet0/4

switchport access vlan 110

no ip address

!

interface FastEthernet0/5

switchport access vlan 100

no ip address

!

-------------------------------------------

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan100

ip address 10.140.100.253 255.255.255.0

!

interface Vlan90

ip address 10.140.90.254 255.255.255.0

!

interface Vlan110

ip address 10.140.110.254 255.255.255.0

!

ip default-gateway 10.140.100.254

ip classless

ip http server

!

!

!

password xxx

login

line vty 5 15

password xxxx

login

!

end

6 REPLIES
New Member

Re: Cisco 3550-48-EMI VLAN routing issue...

Hi Jon,

Have you configured your V-lan´s in your V-lan database yet? (show vlan)

If not, you can do so with the "vlan database" command in enable mode att the promt in your Catalyst 3550.

Regards,

Kalle

Re: Cisco 3550-48-EMI VLAN routing issue...

Hi,

is there "ip routing" command present in the config?

Regards,

Milan

Bronze

Re: Cisco 3550-48-EMI VLAN routing issue...

Just to add, are you able to ping between workstations on VLAN 90? I was just thinking why don't you have the 'switchport mode access' command under the FastEthernet interfaces configured as Layer 2 interfaces. I believe you need this command since you have configured static-access VLANs.

New Member

Re: Cisco 3550-48-EMI VLAN routing issue...

First of all, thanks for your solution. Just simple adding 'ip routing' command and 'switchport mode access' to interface simply resolved this issues.

I can ping to any hosts from different VLANs but it seems that any hosts that resides in VLAN, cannot hit the internet at all.

Do I need to add static route(to the internet) to switch configuration?

Please let me know.

Thanks.

- Jon

Gold

Re: Cisco 3550-48-EMI VLAN routing issue...

Jon,

Yes, once you turned on "ip routing" the "ip default-gateway" command ceased to be useful. (The "ip default-gateway" command is for routers, switches, etc., that have IP routing turned off and are just acting as IP hosts.)

Go into config, add "ip route 0.0.0.0 0.0.0.0 10.140.100.254", save your configuration, and you're on your way. See you on the Internet...

Hope this helps.

New Member

Re: Cisco 3550-48-EMI VLAN routing issue...

Thanks guys.

All the issues has been resolved.

I really appreciated your help.

- Jon

145
Views
3
Helpful
6
Replies