Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 3560 boot loader upgrade

I am writing to see if any of the experts can give advice on how to upgrade the boot loader version on a Catalyst 3560 switch? I have tried installed the software through a tar archive download-sw, I have tried copying the IOS bin file only, I have tried first upgrading and then downgrading the software as well as the opposite. I have even tried to format the flash and copy the IOS through xmodem to see if that would force the upgrade. 

 

I am trying to get to this bootloader for specific reasons. Version 12.2(53r)SEY4

I have two switches running the exact same IOS and one is running Version 12.2(50r)SE as the bootloader version while the other is running Version 12.2(53r)SEY4.

The IOS on both devices is Version 12.2(53)SE2 but regardless of this the bootloader remains a different version. I have tried to research but there seems to be very little information about upgrading bootloader software on Cisco switches.

Can anyone provide any insight? Let me know if you need any additional information and I'd be glad to provide that as well.

6 REPLIES
Hall of Fame Super Gold

Don't bother about what

Don't bother about what bootloader version you've got.  At the end of the day, it won't make any difference.  

 

The bootloader version will depend entirely on what IOS your appliance is running.  Bootloader gets upgraded when you upgrade IOS from 12.2(50)SE up to 12.2(58)SE.  Your bootloader will also get upgraded if you run 15.X IOS.  

New Member

Leo,Thank you for replying.

Leo,

Thank you for replying. Unfortunately I am seeing that the bootloader version is having an affect on one action. I have everything identical between two switches and one will allow me to break the boot sequence remotely and the other one is refusing to break despite the configuration being the same. The only noticeable difference that I can see is that the bootloader version is different on them. I have tried upgrading to different IOS versions, specifically 15.1 and it still refused to upgrade the bootloader.

Is there anything else that I should be trying?

Hall of Fame Super Gold

If you can't break the boot

If you can't break the boot sequence, then maybe the "service password-recovery" is disabled.

New Member

Here is output from the

Here is output from the switch that is not working.

CAT4>

Using driver version 1 for media type 1
Base ethernet MAC Address: a4:18:75:2a:56:80
Xmodem file system is available.
The password-recovery mechanism is enabled.
Initializing Flash
telnet> send Break
...
mifs[2]: 0 files, 1 directories
mifs[2]: Total bytes     :    3870720
mifs[2]: Bytes used      :       1024
mifs[2]: Bytes available :    3869696
mifs[2]: mifs fsck took 0 seconds.
mifs[3]: 4 files, 1 directories
mifs[3]: Total bytes     :   27998208
mifs[3]: Bytes used      :   12595712
mifs[3]: Bytes available :   15402496
mifs[3]: mifs fsck took 4 seconds.
...done Initializing Flash
telnet> send Break
.
done.
Loading "flash:c3560-ipservicesk9-mz.122-53.SE2.bin"

 

And the one that is:

CAT3>
Using driver version 1 for media type 1
Base ethernet MAC Address: 54:78:1a:1f:91:80
Xmodem file system is available.
The password-recovery mechanism is enabled.
Initializing Flash.
telnet> send Break
..
mifs[2]: filesystem check interrupted!
...done Initializing Flash.

telnet> send Break

The system has been interrupted, or encountered an error
during initializion of the flash filesystem.  The following
commands will initialize the flash filesystem, and finish
loading the operating system software:

    flash_init
    boot


switch:

And show boot/show ver from Cat3

CAT3#sh boot
BOOT path-list      :
Config file         : flash:/config.text
Private Config file : flash:/private-config.text
Enable Break        : yes
Manual Boot         : no
HELPER path-list    :
Auto upgrade        : yes
Auto upgrade path   :
Timeout for Config
          Download:    0 seconds
Config Download
       via DHCP:       disabled (next boot: disabled)
CAT3#sh ver
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(53)SE2, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 21-Apr-10 05:33 by prod_rel_team
Image text-base: 0x01000000, data-base: 0x02E00000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(53r)SEY4, RELEASE SOFTWARE (fc1)

 

And Cat4:

CAT4#sh boot
BOOT path-list      : flash:c3560-ipservicesk9-mz.122-53.SE2.bin
Config file         : flash:/config.text
Private Config file : flash:/private-config.text
Enable Break        : yes
Manual Boot         : no
HELPER path-list    :
Auto upgrade        : yes
Auto upgrade path   :
Timeout for Config
          Download:    0 seconds
Config Download
       via DHCP:       disabled (next boot: disabled)
CAT4#sh ver
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(53)SE2, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 21-Apr-10 05:33 by prod_rel_team
Image text-base: 0x01000000, data-base: 0x02E00000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(50r)SE, RELEASE SOFTWARE (fc1)

 

 

Since I  have not been able to fix the issue I cannot guarantee 100% that it is the problem, but I have tested around 10 switches with the boot loader version 12.2(53r)SEY4 and they have worked every time. I have also tested around 5 or 6 with 12.2(50r)SE and they have failed every time. 

Hall of Fame Super Gold

Upgrade to IOS version 12.2

Upgrade to IOS version 12.2(55)SE9 and see if you find some improvements.

New Member

I am experiencing the same

I am experiencing the same issue.  I have also tried upgrading IOS to 12.2(55)SE9 and also 15.X but with no success.  Boot simply says boot loader upgrade is not required.

has anyone found a solution to this?

465
Views
0
Helpful
6
Replies