Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 3620 CSM modem allocation

I have a 3620 with a dual e1/10-100 card and a 30 dmc module. My pri circuit is fractionalised with 10 channels. The unit is configured with basic dial access and authentication via radius. Modem line 33 62 is configured for modem inout and the serial int0/0:15 is configured for isdn incoming voice. On the first attempt at connection to the box it authenticates fine and assigns an ip config to the dial in user. However every other attempt at connection it fails with the message 'CSM: Modem is already in csm pool'. When listening via handset it seems like an isdn call only (cant verify though). Its not the circuit because i can put an Intel d56 in place and its fine. Software rel 12.1.1(T) is used and have tried various firmware for the modems with no luck. Cant find any refernce on the cisco site for this message. Any help appreciated !

4 REPLIES
Cisco Employee

Re: Cisco 3620 CSM modem allocation

We need to see the call flow in 3600 when the 2nd call comes in..Following debug will help

debug isdn q931

debug modem csm

debug modem

term mon

Pl. post it with sh run..Thanks..Tejal

New Member

Re: Cisco 3620 CSM modem allocation

Tejal,

Thanks for the reply. The present conf for the unit is -

Cisco1#sho conf

Using 2171 out of 30712 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Cisco1

!

logging buffered 4096 debugging

aaa new-model

aaa authentication login default none

aaa authentication login CONSOLE none

aaa authentication login USERS group radius

aaa authentication ppp USERS group radius

aaa accounting exec default stop-only group radius

aaa accounting commands 1 default stop-only group radius

aaa accounting commands 15 default wait-start group radius

aaa accounting network default start-stop group radius

aaa accounting connection default start-stop group radius

aaa accounting system default start-stop group radius

enable password cisco

!

!

!

!

!

no ip subnet-zero

ip domain-name scotcourts.gov.uk

!

isdn switch-type primary-net5

!

!

controller E1 0/0

pri-group timeslots 1-10,16

!

!

interface Loopback0

ip address 10.1.1.1 255.255.240.0

!

interface FastEthernet0/0

ip address 172.16.37.151 255.255.240.0

duplex auto

speed auto

!

interface Serial0/0:15

no ip address

encapsulation ppp

ip mroute-cache

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

async mode interactive

peer default ip address pool default

no fair-queue

no cdp enable

ppp authentication chap pap USERS

group-range 33 62

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer idle-timeout 3600

dialer-group 1

peer default ip address pool default

no fair-queue

no cdp enable

ppp authentication chap pap

!

ip local pool 172.16.47.140 172.16.47.169

ip default-gateway 172.16.33.1

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

radius-server host 172.16.37.154 auth-port 1645 acct-port 1646

radius-server retransmit 3

radius-server timeout 120

radius-server key ripcurl

!

line con 0

login authentication CONSOLE

transport input pad v120 telnet rlogin

speed 115200

line 33 62

exec-timeout 0 0

autoselect during-login

autoselect ppp

login authentication USERS

modem InOut

line aux 0

line vty 0 4

transport input pad v120 telnet rlogin

!

end

I have a timeslot today in order to gather call flow traces as described.

thanks

Gary

New Member

Re: Cisco 3620 CSM modem allocation

Tejal,

These are the debugs from the traces -

This first sequence shows the first call to the box, succesful trainup and the Radius server answers. Please note authentication fails because i do not have a Securid token for the ACE/Radius server.

Cisco1#debug isdn q931

ISDN Q931 packets debugging is on

Cisco1#debug modem cswm

^

% Invalid input detected at '^' marker.

Cisco1#debug modem csm

Modem Management Call Switching Module debugging is on

Cisco1#debug modem

Modem control/process activation debugging is on

Cisco1#term mon

% Console already monitors

Cisco1#clear log

Clear logging buffer [confirm]

Cisco1#

00:01:53: ISDN Se0/0:15: RX <- SETUP pd = 8 callref = 0x0001

00:01:53: Sending Complete

00:01:53: Bearer Capability i = 0x8090A3

00:01:53: Channel ID i = 0xA98381

00:01:53: Called Party Number i = 0x81, '284177', Plan:ISDN, Type:Unknow

n

00:01:53: CSM: MODEM_REPORT from 0/0:0, call_id=0x1, event=0x1, cause=0x0, dchan

_idb=0x610E40B0

00:01:53: CSM: Next free modem = 1/0; statbits = 10020

00:01:53: Modem 1/0 CSM: modem is allocated, modems free=29

00:01:53: Modem 1/0 CSM: Incoming call from Unknown to 284177, id 0x1

00:01:53: Modem 1/0 CSM: (CSM_PROC_IDLE)<--ISDN_CALL

00:01:53: ISDN Se0/0:15: TX -> CALL_PROC pd = 8 callref = 0x8001

00:01:53: Channel ID i = 0xA98381

00:01:53: ISDN Se0/0:15: TX -> ALERTING pd = 8 callref = 0x8001

00:01:53: ISDN Se0/0:15: TX -> CONNECT pd = 8 callref = 0x8001

00:01:53: ISDN Se0/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x0001

00:01:53: ISDN Se0/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x1, bchan -1, ds

l 0

00:01:53: CSM: MODEM_REPORT from 0/0:0, call_id=0x1, event=0x4, cause=0x0, dchan

_idb=0x610E40B0

00:01:53: Modem 1/0 CSM: MODEM_REPORT rcvd DEV_CONNECTED for call_id 0x1

00:01:53: Modem 1/0 CSM: (CSM_PROC_MODEM_RESERVED)<--ISDN_CONNECTED

00:01:53: Modem 1/0 Mica: configured for Answer mode, with Null signaling, 0x0 t

one detection.

00:01:53: Modem 1/0 Mica: in modem state CALL_SETUP

00:01:54: Modem 1/0 Mica: in modem state CONNECT

00:01:59: Modem 1/0 Mica: in modem state LINK

00:02:08: Modem 1/0 Mica: in modem state TRAINUP

00:02:09: Modem 1/0 Mica: in modem state EC_NEGOTIATING

00:02:10: Modem 1/0 CSM: (CSM_PROC_WAIT_FOR_CARRIER)<--MODEM_CONNECTED

00:02:10: Modem 1/0 Mica: in modem state STEADY

00:02:10: Modem 1/0 Mica: CONNECT at 33600/33600 (Tx/Rx), V34+, LAPM, V42bis

00:02:10: TTY33: DSR came up

00:02:10: tty33: Modem: IDLE->(unknown)

00:02:10: TTY33: EXEC creation

00:02:10: TTY33: set timer type 10, 30 seconds

00:02:12: TTY33: Autoselect(2) sample 7E

00:02:12: TTY33: Autoselect(2) sample 7EFF

00:02:12: TTY33: Autoselect(2) sample 7EFF7D

00:02:12: TTY33: Autoselect(2) sample 7EFF7D23

00:02:12: TTY33 Autoselect cmd: ppp negotiate

00:02:12: TTY33: EXEC creation

00:02:12: TTY33: no timer type 1 to destroy

00:02:12: TTY33: no timer type 0 to destroy

00:02:14: %LINK-3-UPDOWN: Interface Async33, changed state to up

00:02:19: Modem 1/0 Mica: PPP escape_map: Tx map = 0, Rx map = 0

00:02:59: Modem 1/0 Mica: in modem state TERMINATING

00:02:59: Modem 1/0 CSM: (CSM_PROC_CONNECTED)<--MODEM_DISCONNECTED

00:02:59: Modem 1/0 Mica: in modem state IDLE

00:02:59: Modem 1/0 CSM: (CSM_PROC_CONNECTED)<--QUEUED_DISCONNECT

00:02:59: %ISDN-6-DISCONNECT: Interface Serial0/0:0 disconnected from unknown ,

call lasted 66 seconds

00:02:59: ISDN Se0/0:15: TX -> DISCONNECT pd = 8 callref = 0x8001

00:02:59: Cause i = 0x8090 - Normal call clearing

00:02:59: Modem 1/0 Mica: DISCONNECT after 00:01:05, due to reason (0xA220) EC r

cvd DISC frame.

00:03:00: ISDN Se0/0:15: RX <- RELEASE pd = 8 callref = 0x0001

00:03:00: ISDN Se0/0:15: TX -> RELEASE_COMP pd = 8 callref = 0x8001

00:03:00: TTY33: DSR was dropped

00:03:00: tty33: Modem: READY->(unknown)

00:03:01: TTY33: dropping DTR, hanging up

00:03:01: Modem 1/0 CSM: (CSM_PROC_IDLE)<--ASYNC_DTR_DOWN

00:03:01: TTY33: Async Int reset: Dropping DTR

00:03:01: Modem 1/0 CSM: (CSM_PROC_IDLE)<--ASYNC_DTR_DOWN

00:03:01: tty33: Modem: HANGUP->(unknown)

00:03:02: TTY33: cleanup pending. Delaying DTR

00:03:03: %LINK-5-CHANGED: Interface Async33, changed state to reset

00:03:03: TTY33: cleanup pending. Delaying DTR

00:03:04: TTY33: cleanup pending. Delaying DTR

00:03:05: TTY33: cleanup pending. Delaying DTR

00:03:06: TTY33: no timer type 0 to destroy

00:03:06: TTY33: no timer type 1 to destroy

00:03:06: TTY33: no timer type 3 to destroy

00:03:06: TTY33: no timer type 4 to destroy

00:03:06: TTY33: no timer type 2 to destroy

00:03:06: Async33: allowing modem_process to continue hangup

00:03:06: TTY33: restoring DTR

00:03:06: Modem 1/0 CSM: received ASYNC_DTR_UP for line 33

00:03:08: %LINK-3-UPDOWN: Interface Async33, changed state to down

The following sequence shows an immediate call after, the modem seems to setup but does not train and therefore fails -

00:04:56: ISDN Se0/0:15: RX <- SETUP pd = 8 callref = 0x0001

00:04:56: Sending Complete

00:04:56: Bearer Capability i = 0x8090A3

00:04:56: Channel ID i = 0xA98381

00:04:56: Called Party Number i = 0x81, '284177', Plan:ISDN, Type:Unknow

n

00:04:56: CSM: MODEM_REPORT from 0/0:0, call_id=0x2, event=0x1, cause=0x0, dchan

_idb=0x610E40B0

00:04:56: CSM: Next free modem = 1/1; statbits = 10020

00:04:56: Modem 1/1 CSM: modem is allocated, modems free=29

00:04:56: Modem 1/1 CSM: Incoming call from Unknown to 284177, id 0x2

00:04:56: Modem 1/1 CSM: (CSM_PROC_IDLE)<--ISDN_CALL

00:04:56: ISDN Se0/0:15: TX -> CALL_PROC pd = 8 callref = 0x8001

00:04:56: Channel ID i = 0xA98381

00:04:56: ISDN Se0/0:15: TX -> ALERTING pd = 8 callref = 0x8001

00:04:56: ISDN Se0/0:15: TX -> CONNECT pd = 8 callref = 0x8001

00:04:56: ISDN Se0/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x0001

00:04:56: ISDN Se0/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x2, bchan -1, ds

l 0

00:04:56: CSM: MODEM_REPORT from 0/0:0, call_id=0x2, event=0x4, cause=0x0, dchan

_idb=0x610E40B0

00:04:56: Modem 1/1 CSM: MODEM_REPORT rcvd DEV_CONNECTED for call_id 0x2

00:04:56: Modem 1/1 CSM: (CSM_PROC_MODEM_RESERVED)<--ISDN_CONNECTED

00:04:56: Modem 1/1 Mica: configured for Answer mode, with Null signaling, 0x0 t

one detection.

00:04:57: Modem 1/1 Mica: in modem state CALL_SETUP

00:05:56: ISDN Se0/0:15: RX <- DISCONNECT pd = 8 callref = 0x0001

00:05:56: Cause i = 0x8290 - Normal call clearing

00:05:56: Progress Ind i = 0x8288 - In-band info or appropriate now avai

lable

00:05:56: %ISDN-6-DISCONNECT: Interface Serial0/0:0 disconnected from unknown ,

call lasted 59 seconds

00:05:56: CSM: MODEM_REPORT from 0/0:0, call_id=0x2, event=0x0, cause=0x10, dcha

n_idb=0x610E40B0

00:05:56: Modem 1/1 CSM: MODEM_REPORT rcvd DEV_IDLE for call_id 0x2

00:05:56: Modem 1/1 CSM: (CSM_PROC_WAIT_FOR_CARRIER)<--ISDN_DISCONNECTED

00:05:56: ISDN Se0/0:15: TX -> RELEASE pd = 8 callref = 0x8001

00:05:56: Modem 1/1 Mica: in modem state CONNECT

00:05:56: Modem 1/1 Mica: in modem state TERMINATING

00:05:56: ISDN Se0/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x0001

00:05:56: Modem 1/1 CSM: (CSM_PROC_DISCONNECTED)<--MODEM_DISCONNECTED

00:05:56: Modem 1/1 Mica: in modem state IDLE

00:05:56: Modem 1/1 Mica: DISCONNECT after 00:00:00, due to reason (0x6001) SOFT

WARE_RESET command.

00:05:56: Modem 1/1 CSM: (CSM_PROC_DISCONNECTED)<--QUEUED_DISCONNECT

Thanks

Gary

New Member

Re: Cisco 3620 CSM modem allocation

Does the units memory have any bearing on this ?

243
Views
0
Helpful
4
Replies