Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 3640 and ISDN Callback doesn't work

Hi,

I' m trying to configure a Cisco 3640 with 4 BRI and 12 Digital Mica Modem.

Callback with analog modem is working fine.

I' m having troubles with ISDN callback.

On ISDN q.931 debug cisco router, when it starts to call, receive the following message:

02:01:27: ISDN BR2/3: RX <- DISCONNECT pd = 8 callref = 0x97

02:01:27: Cause i = 0x80D8 - Incompatible destination

I'm using ios vers. c3640-i-mz.122-13b.bin but I also tried other IOS versions.

As ISDN TA on client I used Digicom Palladio ISDN-USB and Zyxel

This is the cisco configuration:

Router#sh run

Building configuration...

Current configuration : 2030 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

aaa new-model

aaa authentication ppp default local

aaa authorization network default local

enable secret 5 $1$2R/p$CvBEcaGMnsXTaTt9ZA3MR.

!

username test callback-dialstring "" password 0 test

ip subnet-zero

!

!

ip domain-list bocchiotti.it

no ip domain-lookup

!

isdn switch-type basic-net3

chat-script callback ABORT ERROR ABORT BUSY "" "ATDT\T" TIMEOUT 120 "CONNECT

!

!

!

interface FastEthernet0/0

ip address 128.1.5.3 255.255.0.0

no keepalive

duplex auto

speed auto

!

interface BRI2/0

no ip address

encapsulation ppp

shutdown

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication chap pap

!

interface BRI2/1

no ip address

encapsulation ppp

shutdown

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap chap

!

interface BRI2/2

no ip address

encapsulation ppp

shutdown

isdn switch-type basic-net3

isdn incoming-voice modem

!

interface BRI2/3

no ip address

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-net3

isdn incoming-voice modem

!

interface Group-Async1

physical-layer async

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer in-band

dialer callback-secure

dialer-group 1

async mode interactive

peer default ip address pool default

ppp callback accept

ppp authentication pap chap

!

interface Dialer1

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer pool 2

dialer-group 1

peer default ip address pool default

ppp callback accept

ppp authentication pap chap

!!

ip local pool default 192.168.200.100 192.168.200.130

ip classless

ip http server

ip pim bidir-enable

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

line 33 44

flush-at-activation

line aux 0

line vty 0 4

password cisco

!

end

And ISDN q.931 debug:

outer#deb isdn q931

ISDN Q931 packets debugging is on

Router#

02:01:01: ISDN BR2/3: RX <- SETUP pd = 8 callref = 0x3D

02:01:01: Bearer Capability i = 0x8890

02:01:01: Channel ID i = 0x89

02:01:01: Calling Party Number i = 0x21, 0x83, '103071401', Plan:ISDN, Type:

02:01:01: Called Party Number i = 0xA1, '103072700', Plan:ISDN, Type:Nationa

02:01:01: Sending Complete

02:01:01: ISDN BR2/3: Event: Received a DATA call from 103071401 on B1 at 64 Kb/s

02:01:01: ISDN BR2/3: Event: Accepting the call id 0x3E

02:01:01: %DIALER-6-BIND: Interface BR2/3:1 bound to profile Di1

02:01:01: %LINK-3-UPDOWN: Interface BRI2/3:1, changed state to up

02:01:03: %ISDN-6-LAYER2UP: Layer 2 for Interface BR2/3, TEI 90 changed to up

02:01:03: ISDN BR2/3: TX -> CALL_PROC pd = 8 callref = 0xBD

02:01:03: Channel ID i = 0x89

02:01:03: ISDN BR2/3: TX -> CONNECT pd = 8 callref = 0xBD

02:01:03: ISDN BR2/3: RX <- CONNECT_ACK pd = 8 callref = 0x3D

02:01:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI2/3:1, changed state to

02:01:07: %ISDN-6-CONNECT: Interface BRI2/3:1 is now connected to 103071401 sala

02:01:08: ISDN BR2/3: RX <- DISCONNECT pd = 8 callref = 0x3D

02:01:08: Cause i = 0x8090 - Normal call clearing

02:01:08: %ISDN-6-DISCONNECT: Interface BRI2/3:1 disconnected from 103071401 sala,

02:01:08: %LINK-3-UPDOWN: Interface BRI2/3:1, changed state to down

02:01:08: %DIALER-6-UNBIND: Interface BR2/3:1 unbound from profile Di1

02:01:08: ISDN BR2/3: TX -> RELEASE pd = 8 callref = 0xBD

02:01:08: Cause i = 0x8090 - Normal call clearing

02:01:08: ISDN BR2/3: RX <- RELEASE_COMP pd = 8 callref = 0x3D

02:01:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI2/3:1, changed state to

02:01:21: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR2/3, TEI 90 changed to down

02:01:23: %ISDN-6-LAYER2UP: Layer 2 for Interface BR2/3, TEI 90 changed to up

02:01:23: ISDN BR2/3: TX -> SETUP pd = 8 callref = 0x17

02:01:23: Bearer Capability i = 0x8890

02:01:23: Channel ID i = 0x83

02:01:23: Called Party Number i = 0x80, '0103071401', Plan:Unknown, Type:Unk

02:01:23: ISDN BR2/3: RX <- CALL_PROC pd = 8 callref = 0x97

02:01:23: Channel ID i = 0x8A

02:01:27: ISDN BR2/3: RX <- DISCONNECT pd = 8 callref = 0x97

02:01:27: Cause i = 0x80D8 - Incompatible destination

02:01:27: ISDN BR2/3: TX -> RELEASE pd = 8 callref = 0x17

02:01:27: Cause i = 0x80D8 - Incompatible destination

02:01:27: ISDN BR2/3: RX <- RELEASE_COMP pd = 8 callref = 0x97

02:01:41: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR2/3, TEI 90 changed to down

Thanks in advance

Marco Parmigiani

Digipoint srl

Genova- Italy

4 REPLIES
Silver

Re: Cisco 3640 and ISDN Callback doesn't work

During the call IN we see the following:

Calling Party Number '103071401', Plan:ISDN, Type:

Called Party Number '103072700', Plan:ISDN, Type:National

During CALLBACK, the number dialed is:

Called Party Number '0103071401', Plan:Unknown, Type:Unk

We see a Zero before the called number....not sure why. As a simple test try making an ISDN call from this 3640 & see if it connects with which number,

3640#isdn call interface bri2/3 0103071401

AND

3640#isdn call interface bri2/3 103071401

deb isdn q931 / deb ppp nego / deb dialer / deb callback will be helpful.

For ISDN q931 cause code:

http://www.cisco.com/warp/public/129/isdn_disc_code.html

Thanks, Mak.

New Member

Re: Cisco 3640 and ISDN Callback doesn't work

We have tested dialer string and it worked fine. The phone number we used was 0103071401.

We have tried a wrong phone number and we receive an ISDN message that the phone is bad.

We have tried a lot of debug (but not deb callback) .

When the router callback the pc no ppp negotiation start because the call stops at ISDN level.

Thanks for help

Marco

New Member

Re: Cisco 3640 and ISDN Callback doesn't work

You are using Basic-Net3 as your ISDN type, are you sure this is correct for your country? (don't know where you are located)

Something else I see that will resolve a lot of headaches later:

- Change your dialer callback to PERMIT otherwise you can have problems cancelling callback.

- Use rotary groups instead of Dialer Pools as the pools cause problems with multiple isdn users connecting. Remove the dialer pool statements and add into the BRI's dialer rotary-group 1 This points to the dialer 1 interface, where you will have to add the dialer in-band statement.

New Member

Re: Cisco 3640 and ISDN Callback doesn't work

The router is in Italy and we use Basic-Net3.

I already tried dialer callback to PERMIT and dialer rotary-group insted of dialer pool with no solution

I don't remember if I used both together, I' ll verify it again at the end of the week.

Thanks for the info

Marco Parmigiani

273
Views
0
Helpful
4
Replies
CreatePlease to create content