Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 3640 w/ NM-16AM Connection Speed Problem

Hi, the network is like that 16 branches, 8 of them using 3Com 56K Lan modem and the rest using PC modem, dialing into the 3640 w/NM-16AM (slot 1) and 10BT Ethernet (slot 0) at headquarter.

There is traffic between 2 branches, say A & B (Lan Modem branches). It is the Visual FoxPro application accessing data files on both branches' Samba Servers and the headquarter ' Samba Server.This Cisco solution is to replace the existing Linux Router w/ 2 USR Couriers (and others equipments are the same) for traffic between A & B. No problems before replacement.

The problem now is that branch A cannot open/use the data file locate on branch B for file size > 9KB or vice versa. I need to allow open/use file with size >10MB.

The application prompts a "Reading Error". It seems like time out as there is no problem accessing data file in headquarter. I tried ftp from headquarter's samba to branch B's samba. "stalled" prompted in the progress bar during ftp for several times.

The questions are :

(1) how to set the line connect at a higher speed? And, how to set the modem to auto-negotiate the line speed with the remote modem as now I set the remote modem to have speed of 38400 max otherwise no connection ? Currently, I have not set any modemcap entries but using modem autoconfigure discovery. Do I need to do so?

(2) how to optimize the performance? Will PPP compress stac be useful on concerned interfaces? Lan Modem is said to support LZS.

(3) tcp header-compression useful? Stopbits 1 ?

another question :

(4) I rack mounted the cisco 3640. Do i need to ground the Cisco 3640 chasis for the NM-16AM?

Ping result (done at a PC in headquarter)

(A) to branch A's samba server

C:\WINDOWS\Desktop>ping 10.0.40.2

Pinging 10.0.40.2 with 32 bytes of data:

Reply from 10.0.40.2: bytes=32 time=142ms TTL=62

Reply from 10.0.40.2: bytes=32 time=856ms TTL=62

Reply from 10.0.40.2: bytes=32 time=142ms TTL=62

Reply from 10.0.40.2: bytes=32 time=289ms TTL=62

Ping statistics for 10.0.40.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 142ms, Maximum = 856ms, Average = 357ms

(B) to branch B's samba server

C:\WINDOWS\Desktop>ping 10.0.41.2

Pinging 10.0.41.2 with 32 bytes of data:

Reply from 10.0.41.2: bytes=32 time=1190ms TTL=62

Reply from 10.0.41.2: bytes=32 time=1014ms TTL=62

Reply from 10.0.41.2: bytes=32 time=2869ms TTL=62

Reply from 10.0.41.2: bytes=32 time=1481ms TTL=62

Ping statistics for 10.0.41.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1014ms, Maximum = 2869ms, Average = 1638ms

Running Config

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname HQ

!

enable secret 5 $1$TKTt$.fu4jDmMA/p66S9AYmC5l.

enable password 123456

!

username user1 password 0 password1

username user2 password 0 password2

username user3 password 0 password3

username user4 password 0 password4

username user5 password 0 password5

username user6 password 0 password6

username user7 password 0 password7

username user8 password 0 password8

username user9 password 0 password9

username user10 password 0 password10

username user11 password 0 password11

username user12 password 0 password12

username user13 password 0 password13

username user14 password 0 password14

username user15 password 0 password15

username user16 password 0 password16

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 10.0.0.10 255.255.255.0

half-duplex

!

!async 33 40 : connect to Lan Modem

!async 33 : branch A -- 192.168.0.2 Lan Modem WAN IP

!async 34 : branch B -- 192.168.1.2 Lan Modem WAN IP

!

interface Async33

ip address 192.168.0.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async34

ip address 192.168.1.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async35

ip address 192.168.2.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async36

ip address 192.168.3.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async37

ip address 192.168.4.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async38

ip address 192.168.5.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async39

ip address 192.168.6.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

interface Async40

ip address 192.168.7.1 255.255.255.0

encapsulation ppp

async dynamic address

async mode dedicated

ppp authentication pap

!

!async 41 48 : connect to single PC modem

!

interface Async41

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.101

ppp authentication pap

!

interface Async42

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.102

ppp authentication pap

!

interface Async43

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.103

ppp authentication pap

!

interface Async44

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.104

ppp authentication pap

!

interface Async45

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.105

ppp authentication pap

!

interface Async46

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.106

ppp authentication pap

!

interface Async47

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.107

ppp authentication pap

!

interface Async48

ip unnumbered Ethernet0/0

encapsulation ppp

async mode dedicated

peer default ip address 10.0.0.108

ppp authentication pap

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.2

ip route 10.0.40.0 255.255.255.0 192.168.0.2

ip route 10.0.41.0 255.255.255.0 192.168.1.2

ip route 10.0.42.0 255.255.255.0 192.168.2.2

ip route 10.0.43.0 255.255.255.0 192.168.3.2

ip route 10.0.44.0 255.255.255.0 192.168.4.2

ip route 10.0.45.0 255.255.255.0 192.168.5.2

ip route 10.0.46.0 255.255.255.0 192.168.6.2

ip route 10.0.47.0 255.255.255.0 192.168.7.2

ip route 192.168.0.2 255.255.255.255 Async33

ip route 192.168.1.2 255.255.255.255 Async34

ip route 192.168.2.2 255.255.255.255 Async35

ip route 192.168.3.2 255.255.255.255 Async36

ip route 192.168.4.2 255.255.255.255 Async37

ip route 192.168.5.2 255.255.255.255 Async38

ip route 192.168.6.2 255.255.255.255 Async39

ip route 192.168.7.2 255.255.255.255 Async40

ip http server

ip pim bidir-enable

!

!

dial-peer cor custom

!

!

!

!

line con 0

line 33 40

exec-timeout 0 0

modem Dialin

modem autoconfigure discovery

transport input all

flowcontrol hardware

line 41 48

exec-timeout 0 0

modem Dialin

transport input all

flowcontrol hardware

line aux 0

line vty 0 4

password 123456

login

!

end

Thanks a lot.

Modem Version :

slot 1 : MCOM Analog Integrated Modem Firmware Version 1.2.8

Source : IOS

Boot Firmware : 1.1.5

MIMC Firmware : 1.3.3

Modem Firmware : 2.3.17

DSP Firmware : 0.0.2

1 REPLY
Bronze

Re: Cisco 3640 w/ NM-16AM Connection Speed Problem

The default modem config should be set to allow for any modulation type, starting with the fastest (V.34) and working down from there. Modem autoconfig is not necessary and in fact should not really be used, it may end up causing more problems than it solves.

For optimization, you can consider PPP compression but the modems will already be doing compression and so PPP may not help out much (but it will cause a corresponding CPU increase). Same goes for TCP header compression, but you can try some tests to see if it helps in the end.

Yes, the chassis should be grounded.

To judge the ping results, you need to look at the quality of the individual connections - what modulation rate they connected at, etc.

120
Views
0
Helpful
1
Replies
CreatePlease to create content