Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Cisco 6509 & 3750 error while etherchanneling

Hi,

we have cisco 6509(catOS) & 3750(IOS), while etherchanneling between them, ports are getting err-disabled in 3750, below are the configuration.

Cisco 3750

interface gig 1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

interface gi 2/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

Cisco 6509

set port channel 3/4 445

set port channel 3/5 447

set trunk 3/4 on dot1q 1-1005,1025-4094

set trunk 3/5 on dot1q 1-1005,1025-4094

set port channel 3/4-5 mode on

with this configuration, when i connect, within a minute the ports gets err-disabled in 3750, any changes to be made in the above said configuration?

5 REPLIES

Re: Cisco 6509 & 3750 error while etherchanneling

Hi Anand,

Can you confirm if your modules 3 on your cat6k is gig module or 10/100 module?

It is going into errdisable state due to some etherchannel problem and that can be due to negotiation also.

Regards,

Ankur

Re: Cisco 6509 & 3750 error while etherchanneling

on cisco 6509 the 3rd module is WS-X6408A-GBIC which has got fiber, port is getting disabled only 3750 not on 6509.

Re: Cisco 6509 & 3750 error while etherchanneling

Hi Ankur,

actually i resolved the problem, just because the admin group value is different it has disabled, when i made it as equal, it started working fine, i mean admin group ID i meade in cisco 6509. thanks for the effort

New Member

Re: Cisco 6509 & 3750 error while etherchanneling

I'm pretty sure that the 2 ports on the 6509 have to be in the same admin group. In your example, the 2 ports are in seperate admin groups (445 and 447). Try configuring the admin group to be the same for the 2 interfaces.

6509

set port channel 3/4,3/5 448

I've never had much luck allowing the 6509 to put the ports into admin groups on it's own. I've had much better luck assigning the admin group explicitly.

Purple

Re: Cisco 6509 & 3750 error while etherchanneling

I think if you had set up the channels as desirable and let the switches negotiate they would not have this problem , you only see this when channels are forced on. From what i have read it is best practice to set up the trunks and channels as desirable and let them negotiate the trunks and channels. I have never seen a problem with channel or trunk negotiation and myself try to avoid forcing them on .

396
Views
0
Helpful
5
Replies