Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 800 series ADSL help

Hi,

I have a Cisco 800 series ADSL router (i think it's an 837). It's an old one from work so i don't have much documentation or support with it.

I want to configure it for my home ADSL, preferably using the CLI.

Could anyone give me any info on just simply getting the ADSL up and runnning and then where to go from there ?

What the correct config-register setting is?

How to either clear current config or reset to default settings.

kind Regards

J mac

8 REPLIES

Re: Cisco 800 series ADSL help

Hi

Normal configuration register setting value is 0x2102 if you want to go for a factory default then change the same to 0x2142 and then do a reload.

once you are done with the reload it will get u the default config prompt wherein you can change the registe value to 0x2102 and save the config.

Another best option is execute write erase and reload (dont save before reloading).

Relevant config for ADSL :

interface ATM0

no ip address

no ip directed-broadcast

no ip mroute-cache

no atm ilmi-keepalive

pvc 1/150

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface Dialer0

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username password

!

ip nat inside source list 101 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

access-list 101 permit ip 10.0.0.0 0.255.255.255 any

dialer-list 1 protocol ip permit

for more configuration assistance do refer this link ..

http://cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080093fd2.shtml

regds

New Member

Re: Cisco 800 series ADSL help

Wouldnt you just need a standard access list to nat not an extended one, ie access list 1 permit 10.0.0.0 0.255.255.255 !!

New Member

Re: Cisco 800 series ADSL help

We can't give you now for what your asking.... We have to little information.

First make sure you know how your ISP is setting up your ADSL connection. is it by dhcp ? (layer2 mac assigned) and what are the pvc number of your ISP?

New Member

Re: Cisco 800 series ADSL help

Hi,

I used the config provided and looked up the ADSL info for my ISP, PVC etc. and enetered it. It doesn't seem to work.

do i need to configure the inside ethernet interface at all?

also i couldn't ping from the router it said protocol not supported.

Any help gratefully appreciated.

Regards

J mac

Re: Cisco 800 series ADSL help

hi

Do post out the whole config here which you are trying over there and also the output of show version taken from your router..

regds

New Member

Re: Cisco 800 series ADSL help

Runnig-config

Current configuration : 1289 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

no aaa new-model

ip subnet-zero

!

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

ip address dhcp

hold-queue 100 out

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

pvc 1/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username xxxxx@xtreme4.pipex.net password 0 xxxxxxxxx

!

ip nat inside source list 101 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

access-list 101 permit ip 10.0.0.0 0.255.255.255 any

dialer-list 1 protocol ip permit

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

!

end

many thanks

J mac

New Member

Re: Cisco 800 series ADSL help

Show version

Cisco Internetwork Operating System Software

IOS (tm) C837 Software (C837-K9O3Y6-M), Version 12.3(2)XC2, EARLY DEPLOYMENT REL

EASE SOFTWARE (fc1)

Synched to technology version 12.3(1.6)T

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Thu 04-Mar-04 01:13 by ealyon

Image text-base: 0x800131E8, data-base: 0x80B93040

ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)

ROM: C837 Software (C837-K9O3Y6-M), Version 12.3(2)XC2, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)

Router uptime is 5 minutes

System returned to ROM by power-on

System image file is "flash:c837-k9o3y6-mz.123-2.XC2.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

CISCO C837 (MPC857DSL) processor (revision 0x500) with 44237K/4915K bytes of mem

ory.

Processor board ID AMB08230ULY (2220150277), with hardware revision 0000

CPU rev number 7

Bridging software.

1 Ethernet/IEEE 802.3 interface(s)

4 FastEthernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

128K bytes of non-volatile configuration memory.

12288K bytes of processor board System flash (Read/Write)

2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102

.......................................

Cheers

J mac

Re: Cisco 800 series ADSL help

Hi Mac

Try configuring an ip address under your ethernet interface and also make that interface as your NAT inside interface.

once you are done with that you can try again pinging some external sites and check whether your getting connected to the outside world..

Try the below mentioned config and check whether you are able to get connected.

interface Ethernet0

no ip address dhcp

ip address 10.1.1.1 255.255.255.0

!

no access-list 101 permit ip 10.0.0.0 0.255.255.255 any

access-list 101 permit ip 10.1.1.0 0.0.0.255 any

do clear the nat translations before you start trying to get connected.

you can use this Command to clear up the same clear ip nat translations *

regds

836
Views
0
Helpful
8
Replies
CreatePlease login to create content