cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
464
Views
0
Helpful
4
Replies

Cisco 804 two default routes Help please

kingtut
Level 1
Level 1

In my Cisco 804 I have two dialer interfaces going to the same ISP; Dialer1 with Multilink PPP and Dialer2 with NO Multilink PPP. I do this for cost savings and the ISP's Multilink is unstable and prone to unbundled redials.

My issue is I have to manually remove one of the default routes or do a Shutdown of one or the other dialer interfaces to make this work, what a drag.

Because of spoofing Dialer1 and Dialer2 appears connected in the routing table and my two default routes try to load balance which I do not want!

The addresses are negotiated; my end gets something from the 66.19.0.0 network and unfortunately the POP end will be something in the 66.19.36.0 network also different each call.

RIP has the ability to know the difference between an UP UP Dialer and a Spoofing UP dialer however that fact seems to do me little good. Policy routing seems very limited for an 804. I am asking if anyone can suggest a solution please. Thank you

version 12.1

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

no service password-encryption

!

hostname amp/

!

boot system flash c800-y6-mw.121-6

logging buffered 163840 debugging

no logging console

enable secret 5 xxxxxxxxxxxxxxxx

!

clock timezone central -6

clock summer-time CDT recurring

!

dial-peer voice 1 pots

call-waiting

ring 0

port 1

destination-pattern xxxxxxx

!

dial-peer voice 2 pots

call-waiting

ring 0

port 2

destination-pattern xxxxxxx

!

pots country US

no ip subnet-zero

no ip source-route

!

no ip domain-lookup

no ip finger

isdn switch-type basic-ni

!

interface Ethernet0

ip address 1x9.x.1x8.25 255.255.255.248

no ip proxy-arp

ip nat inside

no ip split-horizon

no cdp enable

!

interface BRI0

no ip address

ip nat outside

encapsulation ppp

no ip split-horizon

no logging event link-status

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-ni

isdn spid1 xxxxxxxxx10101 xxxxxxx

isdn spid2 xxxxxxxxx30101 xxxxxxx

isdn voice-priority xxxxxxx in always

isdn voice-priority xxxxxxx in always

isdn voice-priority xxxxxxx out always

isdn voice-priority xxxxxxx out always

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Dialer1

ip address negotiated

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

no logging event link-status

dialer pool 1

dialer remote-name MLP

dialer idle-timeout 3600

dialer fast-idle 3600

dialer string 17733537827

dialer hold-queue 10

dialer load-threshold 1 either

dialer-group 1

no fair-queue

no cdp enable

ppp authentication pap callin

ppp pap sent-username amp/ password 7 xxxxxxxxxxxxxx

ppp multilink

!

interface Dialer2

ip address negotiated

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

no logging event link-status

dialer pool 2

dialer remote-name PPP

dialer idle-timeout 3600

dialer fast-idle 3600

dialer string 17733537827

dialer hold-queue 10

dialer-group 2

no fair-queue

no cdp enable

ppp authentication pap callin

ppp pap sent-username amp/ password 7 xxxxxxxxxxxx

!

ip nat inside source route-map MLP interface Dialer1 overload

ip nat inside source route-map PPP interface Dialer2 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer2

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 101 permit ip 1x9.x.1x8.24 0.0.0.7 any

access-list 101 deny ip host 1x9.x.1x8.25 any

access-list 101 permit icmp any host 206.141.239.142 echo

access-list 102 permit ip 1x9.x.1x8.24 0.0.0.7 any

access-list 102 deny ip host 1x9.x.1x8.25 any

access-list 102 permit icmp any host 216.239.33.100 echo

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

no cdp run

route-map PPP permit 1

match ip address 102

match interface Dialer2

!

route-map MLP permit 1

match ip address 101

match interface Dialer1

!

line con 0

exec-timeout 0 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 0 0

password cisco

login

!

sntp server 64.24.52.1 version 3

4 Replies 4

jgizel
Level 1
Level 1

I still do not understand why you have the two dialers. But if you want to prefer one dialer (and hence one route) over the other, make the undesirable route a higher metric i.e. ip route 0.0.0.0 0.0.0.0 Dialer1 5

Thanks for the response. The reason I need two dialers to the same location is so I can choose between one channel ISDN 64 or Two channel 128. Your suggestion will not work because the routing table considers both dialers as up (spoofing) even though I really have only one or the other dialer connected at a given time, so the default route in your example is always dialer2 regardless of which is connected to the ISP. I guess there is no solution and I am stuck reconfiguring one or the other.

I see. What decision process do you use to determine whether you want 64k or 128k access?

Hello

Below is a better configuration. This is what I used before my ISP changed out all of the host POP equipment. I connect a ISDN 64 connection with a simple ping shortcut on my desktop to host 216.239.33.100 (dialer2 access list 102) or ISDN 128 via pinging host 206.141.239.142 (dialer1 access list 101). Then it was easy to do what I want. Every time I would connect, the next hop address (POP site 192.168.254.1) was always the same, only my end negotiated a different address each call. Since the same next hop address would always appear in the routing table, once connected a simple default route to 192.168.254.1 worked. With the new ISP POP routers the addresses are negotiated or different with every new connection. My end gets something from the 66.19.0.0 network and unfortunately the POP end will be something in the 66.19.36.0 network also different each call. Thank you.

version 12.1

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

no service password-encryption

!

hostname amp/

!

boot system flash c800-y6-mw.121-6

logging buffered 163840 debugging

no logging console

enable secret 5 xxxxxxxxxxxxxxxx

!

clock timezone central -6

clock summer-time CDT recurring

!

dial-peer voice 1 pots

call-waiting

ring 0

port 1

destination-pattern xxxxxxx

!

dial-peer voice 2 pots

call-waiting

ring 0

port 2

destination-pattern xxxxxxx

!

pots country US

no ip subnet-zero

no ip source-route

!

no ip domain-lookup

no ip finger

isdn switch-type basic-ni

!

interface Ethernet0

ip address 1x9.x.1x8.25 255.255.255.248

no ip proxy-arp

ip nat inside

no ip split-horizon

no cdp enable

!

interface BRI0

no ip address

ip nat outside

encapsulation ppp

no ip split-horizon

no logging event link-status

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-ni

isdn spid1 xxxxxxxxx10101 xxxxxxx

isdn spid2 xxxxxxxxx30101 xxxxxxx

isdn voice-priority xxxxxxx in always

isdn voice-priority xxxxxxx in always

isdn voice-priority xxxxxxx out always

isdn voice-priority xxxxxxx out always

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Dialer1

ip address negotiated

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

no logging event link-status

dialer pool 1

dialer remote-name MLP

dialer idle-timeout 3600

dialer fast-idle 3600

dialer string 17733537827

dialer hold-queue 10

dialer load-threshold 1 either

dialer-group 1

no fair-queue

no cdp enable

ppp authentication pap callin

ppp pap sent-username amp/ password 7 xxxxxxxxxxxxxx

ppp multilink

!

interface Dialer2

ip address negotiated

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

no logging event link-status

dialer pool 2

dialer remote-name PPP

dialer idle-timeout 3600

dialer fast-idle 3600

dialer string 17733537827

dialer hold-queue 10

dialer-group 2

no fair-queue

no cdp enable

ppp authentication pap callin

ppp pap sent-username amp/ password 7 xxxxxxxxxxxx

!

ip nat inside source route-map MLP interface Dialer1 overload

ip nat inside source route-map PPP interface Dialer2 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.1

ip route 206.141.239.142 255.255.255.255 Dialer1

ip route 216.239.33.100 255.255.255.255 Dialer2

!

access-list 18 permit 199.3.168.24 0.0.0.7

access-list 101 deny ip host 199.3.168.25 any

access-list 101 permit ip any host 206.141.239.142

access-list 101 permit udp any any eq domain

access-list 102 deny ip host 199.3.168.25 any

access-list 102 permit ip any host 216.239.33.100

access-list 102 permit udp any any eq domain

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

no cdp run

route-map PPP permit 1

match ip address 18

match interface Dialer2

!

route-map MLP permit 1

match ip address 18

match interface Dialer1

!

line con 0

exec-timeout 0 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 0 0

password cisco

login

!

sntp server 64.24.52.1 version 3

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: