Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 806 (12.3(1)) & Verizon DSL w/ PPPoE

Hi,

I just received a Verizon DSL connection that uses PPPoE to authenticate users. I am attempting to configure my Cisco 806 to handle routing to and from the Internet handling the PPPoE authentication. I am trying to configure my router using some docs from Cisco ... but with no luck. I see the link get established but it goes right into a down state again. I have tested this with other routers... here is some info:

>>>>

02:06:02: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

02:06:02: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

02:06:06: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

02:06:06: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

02:06:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1, changed state to down

>>>>

And my config:

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

ip subnet-zero

ip dhcp excluded-address 10.10.10.1

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

partition flash 2 6 2

!

!

!

!

interface Ethernet0

ip address 10.180.1.254 255.255.255.0

ip nat inside

no cdp enable

hold-queue 32 in

hold-queue 100 out

!

interface Ethernet1

no ip address

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp pap sent-username <username> password <password>

!

ip nat inside source list 102 interface Ethernet1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

no ip http secure-server

!

access-list 23 permit 10.10.10.0 0.0.0.255

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 120 0

login local

!

scheduler max-task-time 5000

!

end

Thanks!

Stefan

2 REPLIES
Bronze

Re: Cisco 806 (12.3(1)) & Verizon DSL w/ PPPoE

Stefan,

I don't know if this will fix the PPPoE issue, but your ip nat statement assigns the IP address of Ethernet 1to internal hosts, and that interface has no IP address. Change the NAT statement to "ip nat inside source list 102 interface dialer 1 overload".

Good luck.

Mark

New Member

Re: Cisco 806 (12.3(1)) & Verizon DSL w/ PPPoE

You are using ppp authentication chap pap callin but you have no chap password or hostname.

I am not sure if that ISP uses chap or pap ( I would think Chap)

Try putting in under the dialer

ppp chap hostname (username)

ppp chap password (password)

You are also missing a dialer-list that will permit the link to come up when it see's interesting traffic.

The most common dialer-list is

dialer-list 1 protocol ip permit

Hope that helps

Travers

336
Views
0
Helpful
2
Replies