Cisco Support Community
Community Member

Cisco 806, Wanadoo Pro, Netissimo 2, ECI B-Focus - Prob Connection/dialer


I've wrestled with the following config for weeks but I'm never able to establish a connection. With WinRoute Pro 4.2.1 and RASPPPoE I've confirmed that the modem works and there's no problem in establishing a persistent connection. You guys/gals are my last hope: Failing here means I'll have to do something stupid and put the 806 behind the WinRoute Pro.

I've read a number of messages that claim to have no problems with the following config successfully establishing connections via an Alcatel STH modem. But in my corner of the world France Telecom, in its customary blundering way, has opted for ECI chipset DSLAMs. Consequently they supply ECI B-Focus modems.

For the record, every time I modify the startup-config, I reload

the router and restart the modem. Here's the 806 config:

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption


hostname asterix


no logging buffered

enable secret 5 --moderator edit--

enable password milou


ip subnet-zero

no ip domain-lookup


ip ssh time-out 120

ip ssh authentication-retries 3

vpdn enable


vpdn-group my-vpdn-group


protocol pppoe

ip mtu adjust


interface Ethernet0

ip address

ip nat inside

ip tcp adjust-mss 1452

no cdp enable

hold-queue 32 in

hold-queue 100 out


interface Ethernet1

no ip address

ip tcp adjust-mss 1452

no keepalive

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable


interface Dialer0

ip address negotiated

no ip proxy-arp

ip mtu 1492

ip nat outside

encapsulation ppp

no ip split-horizon

no keepalive

dialer pool 1

dialer idle-timeout 300 either

dialer enable-timeout 2

dialer hold-queue 100

dialer-group 1

no cdp enable

ppp authentication pap callin optional

ppp chap hostname fti/xxxxxxx@fti

ppp chap password 7 --moderator edit--

ppp pap sent-username fti/ xxxxxxx @fti password 7 --moderator edit--


ip nat inside source list 101 interface Dialer0 overload

ip classless

ip route Dialer0

no ip http server

ip pim bidir-enable



access-list 101 permit ip any any

dialer-list 1 protocol ip permit


line con 0

exec-timeout 0 0

stopbits 1

line vty 0 4

password rasteau


transport input none


scheduler max-task-time 5000

ntp server

The dialer seems to be functioning correctly (although I do find it strange the MTU value shows 1500 when the startup-config specifies ip mtu 1492):

asterix#sh int d0

Dialer0 is up, line protocol is up (spoofing)

Hardware is Unknown

Internet address will be negotiated using DHCP

MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

DTR is pulsed for 1 seconds on reset

Last input never, output never, output hang never

Last clearing of "show interface" counters 18:53:09

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:


Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 42 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

0 packets output, 0 bytes

The debug output:

18:52:31: Di0 DDR: ip (s=, d=, 76 bytes, outgoing


g (ip PERMIT)

18:52:31: DDR: 45C0004C 00000000 FF11F232 00000000 C26D0641 007B007B

18:52:31: DDR: 00380000 DB0006EE 00000000 00010001 00000000 00000000

18:52:31: Di0 DDR: dialer_fsm_idle()

18:52:31: Di0 DDR: Cannot place call, no dialer string set

Seeing this I said, "no dialer string set, OK, I'll put one in". Thanks to the RASPPPoe driver and the aforementioned WinRoute Pro, I found an ISDN number for the Dialup Networking connection it uses to connect to the ISP (Wanadoo). (Admittedly I also find it strange that the driver displays an ISDN connection when the ISP is providing ADSL.) But upon adding the following to the config:

asterix(config-if)#dialer string 62031050125595-BSANN201

yet again, another defeat:

18:58:55: DDR: 45C0004C 00000000 FF11F232 00000000 C26D0641 007B007B

18:58:55: DDR: 00380000 DB0006EE 00000000 00010001 00000000 00000000

18:58:55: Di0 DDR: dialer_fsm_idle()

18:58:55: Di0: No free dialer - starting fast idle timer

Is there anyone out there that can save me?



Re: Cisco 806, Wanadoo Pro, Netissimo 2, ECI B-Focus - Prob Conn

Fast Idle Timeout has the following characteristics:

1. If the session has been idling for a time period equal or greater than the fast idle timeout then the next contention call will drop the current call immediately.

2. If the session has been idling for a time period less than the fast idle timeout then the next contention call will use the fast idle timeout and wait till that fast idle timeout finishes before dropping the call.

There is a page which might make this process easier diagnose:

CreatePlease to create content