Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 827 locks up after about an hour or so

This is probably an easy one for someone out there.

IOS= 12.1(5)yb1

Just doing standard RFC1483 routing with NAT, nothing real special or complicated. I erased the NVRAM and started fresh with the configuration I already mentioned. As soon as I get done with the configuration and test for connectivity everything works fine. I have a friend of mine try my web site and FTP site through the router and evrything is just fine no problems. After about an hour or two I will no longer be able to ping my gateway and I am now down. No one can get to me from the outside and I can't get out. I can restart the router several times and nothing works. If I wipe the configuration and start over then it will work fine and then stop again after about another hour or so.

I tried straight bridge mode and it works fine with no problems????

It's wierd that it'll work in bridge mode but not work (for more than an hour) doing routing with NAT. Before someone says it's the router, this is the second 827 that I tried and it's doing the same thing the first one did!!

I've searched the forums but didn't see anything like this one anywhere.

THis is the configuration that I'm trying to make work:

http://www.cisco.com/warp/customer/794/827guide_rtng_opt1.html

I'm connecting to a BellSuck (Bellsouth) DSLAM but I'm not sure what type.

ANy comments would be helpful.

Allen

afish6969@i-55.com

6 REPLIES
Bronze

Re: Cisco 827 locks up after about an hour or so

The problem could be the way you have configured your acl for NAT. For example, if you use "access-list 1 permit any"... this could be your problem. You should always be as specific as possible when specifying which networks you want to translate (ie. "access-list 1 permit 192.168.1.0 0.0.0.255").

If that doesnt help, the next time you have this problem, rather than re-configuring or reloading your router, try clearing the NAT table... the command to do this is:

clear ip nat trans *

If you have configured NAT correctly and clearing the NAT table fixes the problem, it is likely a software bug. If you need more help, please re-post with your config (be sure to remove your passwords before posting to the forum)

New Member

Re: Cisco 827 locks up after about an hour or so

I will try this later tonight. One of my friends suggested that I may need to allocate memory in the configuration??

I'll be sure and post later tonight and also put the configuration up also.

Thanks a lot!!!

New Member

Re: Cisco 827 locks up after about an hour or so

Ron,

It may be asking Bell what their DSLAM types are. I seem to remember a problem with the 827 running a particular IOS version and a Cisco DSLAM. I can't remember the bug details but what was happening was the 827 was working fine and then failed. When rebooted the 827 could not train up again for some time and when it did it would fail again shortly after. Another part of this was that when the DSLAM was upgraded and rebooted and the router was not, the router could not train up at all.

The fix was an IOS upgrade on both the 827 and the DSLAM.

It may be worth investigating, but may not be related to your problem - just a thought.

Ali

New Member

Re: Cisco 827 locks up after about an hour or so

OK, here's the current config that I keep trying to run:

service timestamps debug datetime msec

service timestamps log datetime msec

ip subnet-zero

!

!

interface ethernet0

no shut

ip address 192.168.1.1 255.255.255.0

ip nat inside

no ip directed-broadcast

!

interface atm0

no shut

no ip address

no ip directed-broadcast

no atm ilmi-keepalive

!

interface atm0.1 point-to-point

ip address 209.205.185.68 255.255.255.0

ip nat outside

pvc 8/35

encapsulation aal5snap

ip nat inside source list 1 interface atm0.1 overload

ip nat inside source static tcp 192.168.1.110 80 209.205.185.68 80 extendable

ip nat inside source static tcp 192.168.1.110 21 209.205.185.68 21 extendable

ip nat inside source static tcp 192.168.1.130 3389 209.205.185.68 3389 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 209.205.185.1

access-list 1 permit 192.168.1.1 0.0.0.255

I ran it again last night and it failed a couple of hours later. I tried the command you mentioned with no results, it just didn't do anything. I have ordered more memory and will try to upgrade to the latest IOS in the near future. I'm begining to think that it may be a BellSouth problem, we'll see......

Thanks for all your help!!

New Member

Re: Cisco 827 locks up after about an hour or so

Here's a little twist to the whole thing. Right now I'm running the router in bridge mode only, and of course it works fine. I've been testing different configurations to see if maybe one of them will work for more than an hour or so. I erased the NVRAM so I could try a different configuration and when I told it to reload I got this message:

18:44:07: %SYS-5-RELOAD: Reload requested

*** Alignment Error Exception ***

PC = 0x4, Vector = 0x600, SP = 0x80cf9f68

It's never done that before and it's the first time I've ever seen this. Does anyone know what it means?

Thanx

Cisco Employee

Re: Cisco 827 locks up after about an hour or so

That means the router reloaded itself because of "Alignment Errors". Go i would say go for the latest image near 12.2 version if possible.

Its very strange that the router work for just one hr and locks up.

You can open a tac case for that by logging at

www.cisco.com/tac

114
Views
0
Helpful
6
Replies
CreatePlease login to create content