Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 827 PPoE ADSL

We have Cisco 827 router running PPoE for ADSL connection which is working fine, but one problem is that whenever the ISP is down or does something, then comes back, the 827 cannot pick up the connection automatically unless you reboot it.

Is there a command to check the line, then reboot the router? Does it depend on dynamic ip or static ip you are using?

Thanks

Shawn

6 REPLIES
New Member

Re: Cisco 827 PPoE ADSL

Greetings:

Can you clarify. Is it that the interface is down or that it is up and you cannot communicate across it? Do yo have a static IP or a learned one? Could you add the configuration here?

Thanks...Steve

New Member

Re: Cisco 827 PPoE ADSL

Hi, Steve:

In fact, I don't know the interfaces' state when I cannot remotely access. It is running on the client site, only thing they can do is to manully reboot.

Here is the configuration file:!

version 12.1

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname dethomas

!

logging buffered 4096 debugging

logging rate-limit console 10 except errors

enable password 7 05585058741F1D51

!

username admin password 7 0255520C5E555C79

clock summer-time eastern recurring

ip subnet-zero

no ip finger

ip domain-name golden.net

ip name-server 199.166.210.2

ip name-server 199.166.210.5

!

ip dhcp pool CLIENT

!

no ip bootp server

no ip dhcp-client network-discovery

vpdn enable

no vpdn logging

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

interface Ethernet0

ip address 10.0.0.1 255.255.255.0

ip accounting output-packets

ip nat inside

no cdp enable

!

interface ATM0

mtu 1492

no ip address

no atm ilmi-keepalive

atm ilmi-pvc-discovery

pvc 0/35

protocol pppoe

pppoe-client dial-pool-number 1

!

bundle-enable

dsl operating-mode auto

hold-queue 224 in

!

interface Dialer1

mtu 1492

ip address 216.75.163.33 255.255.255.248 secondary

ip address 216.75.163.34 255.255.255.248 secondary

ip address 216.75.163.35 255.255.255.248 secondary

ip address 216.75.163.36 255.255.255.248 secondary

ip address 216.75.163.37 255.255.255.248 secondary

ip address 216.75.163.38 255.255.255.248 secondary

ip address 209.183.136.31 255.255.255.0

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1422

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username dethomas@golden.net password 7 0601002D484B07

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 142.148.10.0 255.255.255.0 10.0.0.20

no ip http server

!

ip nat inside source list 101 interface Dialer1 overload

ip nat inside source static tcp 10.0.0.2 1503 209.183.136.31 1503 extendable

ip nat inside source static 10.0.0.6 216.75.163.38

ip nat inside source static 10.0.0.49 216.75.163.37

ip nat inside source static 10.0.0.157 216.75.163.35

ip nat inside source static 10.0.0.20 216.75.163.34

ip nat inside source static 10.0.0.5 216.75.163.33

ip nat inside source static tcp 10.0.0.4 5632 209.183.136.31 5632 extendable

ip nat inside source static tcp 10.0.0.4 5631 209.183.136.31 5631 extendable

ip nat inside source static tcp 10.0.0.9 443 209.183.136.31 443 extendable

ip nat inside source static tcp 10.0.0.9 389 209.183.136.31 389 extendable

ip nat inside source static tcp 10.0.0.9 709 209.183.136.31 709 extendable

ip nat inside source static tcp 10.0.0.2 1433 209.183.136.31 1433 extendable

ip nat inside source static tcp 10.0.0.2 710 209.183.136.31 710 extendable

ip nat inside source static tcp 10.0.0.2 701 209.183.136.31 701 extendable

ip nat inside source static tcp 10.0.0.2 700 209.183.136.31 700 extendable

ip nat inside source static udp 10.0.0.4 5632 209.183.136.31 5632 extendable

ip nat inside source static 10.0.0.30 216.75.163.36

access-list 98 permit any

access-list 101 permit ip 10.0.0.0 0.0.0.255 any

no cdp run

snmp-server engineID local 000000090200000196A499EB

snmp-server community rescue RO 98

!

line con 0

exec-timeout 120 0

login local

transport input none

stopbits 1

line vty 0 4

exec-timeout 120 0

password 7 15415D5B5179787C

login local

!

scheduler max-task-time 5000

end

Thank you very much, Steve.

Shawn

New Member

Re: Cisco 827 PPoE ADSL

Hi Shawn,

Use a show run and see what IOS version you are running. In order to overcome this one we have found it safer to use c820-y6-mz.122-2.XI.bin. If you try an even more up to date version such as XK and above, you'll find that any static routes, including the default, that point to the Dialer interface won't actually work! We've raised a case and Cisco are on to it. This version will retrain as it should do.

HTH

Ali

New Member

Re: Cisco 827 PPoE ADSL

Here is "sh ver" :

dethomas#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C820 Software (C820-Y6-M), Version 12.1(5)YB4, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Tue 03-Jul-01 18:18 by ealyon

Image text-base: 0x80013170, data-base: 0x80672A1C

ROM: System Bootstrap, Version 12.2(1r)XE2, RELEASE SOFTWARE (fc1)

ROM: C820 Software (C820-Y6-M), Version 12.1(5)YB4, EARLY DEPLOYMENT RELEASE SOF

TWARE (fc1)

dethomas uptime is 21 minutes

System returned to ROM by power-on

System image file is "flash:c820-y6-mz.121-5.YB4"

CISCO C827 (MPC855T) processor (revision 0x701) with 15360K/1024K bytes of memor

y.

Processor board ID JAD0543096Z (311679516), with hardware revision 0000

CPU rev number 5

Bridging software.

1 Ethernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

128K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

New Member

Re: Cisco 827 PPoE ADSL

Try upgrading to the version I mentioned in the previous post.

Ali

New Member

Re: Cisco 827 PPoE ADSL

BTW.

Our DSLAM's are running:

ni2-dsl-mz.122-5.da.bin

You may want to ask your ISP which IOS they are running.

Ali

127
Views
0
Helpful
6
Replies
CreatePlease login to create content