Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 831 and NAT: problem

Hello everybody!

I've got a problem with NAT in a CISCO 831 Router. I'm NATting between the inside eth0 and the outside Dialer0 (where there's a modem that gets connected to an ISP).

The problem is that given the bare-bones setup shown below, only UDP seems to be able to pass! I can resolve domain names with nslookup, but I can't surf to any site, nor use FTP; ping too seems dead, but I read that NAT and ICMP have difficulties living together so I'm not overly worried about it.

Initially I had in place ACLs to avoid triggering on-demand routing unnecessarily, and to protect the internal network. Yet as I experienced the problems I mentioned, I removed everything to no avail.

I asked other collegues for advice but they could not spot anything wrong with the conf: can anybody help me, please?

Ezio

IOS Version: 12.2(8)YN

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname QQQQQQQ

!

enable secret 5 QQQQQQQQQQQQQQQ

!

username QQQQQQQQ privilege 15 password 7 QQQQQQQQQQQQQQQ

username QQQQQQQQ privilege 15 password 7 QQQQQQQQQQQQQ

username QQQQQQQQ password 7 QQQQQQQQQQQQQQQQQQQQQQQQQQQQQ

ip subnet-zero

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

chat-script QQQQQQQQ ABORT ERROR ABORT BUSY "" "AT" OK "ATDT

555555555\T" TIMEOUT 45 CONNECT \c

modemcap entry USR_56K:MSC=X0S6=3S11=100

modemcap entry usr2:MSC=x0

!

!

!

!

interface Ethernet0

ip address 192.168.100.254 255.255.255.0

ip nat inside

no cdp enable

hold-queue 32 in

hold-queue 100 out

!

interface Ethernet1

no ip address

no cdp enable

!

interface Async1

ip address negotiated

encapsulation ppp

dialer in-band

dialer pool-member 1

async mode dedicated

ppp authentication pap callin

!

interface Dialer0

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer string 555555555 modem-script QQQQQQQQQ

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp pap sent-username QQQQQQQQQQQ password QQQQQQQQQQ!

ip nat inside source list 2 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

!

access-list 2 permit 192.168.100.0 0.0.0.255

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

exec-timeout 0 0

modem enable

stopbits 1

line aux 0

exec-timeout 0 0

modem InOut

modem autoconfigure type usr2

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

exec-timeout 120 0

login local

length 0

!

scheduler max-task-time 5000

end

1 REPLY
New Member

Re: Cisco 831 and NAT: problem

Put DNS ips in config :(config)# ip name-server x.x.x.x

enable domain lookup: (config)# ip domain lookup

and check ..Hope it will help..

Thanks & Regards,

Srinivas.S

190
Views
0
Helpful
1
Replies