Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 837

Hi! I just got a new cisco 837 router for internet connection. I'm using dynamic ip. Anyone has any sample & working config that can share with me?

Thanks.

4 REPLIES

Re: Cisco 837

Maybe if you can tell us what is the goal, then someone can provide a sample configuration. I will assume that you want a sample configuration for NATing do that you can have multiple internal users accessing the Internet using a single public IP address provided by the ISP, in that case this is a working config, this is also cofigured to serve as DHCP server for internal users:

!

ip dhcp excluded-address 192.168.1.1 192.168.1.99

!

ip dhcp pool private

network 192.168.1.0 255.255.255.0

domain-name anynet.com

default-router 192.168.1.1

dns-server

lease 3

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Ethernet1

ip address dhcp

ip nat outside

duplex auto

!

ip route 0.0.0.0 0.0.0.0 ethernet1

!

ip nat inside source list 1 interface Ethernet1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

Please rate all posts.

New Member

Re: Cisco 837

Hi! I've tried the config above and plug in on host to the ethernet port on the router, but the host can't even get an ip from the router. The host is configure with dhcp enabled.Any idea?

Will the config above work without any username and password to connect to the internet?

Pls advise. Thanks.

New Member

Re: Cisco 837

Hi! Sorry, the issue of not getting an ip from dhcp is that i didn't do a "no shut" in the ethernet 0 interface.

So, how do i connect to the internet from here if there's no username and password configure in the router? In addition to that i do not have the interface ethernet1, but i do have an atm and dialer interface.

pls advise. Thanks.

Re: Cisco 837

This link have a sample configuration for your router:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a0080118d24.html

Please rate all posts.

121
Views
4
Helpful
4
Replies
CreatePlease login to create content