Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco Catalyst 2950T-24 EI - to do RATE-LIMITING per port ? HOW ?

Dear all,

I just tested Cisco Catalyst 2950 with EI image.

The vendor just upgraded the IOS from Standard Image to Enhanced Image..

My objective is :

To limit port ( traffic shapping) per port basis based on rate-limit command ( as Cisco said can be done with EI version). I want to have 128kbps,256, 512,1024 and 2048 speeds. When logon to IOS command, and went to specific interface to be configured, I can't get "rate-limit" command -> unrecognized command !!!.

Then I try to use Web based. I managed to use QoS but the min speed is 1Mbps to 100Mbps for FE port and increment of 1,2,3,4 up tp 100 Mbps. and the burst rate something like 4k to 512k !!!.

PLEASE HELP...me to rate limit the bandwidth !!!

My current version:

cisco-2950-mpsj-lib#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(11)EA1, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Wed 28-Aug-02 10:25 by antonino

Image text-base: 0x80010000, data-base: 0x80528000

ROM: Bootstrap program is CALHOUN boot loader

cisco-2950-mpsj-lib uptime is 5 hours, 24 minutes

System returned to ROM by power-on

System image file is "flash:/c2950-i6q4l2-mz.121-11.EA1.bin"

cisco WS-C2950T-24 (RC32300) processor (revision G0) with 20402K bytes of memory.

Processor board ID FOC0646W1SH

Last reset from system-reset

Running Enhanced Image

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:0B:5F:8C:9F:C0

--More-- Motherboard assembly number: 73-6114-08

Power supply part number: 34-0965-01

Motherboard serial number: FOC06460CP1

Power supply serial number: PHI0526010Z

Model revision number: G0

Motherboard revision number: A0

Model number: WS-C2950T-24

System serial number: FOC0646W1SH

Configuration register is 0xF

cisco-2950-mpsj-lib#sh run

Building configuration...

Current configuration : 2780 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cisco-2950-mpsj-lib

!

enable secret 5 $1$u9po$5QULW8JA8gVBK2FWaTp4G/

enable password abc123

!

!

class-map match-all 2048kbps

description 2048kbps

match ip dscp 0

class-map match-all 1536kbps

description 1536kbps

match ip dscp 0

class-map match-all 1024kbps

description 1024kbps

--More-- match ip dscp 0

class-map match-all 128kbps

description 128kbps

match ip dscp 0

class-map match-all 256kbps

description 256kbps

match ip dscp 0

class-map match-all 512kbps

description 512kbps

match ip dscp 0

!

!

policy-map 2048kbps

description 2048kbps

class 2048kbps

set ip dscp 0

police 4000000 262144 exceed-action drop

policy-map 1536kbps

description 1536kbps

class 1536kbps

set ip dscp 0

police 2000000 65536 exceed-action drop

policy-map 1024kbps

--More-- description 1024kbps

class 1024kbps

set ip dscp 0

police 1000000 131072 exceed-action drop

policy-map 128kbps

description 128kbps

class 128kbps

set ip dscp 0

police 1000000 65536 exceed-action dscp 0

policy-map 256kbps

description 256kbps

class 256kbps

set ip dscp 0

police 1000000 65536 exceed-action drop

policy-map 512kbps

description 512kbps

class 512kbps

set ip dscp 0

police 1000000 65536 exceed-action drop

!

ip subnet-zero

!

spanning-tree extend system-id

--More-- !

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

--More-- interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

--More-- !

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

--More-- no ip address

!

interface FastEthernet0/24

no ip address

service-policy input 128kbps

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 192.168.10.100 255.255.255.0

no ip route-cache

!

ip http server

!

!

line con 0

line vty 0 4

password cisco

login

--More-- line vty 5 15

password cisco

login

!

end

cisco-2950-mpsj-lib#

  • Other Network Infrastructure Subjects
1 REPLY
Bronze

Re: Cisco Catalyst 2950T-24 EI - to do RATE-LIMITING per port ?

Take a look through the following QoS link. To utilize these features, you must be running the enhanced software image on your switch:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2950/12111ea1/scg/swqos.htm

891
Views
0
Helpful
1
Replies