Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Cisco Catalyst 4506 VLAN's and routing between them?

Hi,

The catalyst has a supervisor engine IV.

We want to use VLAN's on this switch and enable routing between them.

We have 3 subnets 10.0.0.0 255.255.255.0, 10.0.1.0 255.255.255.0, 10.0.2.0 255.255.255.0

The internet is connected via a firewall proxy server with an internal ip number 10.0.2.254.

Each subnet is a VLAN. We want to route some trafic to another VLAN.

All VLAN's will be using internet.

Is this possible, if so, can someone explain me how I must do that step by step?

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Cisco Catalyst 4506 VLAN's and routing between them?

First, create your three VLANs:

Switch(config)# vlan 2

Switch(config-vlan)# exit

Switch(config)# vlan 3

Switch(config-vlan)# exit

Switch(config)# vlan 4

Switch(config-vlan)# exit

Then assign ports to the VLANs:

Switch(config)# interface slot/port

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan (VLAN #)

(repeat the above for all ports)

Assign IP addresses to each VLAN:

Switch(config)# interface vlan2

Switch(config-if)# ip address 10.0.0.x 255.255.255.0

(repeat the above for all VLANS, with valid IP addresses within the VLANs' ranges)

Configure a default route to the internet:

ip route 0.0.0.0 0.0.0.0 10.0.2.254

Make sure that the default gateways of all hosts are set for the IP address of the host's VLAN interface, set above.

That should do it. Check out other features in the configuration guide:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_19/config/index.htm

4 REPLIES
vev
New Member

Re: Cisco Catalyst 4506 VLAN's and routing between them?

You need to create three L3 VLAN-interfaces, like explained in this description:

http://www.cisco.com/en/US/products/hw/switches/ps663/products_configuration_guide_chapter09186a00800e467f.html#41851

For example vlan1:

Switch(config)# vlan vlan1

Switch(config)# interface vlan vlan1

Switch(config-if)# ip address 10.0.0.1 255.255.255.0

Switch(config-if)# no shut

and set default gateway for all vlan1 hosts to 10.0.0.1

make same for vlan2 and vlan3

and set default route:

Switch(config)# ip route 0.0.0.0 0.0.0.0 10.0.2.254

Bronze

Re: Cisco Catalyst 4506 VLAN's and routing between them?

First, create your three VLANs:

Switch(config)# vlan 2

Switch(config-vlan)# exit

Switch(config)# vlan 3

Switch(config-vlan)# exit

Switch(config)# vlan 4

Switch(config-vlan)# exit

Then assign ports to the VLANs:

Switch(config)# interface slot/port

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan (VLAN #)

(repeat the above for all ports)

Assign IP addresses to each VLAN:

Switch(config)# interface vlan2

Switch(config-if)# ip address 10.0.0.x 255.255.255.0

(repeat the above for all VLANS, with valid IP addresses within the VLANs' ranges)

Configure a default route to the internet:

ip route 0.0.0.0 0.0.0.0 10.0.2.254

Make sure that the default gateways of all hosts are set for the IP address of the host's VLAN interface, set above.

That should do it. Check out other features in the configuration guide:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_19/config/index.htm

New Member

Re: Cisco Catalyst 4506 VLAN's and routing between them?

Thanks,

When I don't use the router to the internet, will the cisco route from one VLAN to the other?

Supose that a workstation 10.0.0.200 wants to communicate with a server 10.0.2.5. Will the catalyst then route all packets from one VLAN to the other?

Bronze

Re: Cisco Catalyst 4506 VLAN's and routing between them?

Yes, it will route between VLANs.

1221
Views
0
Helpful
4
Replies
CreatePlease to create content