Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco ISDN Router for connecting to ISP

Anyone knows that any of the Cisco router model can function like an ISDN lan modem, i.e. whenever there is Internet traffic demand, the router will call to ISP by ISDN and login to Internet based an username and password that given by the ISP (Just like the one that the analog modem dial-up).

The router will obtain an IP address from the ISP. Whenever there is no more Internet traffic, the router will disconnect the line in a given time frame.

Please suggest the appropriate Cisco router model and any sample configuration of it.

Please help out.

6 REPLIES
New Member

Re: Cisco ISDN Router for connecting to ISP

u can use cisco 801 router it has a bri interface & can make what u need

New Member

Re: Cisco ISDN Router for connecting to ISP

here's an example:

isdn switch-type basic-net3

!

interface Ethernet0

ip address xxxxx 255.255.255.0

ip nat inside

no shut

!

interface BRI 0

no shutdown

description connected to Internet

ip address negotiated

ip nat outside

no ip directed-broadcast

encapsulation ppp

dialer string xxxxx

dialer idle-timeout 300

dialer enable-timeout 5

dialer-group 1

dialer hold-queue 20

ppp authentication chap callin

ppp chap hostname xxxxxx

ppp chap password xxxxxxx

no cdp enable

no shut

no ppp multilink

!

!

ip nat inside source list 1 interface Bri 0 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 bri0

!

dialer-list 1 protocol ip permit

!

New Member

Re: Cisco ISDN Router for connecting to ISP

Thanks man on the 801 configuration guide.

New Member

Re: Cisco ISDN Router for connecting to ISP

Hi, first of all I tested your above configuration on a 2610 router. The symptom is that I failed to connect to ISP as the router console show that the BRI0/0 was connected to 1525 (my ISP ISDN #) and change state to up but immediately after that the bri0/0 changed state to down.

The state up and down continuously. What could be the reason ? My username and password are correct.

I used IE to enable the Internet traffic and I used ISDN Switch-type basic-net3.

New Member

Re: Cisco ISDN Router for connecting to ISP

Hi,

You can do this using any cisco low end router with onr BRI and one ethernet interface. ( my choice a cisco 1600 )

i can send you the required configuration on the router , to a email address.

you can mail me at - gouthamb@hotmail.com

New Member

Re: Cisco ISDN Router for connecting to ISP

I had emailed to our email address "gouthamb@hotmail.com" to request for the configuration guide on the router 1600. Please email me the entire configuration guide to me at "fkseow@datascan.com.my".

Thank you very much.

255
Views
0
Helpful
6
Replies