Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco ISR 1811 Netbios Resolve/Forwarding issue

I have an ISR 1811 which I have been using for years. I get almost all of the functionality that I want out of it except I am unable to reference wired/wireless hostnames when using the opposite connection type.

For instance, if I have my laptop on wireless it is given an IP in subnet 20.20.20.0/24 such as 20.20.20.2. From my desktop computer (on subnet 10.10.10.0/24) I am able to ping 20.20.20.2 without issue but when I ping "laptopname" I am unable to resolve (this does not work in either direction). Therefore trying to use \\nodename\share do not work either.

Based on my understanding I am running both wired and wireless subnets in VLAN1 and I'm using the BVI interface for wireless.

I have tried ip helper-address many times, fiddled with vlan configurations, and tried ip forward-protocols in various variations without luck.

Here is my configuration:

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ISR

!

boot-start-marker

boot-end-marker

!

no logging buffered

no logging console

enable secret 5 xxxxxx

enable password 7 xxxxxx

!

no aaa new-model

!

!

!

!

!

dot11 ssid secure

   vlan 1

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 xxxxxxxx

!

no ip source-route

!

!

ip nbar port-map custom-01 tcp 59835

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 10.10.10.7

ip dhcp excluded-address 20.20.20.7

ip dhcp excluded-address 10.10.10.8

ip dhcp excluded-address 10.10.10.2

ip dhcp excluded-address 10.10.10.4

ip dhcp excluded-address 10.10.10.18

ip dhcp excluded-address 10.10.10.88

ip dhcp excluded-address 20.20.20.88

ip dhcp excluded-address 20.20.20.8

ip dhcp excluded-address 20.20.20.18

ip dhcp excluded-address 10.10.10.55

ip dhcp excluded-address 10.10.10.230 10.10.10.255

!

ip dhcp pool Wired_DHCP

   network 10.10.10.0 255.255.255.0

   default-router 10.10.10.1

   dns-server 8.8.8.8

   lease 2

!

ip dhcp pool wifi_DHCP

   network 20.20.20.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 20.20.20.1

   lease 2

!

!

no ip bootp server

no ip domain lookup

ip port-map user-RedTorrents port tcp 59835

!

multilink bundle-name authenticated

!

!

archive

log config

  hidekeys

!

!

bridge irb

!

!

!

interface FastEthernet0

no ip address

duplex auto

speed auto

!

interface FastEthernet1

description Connected to ASA

ip address 10.0.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet2

spanning-tree portfast

!

interface FastEthernet3

spanning-tree portfast

!

interface FastEthernet4

spanning-tree portfast

!

interface FastEthernet5

spanning-tree portfast

!

interface FastEthernet6

spanning-tree portfast

!

interface FastEthernet7

spanning-tree portfast

!

interface FastEthernet8

spanning-tree portfast

!

interface FastEthernet9

spanning-tree portfast

!

interface Dot11Radio0

no ip address

no ip redirects

ip local-proxy-arp

ip virtual-reassembly

!

encryption vlan 1 mode ciphers tkip

!

ssid secure

!

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

power local cck 15

power local ofdm 15

power client 20

station-role root

no cdp enable

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip redirects

ip local-proxy-arp

ip virtual-reassembly

!

encryption vlan 1 mode ciphers tkip

!

ssid secure

!

speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root

no cdp enable

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description Wired Segment

ip address 10.10.10.1 255.255.255.0

ip virtual-reassembly

!

interface Async1

no ip address

encapsulation slip

!

interface BVI1

description WiFi

ip address 20.20.20.1 255.255.255.0

ip virtual-reassembly

ip tcp adjust-mss 1452

!

ip route 0.0.0.0 0.0.0.0 10.0.0.2

ip route 10.0.0.0 255.255.255.0 10.0.0.2

!

ip flow-top-talkers

top 20

sort-by bytes

cache-timeout 10000

!

ip http server

no ip http secure-server

!

no logging trap

access-list 1 remark vlan1

access-list 1 permit 10.10.10.0 0.0.0.255

access-list 1 remark vlan2

access-list 1 permit 20.20.20.0 0.0.0.255

access-list 121 deny   ip 10.10.10.0 0.0.0.255 10.0.0.0 0.0.0.255

access-list 121 permit ip 10.10.10.0 0.0.0.255 any

access-list 121 permit ip 20.20.20.0 0.0.0.255 any

no cdp run

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

Thanks for any help in advance.


129
Views
0
Helpful
0
Replies
CreatePlease to create content