Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CISCO ROUTER 2621 MALLOCFAIL, not resolved

We are using the CISCO 2621 router with one serial and one fastethernet port active and configured as attached. recently, we have seen a regularly occurring error on the Router which makes the Router stop responding .The error messages are as below :

1. SYS-2-MALLOCFAIL : memory allocation of 32768 bytes failed from 0x802BE320 pool processor alignment 0, process = "IP Input', ipl = 0, pid =25.

traceback= 802c1480 802c39cc 802be324 8076253c 807639e0 8075e198 803536d0 80352854 80352b90 802e0fe0

2. SYS-2-NOBLOCK : printf with blocking disabled

process= IP Input, ipl =0 , PID = 25

This has become more frequent in the past few days happening regulraly in two/three hours and we need to have a reload of the router everytime.

Please suggest. I am attaching the router conf text file and also the process memory details .

Hoping to have a lead to detect the problem.

with best regards,

Manish

config

nable secret 5 $1$5mz5$T8cC/QlkhTtWdy.NOseSm1

enable password 7 104B1A0A0405

!

!

!

!

!

clock timezone GMT 0 7

ip subnet-zero

!

ip accounting-list 0.0.0.51 255.255.249.0

lane client flush

interface FastEthernet0/0

ip address 10.1.10.1 255.255.248.0 secondary

ip address 202.158.18.65 255.255.255.240

ip accounting output-packets

ip nat inside

duplex auto

speed auto

!

interface Serial0/0

ip address 202.158.8.206 255.255.255.252

ip access-group 1 out

no ip proxy-arp

ip accounting output-packets

ip accounting precedence output

ip nat outside

no ip mroute-cache

no fair-queue

!

ip nat translation timeout never

ip nat translation tcp-timeout never

ip nat translation udp-timeout never

ip nat translation finrst-timeout never

ip nat translation syn-timeout never

ip nat translation dns-timeout never

ip nat translation icmp-timeout never

ip nat pool grp1 202.158.18.66 202.158.18.78 netmask 255.255.255.240

ip nat inside source list 1 pool grp1 overload

ip nat inside source static 10.1.8.5 202.158.18.79

ip classless

ip route 0.0.0.0 0.0.0.0 202.158.8.205

ip route 202.158.18.0 255.255.255.0 202.158.8.205

ip route 202.158.18.64 255.255.255.192 Null0

no ip http server

ip nat translation icmp-timeout never

ip nat pool grp1 202.158.18.66 202.158.18.78 netmask 255.255.255.240

ip nat inside source list 1 pool grp1 overload

ip nat inside source static 10.1.8.5 202.158.18.79

ip classless

ip route 0.0.0.0 0.0.0.0 202.158.8.205

ip route 202.158.18.0 255.255.255.0 202.158.8.205

ip route 202.158.18.64 255.255.255.192 Null0

no ip http server

!

access-list 1 permit 10.0.0.0 0.255.255.255

access-list 1 permit any

!

The process memory and details

sh proc mem

Total: 12632496, Used: 3695648, Free: 8936848

PID TTY Allocated Freed Holding Getbufs Retbufs Process

0 0 67932 1808 2572608 0 0 *Init*

0 0 420 55372 420 0 0 *Sched*

0 0 7241088 2059716 25460 169380 0 *Dead*

1 0 276 276 3844 0 0 Load Meter

2 0 2664 1168 14364 0 0 Exec

3 0 0 0 6844 0 0 Check heaps

4 0 20248 0 27092 0 0 Chunk Manager

5 0 96 0 6940 0 0 Pool Manager

6 0 276 276 6844 0 0 Timers

7 0 276 276 6844 0 0 Serial Backgroun

8 0 276 276 6844 0 0 Environmental mo

9 0 1264 1112 8108 0 0 ARP Input

10 0 276 276 6844 0 0 DDR Timers

11 0 276 276 12844 0 0 Dialer event

12 0 7496 1584 12756 0 0 Entity MIB API

13 0 96 0 6940 0 0 SERIAL A'detect

14 0 96 0 6940 0 0 Critical Bkgnd

15 0 28308 7428 13288 0 0 Net Background

16 0 372 276 12940 0 0 Logger

17 0 26164 276 6932 0 0 TTY Background

18 0 0 0 9844 0 0 Per-Second Jobs

PID TTY Allocated Freed Holding Getbufs Retbufs Process

19 0 276 276 6844 0 0 Hawkeye Backgrou

20 0 244 0 7088 0 0 HDV background

21 0 22816 276 29384 0 0 VNM DSPRM MAIN

22 0 192 0 7036 0 0 Net Input

23 0 276 276 6844 0 0 Compute load avg

24 0 0 0 6844 0 0 Per-minute Jobs

25 0 113456 0 113764 0 0 IP Input

26 0 12996 9184 10656 0 0 CDP Protocol

27 0 232 0 7076 0 0 X.25 Encaps Mana

28 0 700 276 7268 0 0 Emulator

29 0 0 0 6844 0 0 Asy FS Helper

30 0 0 0 6844 0 0 PPP IP Add Route

31 0 464 0 10308 0 0 IP Background

32 0 552 276 7120 0 0 Adj Manager

33 0 0 0 12844 0 0 TCP Timer

34 0 28608 0 14304 0 0 TCP Protocols

35 0 244 0 7088 0 0 Probe Input

36 0 96 0 6940 0 0 RARP Input

37 0 0 0 6844 0 0 HTTP Timer

38 0 0 0 6844 0 0 Socket Timers

39 0 149112 119200 23068 0 0 DHCPD Receive

40 0 0 8400 6844 0 0 IP Cache Ager

41 0 244 0 7088 0 0 PAD InCall

42 0 372 276 12940 0 0 X.25 Background

43 0 372 276 12940 0 0 ILMI Input

44 0 0 0 6844 0 0 SNMP Timers

45 0 372 276 6940 0 0 ILMI Request

46 0 372 276 6940 0 0 ILMI Response

47 0 0 0 6844 0 0 ILMI Timer Proce

48 0 5956 692 18108 0 0 ATM PVC Discover

49 0 372 276 6940 0 0 SSCOP Input

50 0 372 276 6940 0 0 SSCOP Output

51 0 276 276 6844 0 0 SSCOP Timer

52 0 372 276 6940 0 0 ATMSIG DRIVERAPI

53 0 0 0 24844 0 0 ISDN Timer

54 66 105856 105272 13428 0 0 Virtual Exec

55 0 7900 276 14468 0 0 CCVPM_HDSPRM

56 0 6176 0 13020 0 0 CCVPM_HTSP

57 0 25352 0 7352 0 0 CCSWVOICE

58 0 844 276 7412 0 0 tcl ivr app

59 0 844 276 7412 0 0 tcl ivr app

60 0 844 276 7412 0 0 tcl ivr app

61 0 844 276 7412 0 0 tcl ivr app

62 0 844 276 7412

1 REPLY

Re: CISCO ROUTER 2621 MALLOCFAIL, not resolved

First thing I would do is remove the "ip nat translation timeout xxx never", keeping translations open takes memory, and you are never releasing it. Change the timeout to the default or slightly higher than the default, but not never. Do a "show memory dead" to see what is taking the mem, I suspect it's the NAT. See link http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_tech_note09186a00800a6f3a.shtml#deadprocess .

See if that makes a difference. If not, try and remove ip accounting, or at the least narrow down the accounting list.

Steve

223
Views
0
Helpful
1
Replies
CreatePlease to create content