Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco router and Port Forwarding?

Hi, I have a couple of questions, first I have a Cisco Soho 77 ADSL that I want to setup as a Web server in my PC. I tried using Dynamic DNS service http://www.dynu.com or http://www.no-ip.com and others, I think that my current config is Nat/Pat, I did a reverse mapping to my NAT, I added

"ip nat inside source static tcp 192.168.25.3 80 10.28.1.29 80 extendable" and still doesnt works, I think I need to do a port forwarding, but dont have CRWS configured. How does one set up port forwarding on the Cisco SOHO 77 router?

This is my router Configuration.

Current configuration : 1118 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Client_Name

!

enable secret 5 $$$$$$$$$$$$$$$$$.

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

ip dhcp pool dsl1

network 192.168.25.0 255.255.255.0

default-router 192.168.25.1

domain-name ISP.net.gt

dns-server x.x.x.3 216.230.128.32

!

!

!

!

interface Ethernet0

no shut

ip address 192.168.25.1 255.255.255.0

ip nat inside

!

interface ATM0

no shut

description Cliente_No.de Serie_DSLAM_Puerto DSLAM_ TEL

ip address 10.28.1.30 255.255.255.252

ip nat outside

no atm ilmi-keepalive

pvc 0/32

protocol ip 10.28.1.29

encapsulation aal5snap

!

dsl operating-mode auto

hold-queue 224 in

!

ip nat inside source list 101 interface ATM0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 10.28.1.29

no ip http server

!

access-list 101 permit ip 192.168.25.0 0.0.0.255 any

!

line con 0

stopbits 1

line vty 0 4

password thepassword

login

!

scheduler max-task-time 5000

end

The router doesn't have port forwarding configured so it just denies the connection. So I need to configure port forwarding.

Thanks for your help.

2 REPLIES
New Member

Re: Cisco router and Port Forwarding?

have you tried

ip nat inside source static tcp 192.168.25.3 80 interface ATM0 80

can you use show ip nat trans to make sure that the translation is happening from the outside? does your ISP allow port 80? try

ip nat inside source static tcp 192.168.25.3 80 interface ATM0 1700

and then try http://10.28.1.30:1700 to check if port 80 not allowed, if this works then 80 is blocked. pick any port # you want.

New Member

Re: Cisco router and Port Forwarding?

I added to my router config "ip nat inside source static tcp 192.168.25.3 80 interface ATM0 80", but still doesnt works, also I use "show ip nat trans", and shows up the below info. What could be the problem? Thanks for your help

Name_Client#sh ip nat trans

Pro Inside global Inside local Outside local Outside global

tcp 10.28.1.30:36668 192.168.25.3:36668 216.230.149.10:21 216.230.149.10:21

tcp 10.28.1.30:36660 192.168.25.3:36660 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36661 192.168.25.3:36661 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36694 192.168.25.3:36694 198.144.7.122:23 198.144.7.122:23

tcp 10.28.1.30:36664 192.168.25.3:36664 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36672 192.168.25.3:36672 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36686 192.168.25.3:36686 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36685 192.168.25.3:36685 198.144.7.122:80 198.144.7.122:80

tcp 10.28.1.30:36712 192.168.25.3:36712 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36717 192.168.25.3:36717 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36727 192.168.25.3:36727 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:36726 192.168.25.3:36726 198.144.7.122:80 198.144.7.122:80

udp 10.28.1.30:35865 192.168.25.2:35865 66.98.158.185:33033 66.98.158.185:33033

tcp 10.28.1.30:36695 192.168.25.3:36695 24.118.52.210:443 24.118.52.210:443

tcp 10.28.1.30:36701 192.168.25.3:36701 24.118.52.210:443 24.118.52.210:443

tcp 10.28.1.30:36728 192.168.25.3:36728 24.118.52.210:443 24.118.52.210:443

tcp 10.28.1.30:1029 192.168.25.2:1029 64.246.49.60:33033 64.246.49.60:33033

tcp 10.28.1.30:36653 192.168.25.3:36653 216.239.39.99:80 216.239.39.99:80

tcp 10.28.1.30:1028 192.168.25.2:1028 80.160.91.13:80 80.160.91.13:80

tcp 10.28.1.30:80 192.168.25.3:80 --- ---

udp 10.28.1.30:35865 192.168.25.2:35865 64.246.49.61:53802 64.246.49.61:53802

udp 10.28.1.30:32776 192.168.25.3:32776 216.230.128.3:53 216.230.128.3:53

tcp 10.28.1.30:36748 192.168.25.3:36748 63.215.241.204:8245 63.215.241.204:8245

tcp 10.28.1.30:1036 192.168.25.2:1036 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:1065 192.168.25.2:1065 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:1068 192.168.25.2:1068 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:1070 192.168.25.2:1070 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:1072 192.168.25.2:1072 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:1074 192.168.25.2:1074 216.230.149.10:80 216.230.149.10:80

tcp 10.28.1.30:1073 192.168.25.2:1073 198.144.7.122:80 198.144.7.122:80

tcp 10.28.1.30:36745 192.168.25.3:36745 204.69.199.39:80 204.69.199.39:80

tcp 10.28.1.30:36747 192.168.25.3:36747 204.69.199.39:80 204.69.199.39:80

tcp 10.28.1.30:36749 192.168.25.3:36749 204.69.199.39:80 204.69.199.39:80

tcp 10.28.1.30:36750 192.168.25.3:36750 204.69.199.39:80 204.69.199.39:80

tcp 10.28.1.30:36752 192.168.25.3:36752 204.69.199.39:80 204.69.199.39:80

udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33438 198.144.7.122:33438

udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33439 198.144.7.122:33439

udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33440 198.144.7.122:33440

udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33441 198.144.7.122:33441

509
Views
0
Helpful
2
Replies
CreatePlease to create content