Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cisco3745 and ICMP message type 3

our customer has got a cisco3745 which seems to be blocking hotmail.com.

when it is removed from the network it works fine. When we put a sniffer we can see that the DNS gives the client the IP address and the host sends query to the hotmail site. But after that we see an ICMP message Type3 and Code 1.coming back to the host. Apart from this site everything works fine. It is running 12.2(13)T1. Config is as follows. Any ideas wht might causing this?

Building configuration...

Current configuration : 1120 bytes

!

! Last configuration change at 17:45:12 UTC Thu Feb 13 2003

! NVRAM config last updated at 17:56:11 UTC Thu Feb 13 2003

!

version 12.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

no service password-encryption

!

hostname PH-Internet-RT

!

boot system flash c3745-i-mz.122-13.T1.bin

logging buffered 10000 debugging

enable password <removed>

!

ip subnet-zero

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.220.30 255.255.255.0

shutdown

speed 100

full-duplex

!

interface FastEthernet0/1

ip address 10.0.230.30 255.255.255.0

speed 100

full-duplex

!

router ospf 1

log-adjacency-changes

network 10.0.220.0 0.0.0.255 area 0

default-information originate

!

no ip classless

ip route 0.0.0.0 0.0.0.0 10.0.230.20

ip http server

ip pim bidir-enable

!

!

snmp-server community <removed> RO

snmp-server community <removed> RW

snmp-server enable traps tty

snmp-server enable traps config

snmp-server host 10.0.2.100 <removed>

!

line con 0

password <removed>

login

line aux 0

line vty 0 4

password <removed>

login

!

ntp clock-period 17179864

ntp server 10.0.20.15

end

3 REPLIES
Silver

Re: cisco3745 and ICMP message type 3

Type 3 is destination unreachable. What is sending this back to the client? This router? What is the IP address the client is getting from the DNS? Can you trace to this from this router? If not where does it die? Have you checked this router as well?

Hope this helps you,

Don

New Member

Re: cisco3745 and ICMP message type 3

This message is sourced by the Fast Ethernet Interface of the router. The client is getting 64.4.43.7 from the DNS for Hotmail. Following are the tarceroute from the PC. I have asked to get it from router.

E:\>tracert www.yahoo.com

Tracing route to www.yahoo.akadns.net [216.109.125.71]

over a maximum of 30 hops:

1 <10 ms <10 ms <10 ms 10.0.206.9

2 <10 ms <10 ms <10 ms 10.0.220.30

3 * * * Request timed out.

4 <10 ms 10 ms <10 ms 212-127-1-193.concert.net [212.127.1.193]

5 <10 ms 10 ms 10 ms t2a3-s4-0-7.uk-lon1.concert.net [166.49.129.133]

6 <10 ms 10 ms <10 ms t2c1-ge6-0.uk-lon1.concert.net [166.49.135.11]

7 <10 ms 10 ms <10 ms t2c1-ge6-2.uk-lon2.concert.net [166.49.208.241]

8 70 ms 80 ms 80 ms 12.125.51.21

9 80 ms 80 ms 80 ms att-gw.ny.cw.net [192.205.32.118]

10 90 ms 90 ms 100 ms agr4-loopback.NewYork.cw.net [206.24.194.104]

11 91 ms 90 ms 100 ms dcr1-so-7-3-0.NewYork.cw.net [206.24.207.77]

12 80 ms 101 ms 80 ms dcr1-loopback.Washington.cw.net [206.24.226.99]

13 90 ms 90 ms 90 ms bhr1-pos-0-0.Sterling1dc2.cw.net [206.24.238.34]

14 90 ms 110 ms 90 ms csr11-ve241.Sterling2dc3.cw.net [216.109.66.90]

15 90 ms 100 ms 110 ms 216.109.84.162

16 90 ms 90 ms 90 ms vl30.bas1-m.dcn.yahoo.com [216.109.120.142]

17 90 ms 100 ms 90 ms w18.www.dcn.yahoo.com [216.109.125.71]

Trace complete.

E:\>tracert www.hotmail.com

Tracing route to www.hotmail.com [64.4.52.7]

over a maximum of 30 hops:

1 <10 ms <10 ms <10 ms 10.0.206.9

2 <10 ms <10 ms <10 ms 10.0.220.30

3 10.0.220.30 reports: Destination host unreachable.

Silver

Re: cisco3745 and ICMP message type 3

I see no reason, based on your config, that this router would be tossing this or generating the ICMP message. Can you check 10.0.230.20, where you're default route is pointed, to ensure that this router is not the culprit. A trace from the router would be great help.

Hope this helps you,

Don

92
Views
0
Helpful
3
Replies
CreatePlease to create content