Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cisco3745 encapsulation failed

Hi,

I have a Cisco3745 running IOS 12.2(15)T9

There are E1 interfaces and MICA modems inserted.

It doesn't work if I try to dial in. I always get this debug output:

*Mar 1 02:03:58: IP: s=10.38.255.11 (Async87), d=192.1.1.2 (FastEthernet0/0), g=192.1.1.2, len 60, forward

*Mar 1 02:03:58: IP: s=192.1.1.2 (FastEthernet0/0), d=10.38.255.11 (Async87), g=10.38.255.11, len 52, forward

*Mar 1 02:03:58: IP: s=192.1.1.2 (FastEthernet0/0), d=10.38.255.11 (Async87), len 52, encapsulation failed

Here is the configuration of the router:

isdn switch-type primary-net5

!

modemcap entry v90-fa:MSC=&F&D2s0=0

call-history-mib retain-timer 500

!

!

controller E1 1/0

pri-group timeslots 1-31

description *** VN 043 / XXX XX XX ***

!

controller E1 1/1

shutdown

pri-group timeslots 1-31

!

!

interface Loopback0

ip address 10.38.255.68 255.255.255.255

!

interface FastEthernet0/0

description *** Connection to Server ***

ip address 192.1.1.64 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip nat outside

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

ip nat inside

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-net5

isdn timer t321 0

isdn caller 004940539318xxx

isdn caller 00423xxxxxxx

isdn caller 091xxxxxxx

isdn caller 081xxxxxxx

isdn caller 071xxxxxxx

isdn caller 062xxxxxxx

isdn caller 061xxxxxxx

isdn caller 058xxxxxxx

isdn caller 056xxxxxxx

isdn caller 055xxxxxxx

isdn caller 052xxxxxxx

isdn caller 051xxxxxxx

isdn caller 044xxxxxxx

isdn caller 043xxxxxxx

isdn caller 041xxxxxxx

isdn caller 034xxxxxxx

isdn caller 033xxxxxxx

isdn caller 032xxxxxxx

isdn caller 031xxxxxxx

isdn caller 027xxxxxxx

isdn caller 026xxxxxxx

isdn caller 024xxxxxxx

isdn caller 022xxxxxxx

isdn caller 021xxxxxxx

isdn caller 01xxxxxxx

isdn caller 076xxxxxxx

isdn caller 078xxxxxxx

isdn caller 079xxxxxxx

isdn caller 00411xxxxxxx

isdn caller 0041xxxxxxxxx

isdn caller 004940539318xx

isdn incoming-voice modem

no keepalive

no cdp enable

!

interface Serial1/1:15

no ip address

isdn switch-type primary-net5

no cdp enable

!

interface Group-Async1

description *** Bind Modem-lines ***

ip unnumbered Loopback0

ip nat inside

encapsulation ppp

no ip route-cache cef

no ip mroute-cache

no logging event link-status

dialer in-band

dialer idle-timeout 600

dialer mult-map-same-name

dialer-group 1

async mode dedicated

peer default ip address pool ep2urdorf

no keepalive

pulse-time 2

no fair-queue

ppp ipcp ignore-map

ppp ipcp username unique

group-range 65 94

!

interface Dialer1

description *** ISDN Terminals ***

ip unnumbered Loopback0

ip nat inside

encapsulation ppp

no ip route-cache cef

dialer in-band

dialer idle-timeout 1200

dialer mult-map-same-name

peer default ip address pool ep2urdorf

no keepalive

ppp ipcp ignore-map

!

interface Dialer2

description *** analoge Terminals ***

ip unnumbered Loopback0

ip accounting output-packets

ip nat inside

encapsulation ppp

no ip route-cache cef

no ip mroute-cache

dialer pool 2

snmp ifindex persist

peer default ip address pool ep2urdorf

no keepalive

no fair-queue

no cdp enable

ppp ipcp ignore-map

!

ip local pool ep2urdorf 10.38.255.1 10.38.255.62

ip nat translation max-entries 2147483647

ip nat outside source static 192.1.1.91 153.46.226.7

no ip http server

ip classless

ip route 153.46.226.7 255.255.255.255 FastEthernet0/0

ip route 193.192.234.1 255.255.255.255 FastEthernet0/0

!

dialer-list 1 protocol ip permit

line 65 94

no exec-banner

exec-timeout 0 0

flush-at-activation

modem answer-timeout 0

modem Dialin

modem autoconfigure type v90-fa

no editing

transport preferred none

transport output none

escape-character NONE

autoselect ppp

line 97 126

flush-at-activation

line aux 0

exec-timeout 5 0

password 7 <removed>

I'll really appreciate when someone could help me.

Peter

1 REPLY
New Member

Re: cisco3745 encapsulation failed

Hi Peter

I haven't checked every command in your config, but is nat necessary, and is it necessary the way you do it (fa0/0 is outside, dialer is inside).

If you *need* nat, then try to exclusively put the ip nat inside command on the dialer (not on the serial and the group-async).

Use these debugs:

deb isdn q931

deb dialer

deb ip nat (and maybe some options)

deb aaa negotiation

deb aaa authentication

Hope that helps.

Cheers

Toni

377
Views
0
Helpful
1
Replies
CreatePlease login to create content