Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Clearing a stuck modem autoconfig process

Hi,

Does anyone know how to stop or kill a CPU process on a 1760 router?

After configuring a "modem autoconfigure discovery" on an Asnyc line, and later removing the line, the router keeps the process running, consuming a lot of resources. The only way I know to stop this is to

reload the router.

This is the output from the router showing this:

Router config:

interface Async5

description ENLACE-ASYNC

bandwidth 28

ip address 180.1.yyy.xx 255.255.0.0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 60

dialer enable-timeout 10

dialer wait-for-carrier-time 60

dialer string 01800.......

dialer watch-group 1

dialer-group 1

async default routing

async mode dedicated

priority-group 3

pulse-time 1

ppp authentication chap

line aux 0

script dialer reduno

modem InOut

transport input all

stopbits 1

speed 38400

flowcontrol hardware

line vty 0 4

password xxxxx

show outputs:

S0113MTSTAFE#sh line aux 0

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 5 AUX 38400/38400 - inout - - - 2 0 56/0 -

Ready, Carrier Dropped

Line 5, Location: "ENLACE-ASYNC", Type: ""

Length: 24 lines, Width: 80 columns

Baud rate (TX/RX) is 38400/38400, no parity, 1 stopbits, 8 databits

Status: Ready, Active, No Exit Banner, Rcvd BREAK, CTS Raised

Modem Configuring, Autoconfig Running

Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

Modem Callout, Modem RI is CD, Line is permanent async interface

Modem state: Ready, Carrier Dropped

Modem hardware state: CTS* noDSR DTR RTS

TTY NUMBER 5

Parity Error = 0 Framing Error = 4806 Receive Error = 4807 Overrun = 56

Outcount = 0 totalout = 2249 incount = 108 totalin = 22676

Special Chars: Escape Hold Stop Start Disconnect Activation

^^x none - - none

Timeouts: Idle EXEC Idle Session Modem

S0113MTSTAFE#sh proc cpu

CPU utilization for five seconds: 25%/0%; one minute: 23%; five minutes: 21%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

81 913259913282105538 27 22.52% 22.61% 20.00% 5 Modem Autoconfig

I have tried clearing the line aux, disconnecting the modem, resetting the modem,

clearing the dialer and none of these things has worked so far.

Even though reloading the router clears the problem, it is time consuming since the

reloading has to be done late at night, so I would like to just kill the stuck process.

I have searched the Cisco website and the Internet on how to do this, but have not found

the answer yet.

Any help will be greatly appreciated.

Thanks

Eduardo.

2 REPLIES
Silver

Re: Clearing a stuck modem autoconfig process

This surely is a bug. What IOS image are you running on the c1760?

CSCds47583 "Modem Autoconfig process stuck and using 2% CPU"

Unfortunately there is no way to kill the process thru CLI, try upgrading the IOS or open a TAC case for early resolution.

Thanks, Mak.

New Member

Re: Clearing a stuck modem autoconfig process

The IOS version we´re running is the following:

S0113MTSTAFE#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-BNR2SY7-M), Version 12.2(4)YB, EARLY DEPLOYMENT R

ELEASE SOFTWARE (fc1)

Synched to technology version 12.2(6.8)T2

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Fri 15-Mar-02 15:48 by ealyon

Image text-base: 0x80008124, data-base: 0x80E04DEC

ROM: System Bootstrap, Version 12.2(4r)XL, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-BNR2SY7-M), Version 12.2(4)YB, EARLY DEPLOYMENT RELEA

SE SOFTWARE (fc1)

S0113MTSTAFE uptime is 23 weeks, 5 days, 3 hours, 3 minutes

System returned to ROM by power-on

System restarted at 16:25:22 CST Wed Aug 27 2003

System image file is "flash:c1700-bnr2sy7-mz.122-4.YB.bin"

The problem we have with upgrading the IOS is that we are a large bank in Mexico and have about 1700 branch offices. We are running this IOS in almost everyone of them, so that would be a great undertaking, to say the least! I think we will go with the TAC case.

Thanks a lot for your time.

Regards,

Eduardo Alvarez

451
Views
3
Helpful
2
Replies