Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

compression on a dialer interface.

I want to use software compression on ISDN dial backup lines. I currently use compression for analog backup via an ISDN pri and MICA modems with no problems. When I try to invoke compression on ISDN calls it does not negotiate compression. Am I missing something in the config? Below are the conifg parameters and debug output from the peripheral and the catcher router..

Peripheral config:(2650/12.2(7a))

!

interface BRI1/0

no ip address

encapsulation ppp

no ip mroute-cache

dialer rotary-group 0

isdn switch-type basic-ni

isdn spid1 015120867000

isdn spid2 015120885000

compress stac

no cdp enable

!interface BRI1/1

no ip address

encapsulation ppp

no ip mroute-cache

dialer rotary-group 0

isdn switch-type basic-ni

isdn spid1 015121523000

isdn spid2 015129507000

compress stac

no cdp enable

!

interface Dialer0

ip address xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy

encapsulation ppp

ip ospf network point-to-multipoint

ip ospf hello-interval 10

no ip mroute-cache

dialer in-band

dialer string 18888772210

dialer load-threshold 1 outbound

dialer-group 1

compress stac

no cdp enable

ppp authentication chap

ppp chap password 7 121E0816401F000B26

ppp multilink

!

Peripheral debug (ppp negotiation)

GGRTR(config-if)#int dialer0

GGRTR(config-if)#no shut

GGRTR(config-if)#

*Mar 9 16:29:58.181: %LINK-3-UPDOWN: Interface BRI1/1:1, changed state to up

*Mar 9 16:29:58.185: BR1/1:1 PPP: Treating connection as a callout

*Mar 9 16:29:58.185: BR1/1:1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 2 load]

*Mar 9 16:29:58.185: BR1/1:1 LCP: O CONFREQ [Closed] id 17 len 27

*Mar 9 16:29:58.185: BR1/1:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 9 16:29:58.185: BR1/1:1 LCP: MagicNumber 0x35BA8724 (0x050635BA8724)

*Mar 9 16:29:58.185: BR1/1:1 LCP: MRRU 1524 (0x110405F4)

*Mar 9 16:29:58.189: BR1/1:1 LCP: EndpointDisc 1 GGRTR (0x1308014747525452)

*Mar 9 16:29:58.213: BR1/1:1 LCP: I CONFREQ [REQsent] id 36 len 29

*Mar 9 16:29:58.213: BR1/1:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 9 16:29:58.213: BR1/1:1 LCP: MagicNumber 0x79FDEBB5 (0x050679FDEBB5)

*Mar 9 16:29:58.213: BR1/1:1 LCP: MRRU 1524 (0x110405F4)

*Mar 9 16:29:58.213: BR1/1:1 LCP: EndpointDisc 1 Catcher (0x130A0143617463686572)

*Mar 9 16:29:58.213: BR1/1:1 LCP: O

GGRTR(config-i CONFACK [REQsent] id 36 len 29

*Mar 9 16:29:58.213: BR1/1:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 9 16:29:58.213: BR1/1:1 LCP: MagicNumber 0x79FDEBB5 (0x050679FDEBB5)

*Mar 9 16:29:58.213: BR1/1:1 LCP: MRRU 1524 (0x110405F4)

*Mar 9 16:29:58.213: BR1/1:1 LCP: EndpointDisc 1 Catcher (0x130A0143617463686572)

*Mar 9 16:29:58.217: BR1/1:1 LCP: I CONFACK [ACKsent] id 17 len 27

*Mar 9 16:29:58.217: BR1/1:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 9 16:29:58.217: BR1/1:1 LCP: MagicNumber 0x35BA8724 (0x050635BA8724)

*Mar 9 16:29:58.217: BR1/1:1 LCP: MRRU 1524 (0x110405F4)

*Mar 9 16:29:58.217: BR1/1:1 LCP: EndpointDisc 1 GGRTR (0x1308014747525452)

*Mar 9 16:29:58.217: BR1/1:1 LCP: State is Open

*Mar 9 16:29:58.221: BR1/1:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]

*Mar 9 16:29:58.221: BR1/1:1 CHAP: O CHALLENGE id 12 len 26 from "XXX"

*Mar 9 16:29:58.237: BR1/1:1 CHAP: I CHALLENGE id 16 len 28 from "YYY"

*Mar 9 16:29:58.237: BR1/1:1 CHAP: O RESPONSE id 16 len 26 from "XXX"

*Mar 9 16:29:58.261: BR1/1:1 CHAP: I SUCCESS id 16 len 4

*Mar 9 16:29:58.265: BR1/1:1 CHAP: I RESPONSE id 12 len 28 from "YYY"

*Mar 9 16:29:58.265: BR1/1:1 CHAP: O SUCCESS id 12 len 4

*Mar 9 16:29:58.265: BR1/1:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

*Mar 9 16:29:58.269: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]

*Mar 9 16:29:58.269: Vi1 PPP: No remote authentication for call-out

*Mar 9 16:29:58.269: Vi1 PPP: Phase is ESTABLISHING [0 sess, 1 load]

*Mar 9 16:29:58.269: Vi1 CCP: Compression already closed

*Mar 9 16:29:58.269: Vi1 CCP: Re-Syncing history using legacy method

*Mar 9 16:29:58.269: Vi1 CCP: Compression already closed

*Mar 9 16:29:58.269: Vi1 CCP: Re-Syncing history using legacy method

*Mar 9 16:29:58.277: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Mar 9 16:29:58.281: Vi1 PPP: Treating connection as a callout

*Mar 9 16:29:58.281: Vi1 LCP: O CONFREQ [Closed] id 1 len 27

*Mar 9 16:29:58.281: Vi1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 9 16:29:58.281: Vi1 LCP: MagicNumber 0x35BA8787 (0x050635BA8787)

*Mar 9 16:29:58.281: Vi1 LCP: MRRU 1524 (0x110405F4)

*Mar 9 16:29:58.281: Vi1 LCP: EndpointDisc 1 GGRTR (0x1308014747525452)

*Mar 9 16:29:58.285: Vi1 PPP: Phase is UP [0 sess, 1 load]

*Mar 9 16:29:58.289: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

*Mar 9 16:29:58.289: Vi1 IPCP: Address 11.229.111.41 (0x03060BE56F29)

*Mar 9 16:29:58.289: Vi1 CCP: Compression already closed

*Mar 9 16:29:58.289: Vi1 CCP: O CONFREQ [Closed] id 1 len 10

*Mar 9 16:29:58.289: Vi1 CCP: LZSDCP history 1 check mode SEQ process UNCOMPRESSSED (0x170600010201)

*Mar 9 16:29:58.289: Vi1 MLP: Added first link BR1/1:1 to bundle Catcher

*Mar 9 16:29:58.297: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

*Mar 9 16:29:58.297: Vi1 IPCP: Address 11.229.136.245 (0x03060BE588F5)

*Mar 9 16:29:58.297: Vi1 IPCP: O CONFACK [REQsent] id 1 len 10

*Mar 9 16:29:58.297: Vi1 IPCP: Address 11.229.136.245 (0x03060BE588F5)

*Mar 9 16:29:58.297: Vi1 CCP: I CONFREQ [REQsent] id 1 len 10

*Mar 9 16:29:58.297: Vi1 CCP: LZSDCP history 1 check mode SEQ process UNCOMPRESSSED (0x170600010201)

*Mar 9 16:29:58.297: Vi1 CCP: O CONFACK [REQsent] id 1 len 10

*Mar 9 16:29:58.301: Vi1 CCP: LZSDCP history 1 check mode SEQ process UNCOMPRESSSED (0x170600010201)

*Mar 9 16:29:58.305: Vi1 IPCP: I CONFACK [ACKsent] id 1 len 10

*Mar 9 16:29:58.305: Vi1 IPCP: Address 11.229.111.41 (0x03060BE56F29)

*Mar 9 16:29:58.309: Vi1 IPCP: State is Open

*Mar 9 16:29:58.309: Vi1 CCP: I CONFACK [ACKsent] id 1 len 10

*Mar 9 16:29:58.309: Vi1 CCP: LZSDCP history 1 check mode SEQ process UNCOMPRESSSED (0x170600010201)

*Mar 9 16:29:58.309: Vi1 CCP: State is Open

*Mar 9 16:29:58.313: Vi1 CCP: ppp_hwcomp_open: no h/w

*Mar 9 16:29:58.313: Di0 IPCP: Install route to xxx.xxx.xxx.xxx

*Mar 9 16:29:58.618: %LINK-3-UPDOWN: Interface Dialer0, changed state to up

*Mar 9 16:29:58.622: Di0 LCP: Not allowed on a Rotary Group

*Mar 9 16:29:59.267: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/1:1, changed state to up

*Mar 9 16:29:59.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

*Mar 9 16:30:01.715: %OSPF-5-ADJCHG: Process 1, Nbr xxx.xxx.xxx.xxx on Dialer0 from LOADING to FULL, Loading Done

*Mar 9 16:30:02.336: %LINK-3-UPDOWN: Interface BRI1/1:2, changed state to up

******After an FTP of a text file********

GGRTR#sho compress

Dialer0

Software compression enabled

uncompressed bytes xmt/rcv 0/0

compressed bytes xmt/rcv 0/0

1 min avg ratio xmt/rcv 0.000/0.000

5 min avg ratio xmt/rcv 0.000/0.000

10 min avg ratio xmt/rcv 0.000/0.000

no bufs xmt 0 no bufs rcv 0

resyncs 0

Additional Stacker Stats:

Transmit bytes: Uncompressed = 0 Compressed = 0

Received bytes: Compressed = 0 Uncompressed = 0

Central catcher router config:

!

interface Serial2/0:23

no ip address

encapsulation ppp

ip mroute-cache

dialer rotary-group 0

isdn switch-type primary-ni

isdn incoming-voice modem

compress stac

no cdp enable

!

interface Group-Async1

no ip address

no ip mroute-cache

dialer in-band

dialer rotary-group 0

async default routing

async mode dedicated

no fair-queue

compress stac

group-range 97 120

!

interface Dialer0

ip address 11.229.136.245 255.0.0.0

encapsulation ppp

no ip route-cache

ip ospf network point-to-multipoint

ip ospf hello-interval 10

no ip mroute-cache

dialer-group 1

no peer default ip address

compress stac

no cdp enable

ppp authentication chap

ppp chap password 7 'deleted'

ppp multilink

!

  • Other Network Infrastructure Subjects
2 REPLIES
Cisco Employee

Re: compression on a dialer interface.

From the debug, the compression did get negotiated fine..as we have CCP state is open

*Mar 9 16:29:58.309: Vi1 CCP: State is Open

There are many issue in compression related areas reported..

Some very well knowns are

CSCdx65221 which is reported for "Compression statictics not gathered on virtual access interface" while data gets compressed fine.

CSC09965 : Software compression reported 0 counts on dialer rotary-groups

So you can turn on "debug compression" and try to do ping or ftp and see the data gets compressed or not..Follow the debug and load the fixed version of the ios near latest..

Cisco Employee

Re: compression on a dialer interface.

I will also suggest to look for upgrading IOS .

Please have a look at the release note

I made a setup with a AS5800 running 12.2(7)

The test has been sucessfull for MPPC and ip tcp header-compression

Please see below my interesting outputs and comments which will help you.

I will put the case in close-pending.

regards

Jean-Michel

Cisco Systems - TAC

Jean-Michel Veyne

Phone : +32 2 704 5162

ccie# 7025

Two test have been made

1) compress mppc

2) ip tcp header-compression

1) compress mppc

interface Serial1/0/0:15

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

compress mppc

!

interface Dialer1

ip unnumbered FastEthernet0/0/0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer-group 1

peer default ip address pool default

compress mppc

ppp authentication chap pap callin

end

dynamite#sh debug

PPP:

PPP protocol negotiation debugging is on

ISDN:

ISDN Q931 packets debugging is on

ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)

DSL 0 --> 31

1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

DSL 32 --> 55

- - - - - - - - - - - - - - - - - - - - - - - -

dynamite#

===> In the debug below, if you see : CCP: State is Open

it means that compress mppc is active

dynamite#

*Mar 20 14:41:20.899: ISDN Se1/0/0:15: RX <- SETUP pd = 8 callref = 0x002B

*Mar 20 14:41:20.899: Bearer Capability i = 0x8890

*Mar 20 14:41:20.899: Channel ID i = 0xA98381

*Mar 20 14:41:20.903: Called Party Number i = 0x81, '3', Plan:ISDN, Type:Unknown

*Mar 20 14:41:20.903: Se1/0/0:0 PPP: Treating connection as a callin

*Mar 20 14:41:20.903: Se1/0/0:0 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

*Mar 20 14:41:20.903: Se1/0/0:0 LCP: State is Listen

*Mar 20 14:41:20.903: ISDN Se1/0/0:15: TX -> CALL_PROC pd = 8 callref = 0x802B

*Mar 20 14:41:20.903: Channel ID i = 0xA98381

*Mar 20 14:41:20.903: ISDN Se1/0/0:15: TX -> CONNECT pd = 8 callref = 0x802B

*Mar 20 14:41:20.903: Channel ID i = 0xA98381

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: I CONFREQ [Listen] id 33 len 10

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: MagicNumber 0x1545BF93 (0x05061545BF93)

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: O CONFREQ [Listen] id 16 len 15

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: AuthProto CHAP (0x0305C22305)

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: MagicNumber 0xD020DD82 (0x0506D020DD82)

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: O CONFACK [Listen] id 33 len 10

*Mar 20 14:41:20.919: Se1/0/0:0 LCP: MagicNumber 0x1545BF93 (0x05061545BF93)

*Mar 20 14:41:20.919: ISDN Se1/0/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x002B

*Mar 20 14:41:20.919: ISDN Se1/0/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0xA, bchan 0, dsl 0

*Mar 20 14:41:20.927: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 16 len 15

*Mar 20 14:41:20.927: Se1/0/0:0 LCP: AuthProto CHAP (0x0305C22305)

*Mar 20 14:41:20.927: Se1/0/0:0 LCP: MagicNumber 0xD020DD82 (0x0506D020DD82)

*Mar 20 14:41:20.927: Se1/0/0:0 LCP: State is Open

*Mar 20 14:41:20.927: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by this end [0 sess, 0 load]

*Mar 20 14:41:20.927: Se1/0/0:0 CHAP: O CHALLENGE id 10 len 29 from "dynamite"

*Mar 20 14:41:20.943: Se1/0/0:0 CHAP: I RESPONSE id 10 len 26 from "cisco"

*Mar 20 14:41:20.943: Se1/0/0:0 CHAP: O SUCCESS id 10 len 4

*Mar 20 14:41:20.943: Se1/0/0:0 PPP: Phase is UP [0 sess, 0 load]

*Mar 20 14:41:20.943: Se1/0/0:0 IPCP: O CONFREQ [Closed] id 4 len 10

*Mar 20 14:41:20.943: Se1/0/0:0 IPCP: Address 10.48.74.125 (0x03060A304A7D)

*Mar 20 14:41:20.943: Se1/0/0:0 CCP: Compression already closed

*Mar 20 14:41:20.943: Se1/0/0:0 CCP: O CONFREQ [Closed] id 4 len 10

*Mar 20 14:41:20.943: Se1/0/0:0 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

*Mar 20 14:41:20.943: Se1/0/0:0 CDPCP: O CONFREQ [Closed] id 4 len 4

*Mar 20 14:41:20.951: Se1/0/0:0 IPCP: I CONFREQ [REQsent] id 17 len 16

*Mar 20 14:41:20.951: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 14:41:20.951: Se1/0/0:0 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 20 14:41:20.951: Se1/0/0:0 IPCP: Pool returned 192.168.100.1

*Mar 20 14:41:20.951: Se1/0/0:0 IPCP: O CONFREJ [REQsent] id 17 len 10

*Mar 20 14:41:20.951: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 14:41:20.951: Se1/0/0:0 CCP: I CONFREQ [REQsent] id 4 len 10

*Mar 20 14:41:20.951: Se1/0/0:0 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

*Mar 20 14:41:20.951: Se1/0/0:0 CCP: O CONFACK [REQsent] id 4 len 10

*Mar 20 14:41:20.951: Se1/0/0:0 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

*Mar 20 14:41:20.955: Se1/0/0:0 CDPCP: I CONFREQ [REQsent] id 14 len 4

*Mar 20 14:41:20.955: Se1/0/0:0 CDPCP: O CONFACK [REQsent] id 14 len 4

*Mar 20 14:41:20.955: Se1/0/0:0 IPCP: I CONFACK [REQsent] id 4 len 10

*Mar 20 14:41:20.955: Se1/0/0:0 IPCP: Address 10.48.74.125 (0x03060A304A7D)

*Mar 20 14:41:20.959: Se1/0/0:0 CCP: I CONFACK [ACKsent] id 4 len 10

*Mar 20 14:41:20.959: Se1/0/0:0 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

*Mar 20 14:41:20.959: Se1/0/0:0 CCP: State is Open

*Mar 20 14:41:20.959: Se1/0/0:0 CCP: ppp_hwcomp_open: no h/w

*Mar 20 14:41:20.959: Se1/0/0:0 CDPCP: I CONFACK [ACKsent] id 4 len 4

*Mar 20 14:41:20.959: Se1/0/0:0 CDPCP: State is Open

*Mar 20 14:41:20.963: Se1/0/0:0 IPCP: I CONFREQ [ACKrcvd] id 18 len 10

*Mar 20 14:41:20.963: Se1/0/0:0 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 20 14:41:20.963: Se1/0/0:0 IPCP: O CONFNAK [ACKrcvd] id 18 len 10

*Mar 20 14:41:20.963: Se1/0/0:0 IPCP: Address 192.168.100.1 (0x0306C0A86401)

*Mar 20 14:41:20.971: Se1/0/0:0 IPCP: I CONFREQ [ACKrcvd] id 19 len 10

*Mar 20 14:41:20.971: Se1/0/0:0 IPCP: Address 192.168.100.1 (0x0306C0A86401)

*Mar 20 14:41:20.971: Se1/0/0:0 IPCP: O CONFACK [ACKrcvd] id 19 len 10

*Mar 20 14:41:20.971: Se1/0/0:0 IPCP: Address 192.168.100.1 (0x0306C0A86401)

*Mar 20 14:41:20.971: Se1/0/0:0 IPCP: State is Open

*Mar 20 14:41:20.971: Di1 IPCP: Install route to 192.168.100.1

*Mar 20 14:41:20.975: %IP-4-DUPADDR: Duplicate address 10.48.74.125 on FastEthernet0/0/0, sourced by 0010.7be6.4498

dynamite#

======> CCP is open : see line 11

dynamite#sh int Se1/0/0:0

Serial1/0/0:0 is up, line protocol is up

Hardware is DS-E1

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, crc 16, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Time to interface disconnect: idle 00:01:47

LCP Open

Open: IPCP, CCP, CDPCP <================ CCP is opened

Last input 00:00:12, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:13:05

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

141 packets input, 3756 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

129 packets output, 3173 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

5 carrier transitions no alarm present

Timeslot(s) Used:1, subrate: 64Kb/s, transmit delay is 0 flags

dynamite#

==========> sh compress

dynamite#sh compress | b Serial1/0/0:0

Serial1/0/0:0

Software compression enabled

uncompressed bytes xmt/rcv 15440/16658

compressed bytes xmt/rcv 0/0

1 min avg ratio xmt/rcv 5.179/5.814

5 min avg ratio xmt/rcv 5.179/5.814

10 min avg ratio xmt/rcv 5.179/5.814

no bufs xmt 0 no bufs rcv 0

resyncs 0

---> after a ping from the client to the AS5800, we can see the counters increasing

dynamite#sh compress | b Serial1/0/0:0

Serial1/0/0:0

Software compression enabled

uncompressed bytes xmt/rcv 16242/17168

compressed bytes xmt/rcv 0/0

1 min avg ratio xmt/rcv 5.064/5.686

5 min avg ratio xmt/rcv 5.064/5.686

10 min avg ratio xmt/rcv 5.064/5.686

no bufs xmt 0 no bufs rcv 0

resyncs 0

==========> other way to check : by monitoring the numbers of output packets

dynamite#clear counters

Clear "show interface" counters on all interfaces [confirm]

---> first i check the ip address of the remote

dynamite#sh caller ip

Line User IP Address Local Number Remote Number <->

Se1/0/0:0 cisco 192.168.100.1 3 in

-----> then I ping the remote : 1 ping of 1000 bytes

dynamite#ping

Protocol [ip]:

Target IP address: 192.168.100.1

Repeat count [5]: 1

Datagram size [100]: 1000

Timeout in seconds [2]:

Extended commands [n]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 1, 1000-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:

!

Success rate is 100 percent (1/1), round-trip min/avg/max = 20/20/20 ms

----> then i check the counters : 6 packets output, 117 bytes

117 is less than 1000 bytes meaning that compression is active

dynamite#sh int Se1/0/0:0

Serial1/0/0:0 is up, line protocol is up

Hardware is DS-E1

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, crc 16, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Time to interface disconnect: idle 00:01:54

LCP Open

Open: IPCP, CCP, CDPCP

Last input 00:00:05, output 00:00:05, output hang never

Last clearing of "show interface" counters 00:00:21

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

5 packets input, 107 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

6 packets output, 117 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions no alarm present

Timeslot(s) Used:1, subrate: 64Kb/s, transmit delay is 0 flags

====> other way to check

with debug ppp packet

2) with ip tcp header-compression

interface Serial1/0/0:15

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

ip tcp header-compression passive

!

interface Dialer1

ip unnumbered FastEthernet0/0/0

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer-group 1

peer default ip address pool default

ppp authentication chap pap callin

end

dynamite#

====> In the debug below, you will not see amy compression negotiation

It makes sense since "ip tcp header compression" is not part of PPP

dynamite#

dynamite#

dynamite#

dynamite#

*Mar 20 15:12:50.531: ISDN Se1/0/0:15: RX <- SETUP pd = 8 callref = 0x0031

*Mar 20 15:12:50.531: Bearer Capability i = 0x8890

*Mar 20 15:12:50.531: Channel ID i = 0xA98381

*Mar 20 15:12:50.531: Called Party Number i = 0x81, '3', Plan:ISDN, Type:Unknown

*Mar 20 15:12:50.535: Se1/0/0:0 PPP: Treating connection as a callin

*Mar 20 15:12:50.535: Se1/0/0:0 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

*Mar 20 15:12:50.535: Se1/0/0:0 LCP: State is Listen

*Mar 20 15:12:50.535: ISDN Se1/0/0:15: TX -> CALL_PROC pd = 8 callref = 0x8031

*Mar 20 15:12:50.535: Channel ID i = 0xA98381

*Mar 20 15:12:50.535: ISDN Se1/0/0:15: TX -> CONNECT pd = 8 callref = 0x8031

*Mar 20 15:12:50.535: Channel ID i = 0xA98381

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: I CONFREQ [Listen] id 39 len 10

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: MagicNumber 0x15629511 (0x050615629511)

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: O CONFREQ [Listen] id 26 len 15

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: AuthProto CHAP (0x0305C22305)

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: MagicNumber 0xD03DB2F5 (0x0506D03DB2F5)

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: O CONFACK [Listen] id 39 len 10

*Mar 20 15:12:50.559: Se1/0/0:0 LCP: MagicNumber 0x15629511 (0x050615629511)

*Mar 20 15:12:50.559: ISDN Se1/0/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x0031

*Mar 20 15:12:50.559: ISDN Se1/0/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x10, bchan 0, dsl 0

*Mar 20 15:12:50.571: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 26 len 15

*Mar 20 15:12:50.571: Se1/0/0:0 LCP: AuthProto CHAP (0x0305C22305)

*Mar 20 15:12:50.571: Se1/0/0:0 LCP: MagicNumber 0xD03DB2F5 (0x0506D03DB2F5)

*Mar 20 15:12:50.571: Se1/0/0:0 LCP: State is Open

*Mar 20 15:12:50.571: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by this end [0 sess, 0 load]

*Mar 20 15:12:50.571: Se1/0/0:0 CHAP: O CHALLENGE id 16 len 29 from "dynamite"

*Mar 20 15:12:50.583: Se1/0/0:0 CHAP: I RESPONSE id 16 len 26 from "cisco"

*Mar 20 15:12:50.583: Se1/0/0:0 CHAP: O SUCCESS id 16 len 4

*Mar 20 15:12:50.583: Se1/0/0:0 PPP: Phase is UP [0 sess, 0 load]

*Mar 20 15:12:50.583: Se1/0/0:0 IPCP: O CONFREQ [Closed] id 10 len 16

*Mar 20 15:12:50.583: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 15:12:50.583: Se1/0/0:0 IPCP: Address 10.48.74.125 (0x03060A304A7D)

*Mar 20 15:12:50.583: Se1/0/0:0 CDPCP: O CONFREQ [Closed] id 10 len 4

*Mar 20 15:12:50.591: Se1/0/0:0 IPCP: I CONFREQ [REQsent] id 32 len 16

*Mar 20 15:12:50.591: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 15:12:50.591: Se1/0/0:0 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 20 15:12:50.591: Se1/0/0:0 IPCP: Pool returned 192.168.100.1

*Mar 20 15:12:50.591: Se1/0/0:0 IPCP: O CONFNAK [REQsent] id 32 len 10

*Mar 20 15:12:50.591: Se1/0/0:0 IPCP: Address 192.168.100.1 (0x0306C0A86401)

*Mar 20 15:12:50.595: Se1/0/0:0 CCP: I CONFREQ [Not negotiated] id 10 len 10

*Mar 20 15:12:50.595: Se1/0/0:0 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

*Mar 20 15:12:50.595: Se1/0/0:0 LCP: O PROTREJ [Open] id 27 len 16 protocol CCP (0x80FD010A000A120600000001)

*Mar 20 15:12:50.595: Se1/0/0:0 CDPCP: I CONFREQ [REQsent] id 20 len 4

*Mar 20 15:12:50.595: Se1/0/0:0 CDPCP: O CONFACK [REQsent] id 20 len 4

*Mar 20 15:12:50.599: Se1/0/0:0 IPCP: I CONFACK [REQsent] id 10 len 16

*Mar 20 15:12:50.599: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 15:12:50.599: Se1/0/0:0 IPCP: Address 10.48.74.125 (0x03060A304A7D)

*Mar 20 15:12:50.599: Se1/0/0:0 CDPCP: I CONFACK [ACKsent] id 10 len 4

*Mar 20 15:12:50.599: Se1/0/0:0 CDPCP: State is Open

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: I CONFREQ [ACKrcvd] id 33 len 16

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: Address 192.168.100.1 (0x0306C0A86401)

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: O CONFACK [ACKrcvd] id 33 len 16

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: Address 192.168.100.1 (0x0306C0A86401)

*Mar 20 15:12:50.603: Se1/0/0:0 IPCP: State is Open

*Mar 20 15:12:50.607: Di1 IPCP: Install route to 192.168.100.1

*Mar 20 15:12:50.611: %IP-4-DUPADDR: Duplicate address 10.48.74.125 on FastEthernet0/0/0, sourced by 0010.7be6.4498

dynamite#

dynamite#sh interfaces Se1/0/0:0

Serial1/0/0:0 is up, line protocol is up

Hardware is DS-E1

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, crc 16, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Time to interface disconnect: idle 00:01:43

LCP Open

Open: IPCP, CDPCP

Last input 00:00:16, output 00:00:04, output hang never

Last clearing of "show interface" counters 00:32:00

Input queue: 0/75/1/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

532 packets input, 31169 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

1 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored, 0 abort

495 packets output, 29275 bytes, 0 underruns

1 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

18 carrier transitions no alarm present

Timeslot(s) Used:1, subrate: 64Kb/s, transmit delay is 0 flags

dynamite#

==> you can check with

The counters are set to 0 because i ididn't generate any tcp traffic

dynamite# sh ip tcp header-compression | b Interface Serial1/0/0:0:

Interface Serial1/0/0:0: (passive, compression on)

Rcvd: 0 total, 0 compressed, 0 errors

0 dropped, 0 buffer copies, 0 buffer failures

Sent: 0 total, 0 compressed,

0 bytes saved, 0 bytes sent

Connect: 16 rx slots, 16 tx slots,

0 long searches, 0 misses 0 collisions, 0 negative cache hits

===> you can check with the counters as previously

===> you can check with debug ppp packets as well

376
Views
0
Helpful
2
Replies