Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Config AS5300 Pool asign with Radius

hello

i have an AS5300 with 3 T2 (N°1005;1006;1007)

the user don't have login and password (gsm data & RTC)

i want assign a different pool for each N°(pool_1005;pool_1006;pool_1007)

i have try 2 different conf but it is not work as i want:

CONF1:

aaa new-model

aaa authentication login default line

aaa authentication login NO_AUTHEN none

aaa authentication ppp default if-needed group radius

aaa authorization network default group radius

aaa accounting suppress null-username

aaa accounting delay-start

aaa accounting network default wait-start group radius

interface Group-Async1

ip unnumbered FastEthernet0

encapsulation ppp

no ip route-cache

ip tcp header-compression

no ip mroute-cache

async mode dedicated

peer match aaa-pools

peer default ip address pool pool_1005 pool_1006 pool_1007

no fair-queue

no cdp enable

ppp authentication chap

group-range 1 120

!

ip local pool pool_1005 172.20.2.100 172.20.2.120

ip local pool pool_1006 172.20.2.91 172.20.2.99

ip local pool pool_1007 172.20.2.71 172.20.2.90

but with this conf i may have a login on the mobile phone or computer

CONF2:

aaa new-model

aaa authentication login default line

aaa authentication login NO_AUTHEN none

aaa authentication ppp default group radius

aaa authorization network default group radius none

aaa accounting delay-start

aaa accounting network default wait-start group radius

aaa preauth

dnis

aaa configuration config-username AS5300

interface Group-Async1

ip unnumbered FastEthernet0

encapsulation ppp

no ip route-cache

ip tcp header-compression

no ip mroute-cache

async mode dedicated

peer match aaa-pools

peer default ip address pool pool_1005 pool_1006 pool_1007

no fair-queue

no cdp enable

group-range 1 120

!

ip local pool pool_1005 172.20.2.100 172.20.2.120

ip local pool pool_1006 172.20.2.91 172.20.2.99

ip local pool pool_1007 172.20.2.71 172.20.2.90

or pool dinamic send by the radius

but the only poool use is the first and the name of the pool send by radius in preauth is not use

if anyone had ever do that or had a idee!!!!

thanks

4 REPLIES
Silver

Re: Config AS5300 Pool asign with Radius

This can be achived using Modem pooling provided the DNIS (called number) is different for the 3 groups of users.

modem-pool pool_1005

pool-range 1-40

called-number 12345<===the DNIS

modem-pool pool_1006

pool-range 41-80

called-number 54321

modem-pool pool_1007

pool-range 81-120

called-number 98765

interface Group-Async1

peer default ip address pool pool_1005

group-range 1 40

interface Group-Async2

peer default ip address pool pool_1006

group-range 41 80

interface Group-Async3

peer default ip address pool pool_1007

group-range 81 120

Pls refer the below URLs:

http://www.cisco.com/warp/public/793/access_dial/cas_dnis_mpooling.html

http://www.cisco.com/warp/public/793/access_dial/pri_dnis_mpool.html

Thanks, Mak.

Cisco Employee

Re: Config AS5300 Pool asign with Radius

Just to add..modem poling is only possible if the DNIS number is delivered from telco to AS5300 when the call is received on AS5300.

You need to configure exact number of digits received as DNIS in modem pool config, otherwise call will fail.

If DNIS number is not delivered, you need to talk to telco to have them configure T1 lines for that.

New Member

Re: Config AS5300 Pool asign with Radius

thanks but with this conf

i may not have dynamicaly more than 40 modem for each T1

Silver

Re: Config AS5300 Pool asign with Radius

Even if the T1 is fully utilized for analog calls, we will not need more than 23 (PRI) or 24 (CAS) modems out of the pool at one given time....the modems in a particular pool will be used on round robin basis.

Thanks, Mak.

208
Views
0
Helpful
4
Replies